Skip to content
Browse files

[DOC] Update README

  • Loading branch information...
1 parent edd0c9f commit f42ee60e26708edb113ab30eb6b940f0ef41caef @benlangfeld committed Sep 30, 2013
Showing with 11 additions and 2 deletions.
  1. +11 −2 README.md
View
13 README.md
@@ -137,7 +137,7 @@ which becomes
#### Built-in grammars
-There are some grammars pre-defined which are available from the `RubySpeech::GRXML::Builtins` module like so.
+There are some grammars pre-defined which are available from the `RubySpeech::GRXML::Builtins` module like so:
```ruby
require 'ruby_speech'
@@ -174,7 +174,16 @@ which yields
</rule>
</grammar>
```
-These grammars can be used just like any you would manually create, and there's nothing special about them except that they are already defined for you.
+
+These grammars come from the VoiceXML specification, and can be used as indicated there (including parameterisation). They can be used just like any you would manually create, and there's nothing special about them except that they are already defined for you. A full list of available grammars can be found in [the API documentation](http://rubydoc.info/gems/ruby_speech/RubySpeech/GRXML/Builtins).
+
+These grammars are also available via URI like so:
+
+```ruby
+require 'ruby_speech'
+
+RubySpeech::GRXML.from_uri('builtin:dtmf/boolean?y=3;n=4')
+```
#### Grammar matching

0 comments on commit f42ee60

Please sign in to comment.
Something went wrong with that request. Please try again.