Permalink
Browse files

Remove pypy3 from Travis

The new version of pip won't support Python 3.2
and we will need to tweak our .travis.yml and
tox.ini in order to run tests on PyPy 3.

However, since we already removed Python 3.2
from Travis, I decided to remove PyPy 3 as well
(it still targets Python 3.2)
  • Loading branch information...
1 parent ea74185 commit ca64a57c77a543bb4cfcd317eb3825edf78187a0 @berkerpeksag berkerpeksag committed Nov 22, 2016
Showing with 2 additions and 3 deletions.
  1. +0 −1 .travis.yml
  2. +2 −2 tox.ini
View
@@ -7,7 +7,6 @@ env:
- TOXENV=py34
- TOXENV=py35
- TOXENV=pypy
- - TOXENV=pypy3
install: pip install tox
script: tox
cache:
View
@@ -1,5 +1,5 @@
[tox]
-envlist = py26, py27, py34, py35, pypy, pypy3
+envlist = py26, py27, py34, py35, pypy
skipsdist = True
[testenv]
@@ -8,5 +8,5 @@ commands = py.test {posargs:tests/} --assert=plain
deps =
-rrequirements_test.txt
py26: unittest2
- py2{6,7},pypy,py32,pypy3: mock
+ py2{6,7},pypy: mock
py3{3,4}: aiohttp

0 comments on commit ca64a57

Please sign in to comment.