Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Updated to a version of passenger that doesn't yet exist (waiting for…

… master to be updated) and rearranged recommended packages to be installed straight up
  • Loading branch information...
commit 0207055fc69242505abf17a0d98c79c69117d81f 1 parent 77e5c6f
@benschwarz authored
Showing with 3 additions and 5 deletions.
  1. +3 −5 config/stack/apache.rb
View
8 config/stack/apache.rb
@@ -9,6 +9,7 @@
end
requires :build_essential
+ recommends :apache_etag_support, :apache_deflate_support, :apache_expires_support
end
package :apache2_prefork_dev do
@@ -18,8 +19,8 @@
package :passenger, :provides => :appserver do
description 'Phusion Passenger (mod_rails)'
- version '2.1.3'
- gem 'passenger' do
+ version '2.2.1'
+ gem 'passenger', :version => version do
post :install, 'echo -en "\n\n\n\n" | sudo passenger-install-apache2-module'
# Create the passenger conf file
@@ -60,7 +61,6 @@
push_text config, apache_conf, :sudo => true
verify { file_contains apache_conf, "Passenger-stack-etags"}
- requires :apache
end
# mod_deflate, compress scripts before serving.
@@ -80,7 +80,6 @@
push_text config, apache_conf, :sudo => true
verify { file_contains apache_conf, "Passenger-stack-deflate"}
- requires :apache
end
# mod_expires, add long expiry headers to css, js and image files
@@ -99,5 +98,4 @@
push_text config, apache_conf, :sudo => true
verify { file_contains apache_conf, "Passenger-stack-expires"}
- requires :apache
end
Please sign in to comment.
Something went wrong with that request. Please try again.