Permalink
Browse files

use passenger 2.2.9 and ree 1.8.7-2010.01

  • Loading branch information...
1 parent bad5223 commit f81ad258c0ea273559f24f56a682441fe09b8eba @ashchan ashchan committed Jan 23, 2010
Showing with 10 additions and 8 deletions.
  1. +7 −5 config/install.rb
  2. +1 −1 config/stack/nginx.rb
  3. +2 −2 config/stack/ruby_enterprise.rb
View
12 config/install.rb
@@ -1,7 +1,9 @@
$:<< File.join(File.dirname(__FILE__), 'stack')
# Require the stack base
-%w(essential scm ruby_enterprise memcached postgresql mysql).each(&method(:require))
+%w(essential scm ruby_enterprise memcached postgresql mysql).each do |lib|
+ require lib
+end
# ===============
# = Web servers =
@@ -13,8 +15,8 @@
# These are enabled by default when you choose Apache, you can remove these dependencies within
# stack/apache.rb
-require 'apache'
-#require 'nginx'
+#require 'apache'
+require 'nginx'
# What we're installing to your server
# Take what you want, leave what you don't
@@ -23,8 +25,8 @@
requires :webserver # Apache or Nginx
requires :appserver # Passenger
requires :ruby_enterprise # Ruby Enterprise edition
- #requires :database # MySQL or Postgres, also installs rubygems for each
- #requires :scm # Git
+ requires :database # MySQL or Postgres, also installs rubygems for each
+ requires :scm # Git
#requires :memcached # Memcached
#requires :libmemcached # Libmemcached
end
View
2 config/stack/nginx.rb
@@ -26,7 +26,7 @@
package :passenger, :provides => :appserver do
description 'Phusion Passenger (mod_rails)'
- version '2.2.2'
+ version '2.2.9'
binaries = %w(passenger-config passenger-install-nginx-module passenger-install-apache2-module passenger-make-enterprisey passenger-memory-stats passenger-spawn-server passenger-status passenger-stress-test)
gem 'passenger', :version => version do
View
4 config/stack/ruby_enterprise.rb
@@ -1,10 +1,10 @@
package :ruby_enterprise do
description 'Ruby Enterprise Edition'
- version '1.8.6-20090421'
+ version '1.8.7-2010.01'
REE_PATH = "/usr/local/ruby-enterprise"
binaries = %w(erb gem irb rackup rails rake rdoc ree-version ri ruby testrb)
- source "http://rubyforge.org/frs/download.php/55511/ruby-enterprise-#{version}.tar.gz" do
+ source "http://rubyforge.org/frs/download.php/68719/ruby-enterprise-#{version}.tar.gz" do
custom_install 'sudo ./installer --auto=/usr/local/ruby-enterprise'
binaries.each {|bin| post :install, "ln -s #{REE_PATH}/bin/#{bin} /usr/local/bin/#{bin}" }
end

0 comments on commit f81ad25

Please sign in to comment.