Skip to content
Permalink
Browse files

Fix issue with sqlalchemy version <= 1.3.0 (#311)

* add dependency constraint "sqlalchemy>=1.3.0"

* fix error message
  • Loading branch information...
parano committed Sep 25, 2019
1 parent 804f804 commit bdf2e822aacbbf038ba87ba79c68e7be6047f2f2
Showing with 4 additions and 3 deletions.
  1. +3 −2 bentoml/yatai/python_api.py
  2. +1 −1 setup.py
@@ -70,8 +70,9 @@ def upload_bento_service(bento_service, base_path=None, version=None):

if response.status.status_code != Status.OK:
raise BentoMLException(
"Error adding bento to repository: %s:%s" % response.status.status_code,
response.status.error_message,
"Error adding bento to repository: {}:{}".format(
response.status.status_code, response.status.error_message
)
)

if response.uri.type == BentoUri.LOCAL:
@@ -35,7 +35,7 @@
"packaging",
"docker",
"configparser",
"sqlalchemy",
"sqlalchemy>=1.3.0",
"protobuf>=3.6.0",
"grpcio",
"cerberus",

0 comments on commit bdf2e82

Please sign in to comment.
You can’t perform that action at this time.