Permalink
Browse files

upgraded HttpClient and Groovy

This will break Grails 1.3.x compatibility but I think it's time to move on.
  • Loading branch information...
1 parent 9119185 commit f6def5055002030b15535b6b28b28c32950315d9 Rob Fletcher committed Oct 24, 2012
Showing with 4 additions and 3 deletions.
  1. +4 −3 build.gradle
View
@@ -19,22 +19,23 @@ archivesBaseName = 'betamax'
repositories {
mavenCentral()
+ mavenRepo url: 'http://repository.codehaus.org'
}
dependencies {
- groovy 'org.codehaus.groovy:groovy-all:1.7.8'
+ groovy 'org.codehaus.groovy:groovy-all:1.8.8'
compile 'junit:junit:4.8.2',
'org.yaml:snakeyaml:1.10',
'org.apache.httpcomponents:httpclient:4.2.1',
'commons-lang:commons-lang:2.4',
'org.eclipse.jetty:jetty-server:7.3.1.v20110307'
- testCompile('org.codehaus.groovy.modules.http-builder:http-builder:0.5.2') {
+ testCompile('org.codehaus.groovy.modules.http-builder:http-builder:0.6') {
exclude module: 'groovy'
exclude module: 'httpclient'
}
- testCompile('org.spockframework:spock-core:0.6-groovy-1.7') {
+ testCompile('org.spockframework:spock-core:0.6-groovy-1.8') {
exclude module: 'groovy-all'
exclude module: 'junit-dep'
}

0 comments on commit f6def50

Please sign in to comment.