Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

v1.5.6. Bugfix.

  • Loading branch information...
commit 5d70ede8c50844ac4a502593b3c040c143cc63c0 1 parent f09e8aa
@balupton balupton authored
View
3  History.md
@@ -1,5 +1,8 @@
# History
+- v1.5.6 November 29, 2013
+ - Fixed browserify support
+
- v1.5.5 November 17, 2013
- Added support for querying nested models and collections
View
7 package.json
@@ -1,7 +1,7 @@
{
"title": "Query-Engine",
"name": "query-engine",
- "version": "1.5.5",
+ "version": "1.5.6",
"description": "Query-Engine is a NoSQL and MongoDb compliant query engine. It can run on the server-side with Node.js, or on the client-side within web browsers",
"homepage": "https://github.com/bevry/query-engine",
"license": {
@@ -49,8 +49,7 @@
"type": "git",
"url": "http://github.com/bevry/query-engine.git"
},
- "dependencies": {
- },
+ "dependencies": {},
"peerDependencies": {},
"devDependencies": {
"exoskeleton": "~0.5.1",
@@ -73,4 +72,4 @@
"test": "node ./out/test/everything-test.js"
},
"main": "./out/lib/query-engine.js"
-}
+}
View
2  src/documents/lib/query-engine.js.coffee
@@ -1,5 +1,5 @@
# Requires
-Backbone = @Backbone or (try require?('backbone')) or (try require?('exoskeleton')) or null
+Backbone = @Backbone or window?.Backbone or (try require?('backbone')) or (try require?('exoskeleton')) or null
# Util
# Contains our utility functions

0 comments on commit 5d70ede

Please sign in to comment.
Something went wrong with that request. Please try again.