Skip to content
Browse files

Updated the limitations to reflect the incompatibility with Ruby 1.9 …

…and updated the tested platforms.
  • Loading branch information...
1 parent 1dfda9d commit b6d82e23376c178c371480e41cf4857d1057751c @flebel flebel committed
Showing with 9 additions and 4 deletions.
  1. +2 −1 README
  2. +4 −1 README.html
  3. +3 −2 downloadGoogleContacts.rb
View
3 README
@@ -59,10 +59,11 @@ Chad Albers
The script does not depend on any third-party Ruby code outside of
Ruby's Core and Standard Libraries. It has been tested successfully on
- Ruby 1.8.7 (on Debian GNU/Linux).
+ Ruby 1.8.7 (on Debian GNU/Linux and FreeBSD).
5. Limitations
+ * Ruby: The script is not compatible with Ruby 1.9.
* OpenSSL: The script makes no attempt to verify the certificate used
to encrypt the transmission between sending login information and
Google's website. Ruby's https class can perform this verification,
View
5 README.html
@@ -130,7 +130,7 @@ <h2 class="title" style="clear: both"><a id="id2497132"></a>4. Script Requireme
</div>
</div>
</div>
- <p>The script does not depend on any third-party Ruby code outside of Ruby's Core and Standard Libraries. It has been tested successfully on Ruby 1.8.7 (on Debian GNU/Linux). </p>
+ <p>The script does not depend on any third-party Ruby code outside of Ruby's Core and Standard Libraries. It has been tested successfully on Ruby 1.8.7 (on Debian GNU/Linux and FreeBSD). </p>
</div>
<div class="sect1" lang="en-US" xml:lang="en-US">
<div class="titlepage">
@@ -143,6 +143,9 @@ <h2 class="title" style="clear: both"><a id="id2497143"></a>5. Limitations</h2>
<div class="itemizedlist">
<ul type="disc">
<li>
+ <p><span class="emphasis"><em>Ruby: </em></span>The script is not compatible with Ruby 1.9.</p>
+ </li>
+ <li>
<p><span class="emphasis"><em>OpenSSL: </em></span>The script makes no attempt to verify the certificate used to encrypt the transmission between sending login information and Google's website. Ruby's https class can perform this verification, but the script intentionally disables it - using OpenSSL::SSL::VERIFY_NONE. To perform the verification, the script would need to include the certificate from Googles' CA. This feature can be enabled by following the instructions posted on <a class="ulink" href="http://redcorundum.blogspot.com/2008/03/ssl-certificates-and-nethttps.html" target="_top">this web page</a>.</p>
</li>
<li>
View
5 downloadGoogleContacts.rb
@@ -70,10 +70,11 @@
# NOTES
# Script Requirements:
# The script does not depend on any third-party Ruby code
-# outside of Ruby's Core and Standard Libraries. It was been testing
-# successfully on Ruby 1.8.7 (on Debian GNU/Linux).
+# outside of Ruby's Core and Standard Libraries. It was been tested
+# successfully on Ruby 1.8.7 (Debian GNU/Linux and FreeBSD).
#
# Limitations:
+# Ruby: The script is not compatible with Ruby 1.9.
# OpenSSL: The script makes no attempt to verify the certificate used to
# encrypt the transmission between sending login information and google's
# website. Ruby's https class can perform this verification,

0 comments on commit b6d82e2

Please sign in to comment.
Something went wrong with that request. Please try again.