Skip to content
This repository contains compatibility data for Web technologies as displayed on MDN
Branch: master
Clone or download
Pull request Compare This branch is 81 commits behind mdn:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
.github
.vscode
api
browsers
css
docs
html
http
javascript
mathml/elements
schemas
scripts
svg
test
webdriver/commands
webextensions
xpath/axes
xslt
.editorconfig
.gitattributes
.gitignore
.npmignore
.travis.yml
CODE_OF_CONDUCT.md
GOVERNANCE.md
LICENSE
README.md
index.d.ts
index.js
package-lock.json
package.json
types.d.ts

README.md

mdn-browser-compat-data

https://github.com/mdn/browser-compat-data

This repository contains compatibility data for Web technologies. Browser compatibility data describes which platforms (where "platforms" are usually, but not always, web browsers) support particular Web APIs.

This data can be used in documentation, to build compatibility tables listing browser support for APIs. For example: Browser support for WebExtension APIs.

npm Build Status Twitter Follow

Read how this project is governed.

Installation

You can install mdn-browser-compat-data as a node package.

npm install mdn-browser-compat-data

Usage

const bcd = require('mdn-browser-compat-data');
bcd.css.properties.background;
// returns a compat data object (see schema)

Repository contents

There's a top-level directory for each broad area covered: for example, "http", "javascript", "webextensions". Inside each of these directories is one or more JSON file containing the compatibility data.

Please note that we have not (yet) migrated all compatibility data from the MDN wiki pages into this repository.

  • api/ contains data for each Web API interface.

  • css/ contains data for CSS properties, selectors, and at-rules.

  • html/ contains data for HTML elements, attributes, and global attributes.

  • http/ contains data for HTTP headers, statuses, and methods.

  • javascript/ contains data for JavaScript built-in Objects, statement, operators, and other ECMAScript language features.

  • mathml/ contains data for MathML elements, attributes, and global attributes.

  • svg/ contains data for SVG elements, attributes, and global attributes.

  • webdriver/ contains data for WebDriver commands.

  • webextensions/ contains data for WebExtensions JavaScript APIs and manifest keys.

  • xpath/ contains data for XPath axes, and functions.

  • xslt/ contains data for XSLT elements, attributes, and global attributes.

Format of the browser compat json files

The definitive description of the format used to represent compatibility data is the schema file. You can also have a look at the schema documentation.

Please note that we do not (yet) guarantee the stability of the data format. You're welcome to use the data, but its structure is subject to change without notice.

Issues?

If you find a problem, please file a bug.

Contributing

We're very happy to accept contributions to this data. See Contributing to browser-compat-data for more information.

Projects using the data

Here are some projects using the data, as an npm module or directly:

  • Add-ons Linter - the Add-ons Linter is used on addons.mozilla.org and the web-ext tool. It uses browser-compat-data to check that the Firefox version that the add-on lists support for does in fact support the APIs used by the add-on.
  • Browser Compatibility Data Explorer - View, search, and visualize data from the compatibility dataset.
  • Compat Report - Firefox Add-on that shows compatibility data for the current site in the developer tools.
  • compat-tester - Scan local documents for compatibility issues.
  • Visual Studio Code - Shows the compatibility information in the code completion popup.
  • webhint.io - Hints to check if your CSS HTML and JavaScript have deprecated or not broadly supported features.
  • WebStorm - JavaScript IDE allowing you to check whether all CSS properties you use are supported in the target browser version.
You can’t perform that action at this time.