Permalink
Browse files

some 1.8 code throws a SyntaxError on 1.9

  • Loading branch information...
1 parent 822b116 commit cb0f0263d40740ccbf96d95a14de55c3fa571304 @rkh rkh committed Aug 18, 2011
Showing with 1 addition and 1 deletion.
  1. +1 −1 README.md
View
@@ -47,7 +47,7 @@ visibility, etc). This requires an annotation syntax, which of course will lead
wars. So I'll be including the syntax *I* would like, as well as a parser for YARD-style
annotations.
**6. Ruby 1.9+ only** - Yep, LASER will only run on Ruby 1.9, and it'll expect its target
-code is Ruby 1.9. Of course, since any 1.8 code will still parse just fine, the only issues
+code is Ruby 1.9. Of course, since almost any 1.8 code will still parse just fine, the only issues
that will come up is API differences (looking at you, `String`).
**7. Reusable Semantic Information** - I don't want a new AST format. I don't like the one
provided by RubyParser and co. So I'm sticking with Ripper's AST format. It has quirks, but

0 comments on commit cb0f026

Please sign in to comment.