Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Stopped using Jeweler

  • Loading branch information...
commit e81bdf2107c8b313907c919557e1b9c8eb24d265 1 parent 8cdb958
@bhb authored
View
6 .gitignore
@@ -3,4 +3,8 @@
coverage
rdoc
pkg
-.rvmrc
+.rvmrc
+*.gem
+.bundle
+Gemfile.lock
+pkg/*
View
3  Gemfile
@@ -0,0 +1,3 @@
+source "http://rubygems.org"
+
+gemspec
View
63 Rakefile
@@ -1,62 +1 @@
-require 'rubygems'
-require 'rake'
-
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |gem|
- gem.name = 'rack-perftools_profiler'
- gem.summary = %Q{Middleware for profiling Rack-compatible apps using perftools.rb}
- gem.description = %Q{Middleware for profiling Rack-compatible apps using perftools.rb}
- gem.email = 'ben@bbrinck.com'
- gem.homepage = 'http://github.com/bhb/rack-perftools_profiler'
- gem.authors = ['Ben Brinckerhoff']
- gem.add_dependency 'perftools.rb', '~> 0.5.6'
- gem.add_dependency 'rack', '~> 1.0'
- gem.add_dependency('open4', '~> 1.0')
- gem.add_development_dependency 'rack', '~> 1.1'
- gem.add_development_dependency 'shoulda', '~> 2.10'
- gem.add_development_dependency 'mocha', '~> 0.9'
- # gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
- end
- Jeweler::GemcutterTasks.new
-rescue LoadError
- puts "Jeweler (or a dependency) not available. Install it with: sudo gem install jeweler"
-end
-
-require 'rake/testtask'
-Rake::TestTask.new(:test) do |test|
- test.libs << 'lib' << 'test'
- test.pattern = 'test/**/*_test.rb'
- test.verbose = true
-end
-
-begin
- require 'rcov/rcovtask'
- Rcov::RcovTask.new do |test|
- test.libs << 'test'
- test.pattern = 'test/**/*_test.rb'
- test.verbose = true
- end
-rescue LoadError
- task :rcov do
- abort "RCov is not available. In order to run rcov, you must: sudo gem install spicycode-rcov"
- end
-end
-
-task :test => :check_dependencies
-
-task :default => :test
-
-require 'rake/rdoctask'
-Rake::RDocTask.new do |rdoc|
- if File.exist?('VERSION')
- version = File.read('VERSION')
- else
- version = ""
- end
-
- rdoc.rdoc_dir = 'rdoc'
- rdoc.title = "rack-perftools_profiler #{version}"
- rdoc.rdoc_files.include('README*')
- rdoc.rdoc_files.include('lib/**/*.rb')
-end
+require "bundler/gem_tasks"
View
5 lib/rack/perftools_profiler/version.rb
@@ -0,0 +1,5 @@
+module Rack
+ module PerftoolsProfiler
+ VERSION = "0.5.0"
+ end
+end
View
98 rack-perftools_profiler.gemspec
@@ -1,76 +1,40 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
+require "rack/perftools_profiler/version"
Gem::Specification.new do |s|
- s.name = %q{rack-perftools_profiler}
- s.version = "0.5.0"
-
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Ben Brinckerhoff"]
- s.date = %q{2011-07-25}
+ s.name = "rack-perftools_profiler"
+ s.version = Rack::PerftoolsProfiler::VERSION
+ s.authors = ["Ben Brinckerhoff"]
+ s.email = ["ben@bbrinck.com"]
+ s.homepage = "http://github.com/bhb/rack-perftools_profiler"
+ s.summary = %q{Middleware for profiling Rack-compatible apps using perftools.rb}
s.description = %q{Middleware for profiling Rack-compatible apps using perftools.rb}
- s.email = %q{ben@bbrinck.com}
- s.extra_rdoc_files = [
- "LICENSE",
- "README.rdoc"
- ]
- s.files = [
- ".document",
- "LICENSE",
- "README.rdoc",
- "Rakefile",
- "VERSION",
- "lib/rack/perftools_profiler.rb",
- "lib/rack/perftools_profiler/action.rb",
- "lib/rack/perftools_profiler/call_app_directly.rb",
- "lib/rack/perftools_profiler/profile_data_action.rb",
- "lib/rack/perftools_profiler/profile_once.rb",
- "lib/rack/perftools_profiler/profiler.rb",
- "lib/rack/perftools_profiler/profiler_middleware.rb",
- "lib/rack/perftools_profiler/return_data.rb",
- "lib/rack/perftools_profiler/return_password_error.rb",
- "lib/rack/perftools_profiler/start_profiling.rb",
- "lib/rack/perftools_profiler/stop_profiling.rb",
- "lib/rack/perftools_profiler/utils.rb",
- "rack-perftools_profiler-0.4.1.gem",
- "rack-perftools_profiler.gemspec",
- "test/multiple_request_profiling_test.rb",
- "test/rack-perftools-profiler_test.rb",
- "test/single_request_profiling_test.rb",
- "test/test_helper.rb"
- ]
- s.homepage = %q{http://github.com/bhb/rack-perftools_profiler}
+
+ s.rubyforge_project = "rack-perftools_profiler"
+
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
s.require_paths = ["lib"]
- s.rubygems_version = %q{1.6.2}
- s.summary = %q{Middleware for profiling Rack-compatible apps using perftools.rb}
- if s.respond_to? :specification_version then
- s.specification_version = 3
+ # specify any dependencies here; for example:
+ # s.add_development_dependency "rspec"
+ # s.add_runtime_dependency "rest-client"
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<perftools.rb>, ["~> 0.5.6"])
- s.add_runtime_dependency(%q<rack>, ["~> 1.0"])
- s.add_runtime_dependency(%q<open4>, ["~> 1.0"])
- s.add_development_dependency(%q<rack>, ["~> 1.1"])
- s.add_development_dependency(%q<shoulda>, ["~> 2.10"])
- s.add_development_dependency(%q<mocha>, ["~> 0.9"])
- else
- s.add_dependency(%q<perftools.rb>, ["~> 0.5.6"])
- s.add_dependency(%q<rack>, ["~> 1.0"])
- s.add_dependency(%q<open4>, ["~> 1.0"])
- s.add_dependency(%q<rack>, ["~> 1.1"])
- s.add_dependency(%q<shoulda>, ["~> 2.10"])
- s.add_dependency(%q<mocha>, ["~> 0.9"])
- end
- else
- s.add_dependency(%q<perftools.rb>, ["~> 0.5.6"])
- s.add_dependency(%q<rack>, ["~> 1.0"])
- s.add_dependency(%q<open4>, ["~> 1.0"])
- s.add_dependency(%q<rack>, ["~> 1.1"])
- s.add_dependency(%q<shoulda>, ["~> 2.10"])
- s.add_dependency(%q<mocha>, ["~> 0.9"])
+ s.add_dependency 'perftools.rb', '~> 0.5.6'
+ s.add_dependency 'rack', '~> 1.0'
+ s.add_dependency('open4', '~> 1.0')
+ s.add_development_dependency 'rack', '~> 1.1'
+ s.add_development_dependency 'shoulda', '~> 2.10'
+ s.add_development_dependency 'mocha', '~> 0.9'
+ s.add_development_dependency 'rake', '~> 0.9.2'
+
+ require 'rake/testtask'
+ Rake::TestTask.new(:test) do |test|
+ test.libs << 'lib' << 'test'
+ test.pattern = 'test/**/*_test.rb'
+ test.verbose = true
end
-end
+end
Please sign in to comment.
Something went wrong with that request. Please try again.