Update perftools.rb dependency to allow 2.0.0 #17

Closed
cboone opened this Issue Mar 19, 2012 · 3 comments

Comments

Projects
None yet
3 participants

cboone commented Mar 19, 2012

Currently, rack-perftools_profiler.gemspec has a dependency of ~> 0.5.6 for perftools.rb. But that version doesn’t work with Ruby 1.9.3. perftools version 2.0.0 does work with 1.9.3 and also seems to work fine with rack-perftools_profiler.

Would you mind updating the dependency to allow using perftools.rb 2.0.0?

Thanks,
Chris

I am also running into this issue, not even on ruby 1.9.3, but because for some reason by 0.5.6 doesn't compile on my new Ubuntu 11.10 box without a patch to google-perftools-1.6 (http://code.google.com/p/gperftools/issues/detail?id=300) to include stddef.h (some different libc version or something) If 0.5.6 used google-perftools-1.7 it might work, but whatever. If perftools version 2.0.0 works fine can we just use that?

evanbattaglia pushed a commit to evanbattaglia/rack-perftools_profiler that referenced this issue Mar 21, 2012

Owner

bhb commented Mar 26, 2012

Thanks for the report. Sorry for the delay - was out of town most of last week. Just updated the dependency to 2.0.0 for version 0.6.0 of rack-perftools_profiler. Let me know if you run into any issues!

@bhb bhb closed this Mar 26, 2012

cboone commented Mar 29, 2012

Great, thanks for updating it. Much appreciated.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment