Charset in <pre> tags #79

Closed
Karmac opened this Issue Mar 25, 2013 · 12 comments

Comments

3 participants

Karmac commented Mar 25, 2013

As I write posts in Spanish using Jekyll, I must use special characters like á é í ó ú…
They work in normal paragraph, but they don't show correctly inside <pre> tags.

I attach a pic of the problem. Thanks for your help.

Captura de pantalla 2013-03-25 a la s 23 59 25

PS: they're not working neither in the automatic ids assigned to headings.

Captura de pantalla 2013-03-26 a la s 00 00 19

Owner

bhollis commented Mar 26, 2013

Hi @Karmac,

I think I've fixed both issues in the Git version (I haven't released it yet) - could you try it out and let me know?

Karmac commented Mar 26, 2013

Sorry to be so newbie, but where could I find that version to download it?

Owner

bhollis commented Mar 26, 2013

In your Gemfile, add this line:

gem 'maruku', :git => 'http://github.com/bhollis/maruku'

Karmac commented Mar 26, 2013

I downloaded the git version and found out that I was using that version before, as I did update my maruku version yesterday with the contents of this repo.

It keeps not working.

Karmac commented Mar 26, 2013

OK problems with pre tags are fixed in v0.6.1, but I'm still having problems with id's on v0.6.1.
New Git version has both errors.

Owner

bhollis commented Mar 26, 2013

The ID generation behavior is intentional - it matches other Markdown implementations by dripping non-ASCII characters.

@bhollis bhollis closed this Mar 26, 2013

@bhollis bhollis reopened this Mar 26, 2013

Owner

bhollis commented Mar 26, 2013

Wait, you said the latest from git also has problems with pre tags? I'll write a test.

Karmac commented Mar 26, 2013

Yes, it does.
Thanks for your help, I really appreciate.

bhollis added a commit that referenced this issue Mar 27, 2013

Owner

bhollis commented Mar 27, 2013

OK, I've verified the problem and have added a failing spec. This is targeted to be fixed in the next release.

As a workaround, consider using indented code block instead of raw <pre> tags - they correctly preserve your text.

Karmac commented Mar 27, 2013

OK, I'll try.
Thanks.

Collaborator

distler commented May 23, 2013

For whatever it's worth, this was fixed here.

Collaborator

distler commented May 27, 2013

Fix is now on trunk.

@distler distler closed this May 27, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment