Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Can't get any data from the api #38

Closed
SebastianSzturo opened this Issue · 4 comments

4 participants

@SebastianSzturo

The version from rubygems gives me this error:

{"error":"Nothing to parse. Possibly no data?"}`

But the gem from github is also not working for me:

gem 'bigcommerce', :git => "https://github.com/bigcommerce/bigcommerce-api-ruby.git"
api = Bigcommerce::Api.new({
        ...
    })

puts api.get_product(3)

.rvm/gems/ruby-1.9.3-p392/bundler/gems/bigcommerce-api-ruby-11b7895a55d5/lib/bigcommerce/connection.rb:82:in `rescue in request': Failed to parse Bigcommerce response: 404 Resource Not Found

The api key should be right, it's working fine in php.

Any idea what I'm doing wrong? :goat:

@proletarian

Can you get anything back from get_products(), or get_options()? I'm seeing the same response but only when trying to create a optionset option.

@SebastianSzturo

Same response for get_products and get_options.

.rvm/gems/ruby-2.0.0-p0/bundler/gems/bigcommerce-api-ruby-11b7895a55d5/lib/bigcommerce/connection.rb:82:in `rescue in request': Failed to parse Bigcommerce response: 404 Resource Not Found: <!DOCTYPE html PUBLIC...

...and it prints the html of my webshop.

@maetl

Given that you’re seeing 404 errors, it looks like the configured URL might have some additional segment paths.

0.8.0 requires the store_url to be provided without an additional segment path.

I just tested the following:

api.store_url = "https://mystore.mybigcommerce.com" # works
api.store_url = "https://mystore.mybigcommerce.com/" # broken
api.store_url = "https://mystore.mybigcommerce.com/api/v2" # broken

#39 fixes this, so that any given URL added will resolve to the same base path (it should do the right thing by default, rather than force people using the library to work around such details).

This change should be out in 0.8.1 on Rubygems shortly.

Thanks very much for your feedback.

@SebastianSzturo

Everything is working fine now. Thank you very much!

@propellerinc propellerinc referenced this issue in bigcommerce/bigcommerce-api-php
Closed

API Connection issue #12

@pedelman pedelman added v0.x question and removed v0.x labels
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.