New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

adam-cli POM invalid: maven.build.timestamp #1004

Closed
ryan-williams opened this Issue Apr 20, 2016 · 11 comments

Comments

Projects
None yet
3 participants
@ryan-williams
Member

ryan-williams commented Apr 20, 2016

Guacamole (which depends on ADAM) is showing an error parsing the adam-cli POM; here is debug output from running mvn -X package there:

[WARNING] Invalid POM for org.bdgenomics.adam:adam-cli_2.10:jar:0.19.0, transitive dependencies (if any) will not be available, enable debug logging for more details: Some problems were encountered while processing the POMs:
[ERROR] Resolving expression: '${maven.build.timestamp}': Detected the following recursive expression cycle in 'maven.build.timestamp': [maven.build.timestamp] @

This line seems to be the culprit.

Anyone have context on why it's there / what it's supposed to be doing?

@ryan-williams ryan-williams added the bug label Apr 20, 2016

@fnothaft

This comment has been minimized.

Show comment
Hide comment
@fnothaft
Member

fnothaft commented Apr 20, 2016

@heuermh

This comment has been minimized.

Show comment
Hide comment
@heuermh

heuermh Apr 20, 2016

Member

That expression is used in the About class here

private static final String BUILD_TIMESTAMP = "${maven.build.timestamp}";

It is repeated in the pom file as a workaround for a bug with the maven assembly plugin (I believe, would have to dig for context). I've never seen this maven error before, what version are you using?

Member

heuermh commented Apr 20, 2016

That expression is used in the About class here

private static final String BUILD_TIMESTAMP = "${maven.build.timestamp}";

It is repeated in the pom file as a workaround for a bug with the maven assembly plugin (I believe, would have to dig for context). I've never seen this maven error before, what version are you using?

@fnothaft

This comment has been minimized.

Show comment
Hide comment
@fnothaft

fnothaft Apr 20, 2016

Member

As an aside, why does Guacamole depend on the adam-cli artifact? I would expect it to only need adam-core?

Member

fnothaft commented Apr 20, 2016

As an aside, why does Guacamole depend on the adam-cli artifact? I would expect it to only need adam-core?

@heuermh

This comment has been minimized.

Show comment
Hide comment
@heuermh

heuermh Apr 20, 2016

Member

Ouch, found it, issue open since 2009.
https://issues.apache.org/jira/browse/MRESOURCES-99

There is a workaround but I found it to be unreliable (on a different project).

Member

heuermh commented Apr 20, 2016

Ouch, found it, issue open since 2009.
https://issues.apache.org/jira/browse/MRESOURCES-99

There is a workaround but I found it to be unreliable (on a different project).

@heuermh

This comment has been minimized.

Show comment
Hide comment
@heuermh

heuermh Apr 20, 2016

Member

As an aside, why does Guacamole depend on the adam-cli artifact? I would expect it to only need adam-core?

All of my downstream repos do, and I don't believe I've ever seen this error

https://github.com/heuermh/adam-commands
https://github.com/heuermh/adam-examples
https://github.com/heuermh/adam-plugins

Member

heuermh commented Apr 20, 2016

As an aside, why does Guacamole depend on the adam-cli artifact? I would expect it to only need adam-core?

All of my downstream repos do, and I don't believe I've ever seen this error

https://github.com/heuermh/adam-commands
https://github.com/heuermh/adam-examples
https://github.com/heuermh/adam-plugins

@ryan-williams

This comment has been minimized.

Show comment
Hide comment
@ryan-williams

ryan-williams Apr 20, 2016

Member

I've never seen this maven error before, what version are you using?

$ mvn --version
Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-10T16:41:47+00:00)
Member

ryan-williams commented Apr 20, 2016

I've never seen this maven error before, what version are you using?

$ mvn --version
Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-10T16:41:47+00:00)
@ryan-williams

This comment has been minimized.

Show comment
Hide comment
@ryan-williams

ryan-williams Apr 20, 2016

Member

As an aside, why does Guacamole depend on the adam-cli artifact? I would expect it to only need adam-core?

Good point, seems like we don't need it :) will remove it, but maybe still good to understand why the error was happening.

Member

ryan-williams commented Apr 20, 2016

As an aside, why does Guacamole depend on the adam-cli artifact? I would expect it to only need adam-core?

Good point, seems like we don't need it :) will remove it, but maybe still good to understand why the error was happening.

@fnothaft

This comment has been minimized.

Show comment
Hide comment
@fnothaft

fnothaft Apr 20, 2016

Member

but maybe still good to understand why the error was happening.

Agreed.

Member

fnothaft commented Apr 20, 2016

but maybe still good to understand why the error was happening.

Agreed.

@ryan-williams

This comment has been minimized.

Show comment
Hide comment
@ryan-williams

ryan-williams Apr 20, 2016

Member

@heuermh I just cloned adam-commands, ran mvn package, and saw the warning:

[WARNING] Invalid POM for org.bdgenomics.adam:adam-cli_2.10:jar:0.19.1-SNAPSHOT, transitive dependencies (if any) will not be available, enable debug logging for more details
Member

ryan-williams commented Apr 20, 2016

@heuermh I just cloned adam-commands, ran mvn package, and saw the warning:

[WARNING] Invalid POM for org.bdgenomics.adam:adam-cli_2.10:jar:0.19.1-SNAPSHOT, transitive dependencies (if any) will not be available, enable debug logging for more details
@heuermh

This comment has been minimized.

Show comment
Hide comment
@heuermh

heuermh Apr 20, 2016

Member

Yeah just saw that, with mvn --debug ...

[DEBUG] Skipped remote request for org.bdgenomics.adam:adam-cli_2.10:0.19.1-SNAPSHOT/maven-metadata.xml, locally installed metadata up-to-date.
[WARNING] The POM for org.bdgenomics.adam:adam-cli_2.10:jar:0.19.1-SNAPSHOT is invalid, transitive dependencies (if any) will not be available: 1 problem was encountered while building the effective model for org.bdgenomics.adam:adam-cli_2.10:0.19.1-SNAPSHOT
[ERROR] Resolving expression: '${maven.build.timestamp}': Detected the following recursive expression cycle in 'maven.build.timestamp': [maven.build.timestamp] @
Member

heuermh commented Apr 20, 2016

Yeah just saw that, with mvn --debug ...

[DEBUG] Skipped remote request for org.bdgenomics.adam:adam-cli_2.10:0.19.1-SNAPSHOT/maven-metadata.xml, locally installed metadata up-to-date.
[WARNING] The POM for org.bdgenomics.adam:adam-cli_2.10:jar:0.19.1-SNAPSHOT is invalid, transitive dependencies (if any) will not be available: 1 problem was encountered while building the effective model for org.bdgenomics.adam:adam-cli_2.10:0.19.1-SNAPSHOT
[ERROR] Resolving expression: '${maven.build.timestamp}': Detected the following recursive expression cycle in 'maven.build.timestamp': [maven.build.timestamp] @
@heuermh

This comment has been minimized.

Show comment
Hide comment
@heuermh

heuermh May 4, 2016

Member

Fixed by #1005

Member

heuermh commented May 4, 2016

Fixed by #1005

@heuermh heuermh closed this May 4, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment