Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Excessive compilation warnings about multiple scala libraries #695

Closed
ryan-williams opened this Issue Jun 2, 2015 · 1 comment

Comments

Projects
3 participants
@ryan-williams
Copy link
Member

ryan-williams commented Jun 2, 2015

Many instances of this block when I compile ADAM:

[WARNING]  Expected all dependencies to require Scala version: 2.10.4
[WARNING]  org.bdgenomics.utils:utils-misc_2.10:0.2.1 requires scala version: 2.10.4
[WARNING]  org.bdgenomics.utils:utils-misc_2.10:0.2.1 requires scala version: 2.10.4
[WARNING]  org.bdgenomics.utils:utils-metrics_2.10:0.2.1 requires scala version: 2.10.4
[WARNING]  org.bdgenomics.utils:utils-io_2.10:0.2.1 requires scala version: 2.10.4
[WARNING]  org.bdgenomics.utils:utils-cli_2.10:0.2.1 requires scala version: 2.10.4
[WARNING]  org.scoverage:scalac-scoverage-plugin_2.10:0.99.2 requires scala version: 2.10.4
[WARNING]  org.bdgenomics.adam:adam-core_2.10:92dadf8 requires scala version: 2.10.4
[WARNING]  com.twitter:chill_2.10:0.5.0 requires scala version: 2.10.4
[WARNING]  org.spark-project.akka:akka-remote_2.10:2.3.4-spark requires scala version: 2.10.4
[WARNING]  org.spark-project.akka:akka-actor_2.10:2.3.4-spark requires scala version: 2.10.4
[WARNING]  org.spark-project.akka:akka-slf4j_2.10:2.3.4-spark requires scala version: 2.10.4
[WARNING]  org.apache.spark:spark-core_2.10:1.3.1 requires scala version: 2.10.4
[WARNING]  org.json4s:json4s-jackson_2.10:3.2.10 requires scala version: 2.10.4
[WARNING]  org.json4s:json4s-core_2.10:3.2.10 requires scala version: 2.10.4
[WARNING]  org.json4s:json4s-ast_2.10:3.2.10 requires scala version: 2.10.4
[WARNING]  org.json4s:json4s-core_2.10:3.2.10 requires scala version: 2.10.0
[WARNING] Multiple versions of scala libraries detected!

"Someone" should see if they can't do something about that org.json4s:json4s-core_2.10:3.2.10 that seems to be messing everything up!

@fnothaft fnothaft added this to the 1.0.0 milestone Mar 3, 2017

@heuermh heuermh added this to Triage in Release 1.0.0 Mar 8, 2017

@fnothaft fnothaft added the wontfix label Jan 9, 2018

@fnothaft

This comment has been minimized.

Copy link
Member

fnothaft commented Jan 9, 2018

I don't think this is an actionable ticket, as the supported Scala minor versions depends on the underlying dependencies. I will close this for now.

@fnothaft fnothaft closed this Jan 9, 2018

@heuermh heuermh modified the milestones: 1.0.0, 0.24.0 Jan 9, 2018

@heuermh heuermh added this to Completed in Release 0.24.0 Feb 10, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.