New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Information Disclosure Vulnerability(Need Authentication) #354

Open
tangxiaofeng7 opened this Issue Dec 21, 2018 · 2 comments

Comments

Projects
None yet
3 participants
@tangxiaofeng7
Copy link

tangxiaofeng7 commented Dec 21, 2018

I found a information leakage vulnerabilities in BigTree-CMS, you need to login the backstage first.

Steps to reproduce:

1、Login in to the backstage http://localhost/BigTree-CMS-master/site/index.php/admin
2、Post some contents
3、Checked the page and see
4、Then create and publish
5、Search and update
image

image
image

This vulnerability reveals the full path of bigtree-CMS
Let's look at the code:
image

The parameters of post are not restricted,so it will be evali it in wrong。

@fgeek

This comment has been minimized.

Copy link

fgeek commented Dec 25, 2018

CVE-2018-20405 has been assigned for this issue.

@timbuckingham

This comment has been minimized.

Copy link
Collaborator

timbuckingham commented Dec 25, 2018

This looks like it requires developer level access which allows for full code execution through a variety of means (template creation, module creation, extension installation, etc). Am I missing the privilege escalation aspect?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment