Publish to npm #1

Closed
jhurliman opened this Issue Apr 19, 2012 · 8 comments

Projects

None yet

2 participants

Can you publish this module to npm so I can include it in a project I'm working on? I'm building a message queue that speaks memcache (similar to Kestrel but built on node.js+redis) and this library is exactly what I was looking for.

Owner

should be no problem doing this. will try to get it sorted in next day or two and will let you know. are you using latest version of the code? i haven't tested it against recent versions of node.js at all so let me know if you have any changes you need me to pull...

Owner

also, i think i have a fully c++ version of this lying around somewhere. it is a bit faster than the node.js version as far as i can remember. let me know if you want to have a look at it and i'll load it up here...

That would be great. I haven't started using this code yet so nothing to report back, but I will let you know when I test it out.

John

On Apr 19, 2012, at 4:26 PM, Andrew Johnstonreply@reply.github.com wrote:

also, i think i have a fully c++ version of this lying around somewhere. it is a bit faster than the node.js version as far as i can remember. let me know if you want to have a look at it and i'll load it up here...


Reply to this email directly or view it on GitHub:
#1 (comment)

Owner

i'm having a look at it here. will get it all up to date for latest node
shortly so check for an update before you test anything...

On 20 April 2012 01:02, John Hurliman <
reply@reply.github.com

wrote:

That would be great. I haven't started using this code yet so nothing to
report back, but I will let you know when I test it out.

John

On Apr 19, 2012, at 4:26 PM, Andrew Johnstonreply@reply.github.com
wrote:

also, i think i have a fully c++ version of this lying around somewhere.
it is a bit faster than the node.js version as far as i can remember. let
me know if you want to have a look at it and i'll load it up here...


Reply to this email directly or view it on GitHub:

#1 (comment)


Reply to this email directly or view it on GitHub:

#1 (comment)

Owner

i've made a few changes and everything seems to be working. need to test different encodings still. let me know if you run into any issues.

I can't seem to install this package with npm:

npm http GET https://registry.npmjs.org/node-memcache-parser/0.0.3
npm http 304 https://registry.npmjs.org/node-memcache-parser/0.0.3

> node-memcache-parser@0.0.3 install /Users/jhurliman/sandbox/node_modules/node-memcache-parser
> node-waf configure build

arg[0] directory does not contain a wscript file

npm ERR! node-memcache-parser@0.0.3 install: `node-waf configure build`
npm ERR! `sh "-c" "node-waf configure build"` failed with 1
npm ERR! 
npm ERR! Failed at the node-memcache-parser@0.0.3 install script.
npm ERR! This is most likely a problem with the node-memcache-parser package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-waf configure build
npm ERR! You can get their info via:
npm ERR!     npm owner ls node-memcache-parser
npm ERR! There is likely additional logging output above.
npm ERR! 
npm ERR! System Darwin 11.3.0
npm ERR! command "node" "/usr/local/bin/npm" "install"
npm ERR! cwd /Users/jhurliman/sandbox
npm ERR! node -v v0.6.17
npm ERR! npm -v 1.1.21
npm ERR! code ELIFECYCLE
npm ERR! message node-memcache-parser@0.0.3 install: `node-waf configure build`
npm ERR! message `sh "-c" "node-waf configure build"` failed with 1
npm ERR! errno {}
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /Users/jhurliman/sandbox/npm-debug.log
npm not ok
@billywhizz billywhizz was assigned May 29, 2012
Owner

Should now be fixed. i'll also update repo with an index.js as soon as possible.

@billywhizz billywhizz closed this May 29, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment