Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Regenerate gemspec for version 3.1.1

commit ce48262d570d34a6a08fab288ff6f27504a0ba09 1 parent 3d9a757
@binarylogic authored
Showing with 18 additions and 4 deletions.
  1. +18 −4 authlogic.gemspec
View
22 authlogic.gemspec
@@ -5,7 +5,7 @@
Gem::Specification.new do |s|
s.name = "authlogic"
- s.version = "2.1.7"
+ s.version = "3.1.1"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Ben Johnson of Binary Logic"]
@@ -16,6 +16,8 @@ Gem::Specification.new do |s|
"README.rdoc"
]
s.files = [
+ "Gemfile",
+ "Gemfile.lock",
"LICENSE",
"README.rdoc",
"Rakefile",
@@ -83,6 +85,9 @@ Gem::Specification.new do |s|
"lib/authlogic/test_case/mock_logger.rb",
"lib/authlogic/test_case/mock_request.rb",
"lib/authlogic/test_case/rails_request_adapter.rb",
+ "lib/generators/authlogic/USAGE",
+ "lib/generators/authlogic/session_generator.rb",
+ "lib/generators/authlogic/templates/session.rb",
"rails/init.rb",
"shoulda_macros/authlogic.rb",
"test/acts_as_authentic_test/base_test.rb",
@@ -149,12 +154,21 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activesupport>, [">= 0"])
+ s.add_runtime_dependency(%q<activesupport>, [">= 3.0.0"])
+ s.add_runtime_dependency(%q<activerecord>, [">= 3.0.0"])
+ s.add_runtime_dependency(%q<activesupport>, [">= 3.0.0"])
+ s.add_runtime_dependency(%q<activerecord>, [">= 3.0.0"])
else
- s.add_dependency(%q<activesupport>, [">= 0"])
+ s.add_dependency(%q<activesupport>, [">= 3.0.0"])
+ s.add_dependency(%q<activerecord>, [">= 3.0.0"])
+ s.add_dependency(%q<activesupport>, [">= 3.0.0"])
+ s.add_dependency(%q<activerecord>, [">= 3.0.0"])
end
else
- s.add_dependency(%q<activesupport>, [">= 0"])
+ s.add_dependency(%q<activesupport>, [">= 3.0.0"])
+ s.add_dependency(%q<activerecord>, [">= 3.0.0"])
+ s.add_dependency(%q<activesupport>, [">= 3.0.0"])
+ s.add_dependency(%q<activerecord>, [">= 3.0.0"])
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.