Skip to content
This repository

save(false) deprecation warning #186

Open
radar opened this Issue September 30, 2010 · 3 comments

2 participants

Ryan Bigg lichtamberg
Ryan Bigg

I gather that you want to leave this gem compatible with Rails 2, so I'm interested in your thoughts about this.

At the moment our application raises a deprecation warning every time the save_without_session_maintenance(false) line is called in authlogic/callbacks.rb. I can fix this by changing this line to use :validate => false in place of false, but this breaks Rails 2 compatibility.

How would you suggest going about fixing this to maintain compatibility with both Rails 2 and Rails 3?

lichtamberg

I think there should be two seperate versions... Its easier i think to maintain..

Ryan Bigg

I think there should be two separate VERSIONS of the gem. Version 2 should be for Rails 2 and version 3 should be for Rails 3. Let's not fragment gems just because there's two different versions of Rails. Let's be smart about this.

Anybody who wants to use Rails 2 features:

config.gem 'authlogic', '~> 2.0.0'

Anybody who wants to use it with Rails 3:

gem 'authlogic', '~> 3.0.0'

Easy, right?

lichtamberg

Sorry, misspelled.. Different versions for different rails versions would be good, as you mentioned... but i dont know if binarylogic will do that?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.