undefined method `generate_best_match=' for ActionController::Routing:Module (NoMethodError) #59

Closed
Nevynxxx opened this Issue Oct 12, 2009 · 2 comments

Comments

Projects
None yet
3 participants

Get the following issue with a brand new app on ruby 1.9.1p243 (2009-07-16 revision 24175), and rails 2.3.3, and authlogic 2.1.2.

Steps went:
sudo gem install authlogic
rails authlogic_test
cd authlogic_test/
vim config/environment.rb
added - config.gem "authlogic"
set - RAILS_GEM_VERSION = '2.3.3' unless defined? RAILS_GEM_VERSION
script/generate session user_session
/home/nevyn/rails/authlogic_test/config/initializers/new_rails_defaults.rb:14:in <top (required)>': undefined methodgenerate_best_match=' for ActionController::Routing:Module (NoMethodError)
from /home/nevyn/.gem/ruby/1.9.1/gems/activesupport-2.3.3/lib/active_support/dependencies.rb:145:in load' from /home/nevyn/.gem/ruby/1.9.1/gems/activesupport-2.3.3/lib/active_support/dependencies.rb:145:inblock in load_with_new_constant_marking'
from /home/nevyn/.gem/ruby/1.9.1/gems/activesupport-2.3.3/lib/active_support/dependencies.rb:521:in new_constants_in' from /home/nevyn/.gem/ruby/1.9.1/gems/activesupport-2.3.3/lib/active_support/dependencies.rb:145:inload_with_new_constant_marking'
from /usr/lib/ruby19/gems/1.9.1/gems/rails-2.3.3/lib/initializer.rb:622:in block in load_application_initializers' from /usr/lib/ruby19/gems/1.9.1/gems/rails-2.3.3/lib/initializer.rb:621:ineach'
from /usr/lib/ruby19/gems/1.9.1/gems/rails-2.3.3/lib/initializer.rb:621:in load_application_initializers' from /usr/lib/ruby19/gems/1.9.1/gems/rails-2.3.3/lib/initializer.rb:176:inprocess'
from /usr/lib/ruby19/gems/1.9.1/gems/rails-2.3.3/lib/initializer.rb:113:in run' from /home/nevyn/rails/authlogic_test/config/environment.rb:9:in<top (required)>'
from /usr/lib/ruby19/gems/1.9.1/gems/rails-2.3.3/lib/commands/generate.rb:1:in require' from /usr/lib/ruby19/gems/1.9.1/gems/rails-2.3.3/lib/commands/generate.rb:1:in<top (required)>'
from script/generate:3:in require' from script/generate:3:in

'

tuxdna commented Apr 16, 2012

I was having this issue and I upgraded to Rails verion 2.3.4

$ sudo gem install rails -V -v=2.3.4 --no-rdoc --no-ri

That solved it.

Collaborator

jaredbeck commented Dec 25, 2016

Closing due to inactivity. If this is still an issue in the latest version of authlogic (currenly 3.5) please let us know and we'll be happy to reopen.

@jaredbeck jaredbeck closed this Dec 25, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment