uninitialized constant AuthLogic #69

Closed
mattberther opened this Issue Nov 17, 2009 · 1 comment

Projects

None yet

2 participants

@mattberther

I get this error with the following setup: uninitialized constant User::AuthLogic

#config/environment.rb

RAILS_GEM_VERSION = '2.3.4' unless defined? RAILS_GEM_VERSION
require File.join(File.dirname(FILE), 'boot')

Rails::Initializer.run do |config|
config.gem 'authlogic'

config.time_zone = 'UTC'

end

#app/models/user.rb
class User < ActiveRecord::Base
acts_as_authentic do |c|
c.crypto_provider = AuthLogic::CryptoProviders::MD5
end
end

Any thoughts on what I am doing wrong?

@mattberther

Please close this... i learned to spell Authlogic properly...

@tiegz tiegz closed this May 27, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment