Skip to content

Rails 3.1 Compatibility #254

Merged
3 commits merged into from May 18, 2011

4 participants

@AndreasWurm

No description provided.

@vagnerzampieri

Hey binarylogic, can you apply this patch? I want to use AuthLogic with Rails 3.1.0-beta, but without this patch it's does work. I got this message when run bundler install:

Bundler could not find compatible versions for gem "activerecord":
In Gemfile:
authlogic (= 3.0.2) depends on
activerecord (~> 3.0.7)

rails depends on
  activerecord (3.1.0.beta)

Tks

@fernandokosh

Vagner, We can use a branch of AndreasWurm for now.
Please aplly this patch, BynaryLogic.

@ghost
ghost commented May 17, 2011

Can you explain what you're doing in this commit:

AndreasWurm@7b114e7

Thats the reason I haven't merged it in. I already merged in more relaxed dependencies on rails 3. Thanks.

@AndreasWurm

ive converted the whole inheritable_attribute thing to use class_attribute (which also supports inheritance).
also added a logger to AR cause it required it.

@ghost ghost merged commit c569334 into binarylogic:master May 18, 2011
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.