Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Release v1.6.1

  • Loading branch information...
commit 4096ddc4b9931679e9b2ece2b21f0041112accac 1 parent 769040d
@binarylogic authored
View
3  Manifest
@@ -101,7 +101,7 @@ lib/searchlogic/shared/utilities.rb
lib/searchlogic/shared/virtual_classes.rb
lib/searchlogic/version.rb
lib/searchlogic.rb
-Manifest
+Manifest.txt
MIT-LICENSE
Rakefile
README.rdoc
@@ -155,3 +155,4 @@ test/search_tests/pagination_test.rb
test/search_tests/protection_test.rb
test/test_helper.rb
TODO.rdoc
+Manifest
View
0  Manifest.txt
No changes.
View
24 Rakefile
@@ -1,19 +1,13 @@
require 'rubygems'
require File.dirname(__FILE__) << "/lib/searchlogic/version"
+require 'echoe'
-begin
- require 'echoe'
-
- Echoe.new 'searchlogic' do |p|
- p.version = Searchlogic::Version::STRING
- p.author = "Ben Johnson of Binary Logic"
- p.email = 'bjohnson@binarylogic.com'
- p.project = 'searchlogic'
- p.summary = "Object based ActiveRecord searching, ordering, pagination, and more!"
- p.url = "http://github.com/binarylogic/searchlogic"
- p.dependencies = %w(activerecord activesupport)
- end
-rescue LoadError => boom
- puts "You are missing a dependency required for meta-operations on this gem."
- puts "#{boom.to_s.capitalize}."
+Echoe.new 'searchlogic' do |p|
+ p.version = Searchlogic::Version::STRING
+ p.author = "Ben Johnson of Binary Logic"
+ p.email = 'bjohnson@binarylogic.com'
+ p.project = 'searchlogic'
+ p.summary = "Object based ActiveRecord searching, ordering, pagination, and more!"
+ p.url = "http://github.com/binarylogic/searchlogic"
+ p.dependencies = %w(activerecord activesupport echoe)
end
View
2  lib/searchlogic/version.rb
@@ -67,7 +67,7 @@ def to_a
MAJOR = 1
MINOR = 6
- TINY = 0
+ TINY = 1
# The current version as a Version instance
CURRENT = new(MAJOR, MINOR, TINY)
Please sign in to comment.
Something went wrong with that request. Please try again.