Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Bundlerize gem and upgrade to rspec2 compatibility.

  • Loading branch information...
commit 8b688ab35cc50a5f8f97fdac4b9679ef321b02fa 1 parent 086cf46
Winfield Peterson authored
Showing with 43 additions and 5 deletions.
  1. +6 −0 Gemfile
  2. +36 −0 Gemfile.lock
  3. +1 −5 spec/spec_helper.rb
View
6 Gemfile
@@ -0,0 +1,6 @@
+source "http://rubygems.org"
+
+gem 'rake', '0.8.7'
+gem 'jeweler'
+gem 'rspec', :require => 'spec'
+gem 'ruby-debug'
View
36 Gemfile.lock
@@ -0,0 +1,36 @@
+GEM
+ remote: http://rubygems.org/
+ specs:
+ columnize (0.3.6)
+ diff-lcs (1.1.3)
+ git (1.2.5)
+ jeweler (1.6.4)
+ bundler (~> 1.0)
+ git (>= 1.2.5)
+ rake
+ linecache (0.46)
+ rbx-require-relative (> 0.0.4)
+ rake (0.8.7)
+ rbx-require-relative (0.0.5)
+ rspec (2.8.0)
+ rspec-core (~> 2.8.0)
+ rspec-expectations (~> 2.8.0)
+ rspec-mocks (~> 2.8.0)
+ rspec-core (2.8.0)
+ rspec-expectations (2.8.0)
+ diff-lcs (~> 1.1.2)
+ rspec-mocks (2.8.0)
+ ruby-debug (0.10.4)
+ columnize (>= 0.1)
+ ruby-debug-base (~> 0.10.4.0)
+ ruby-debug-base (0.10.4)
+ linecache (>= 0.3)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ jeweler
+ rake (= 0.8.7)
+ rspec
+ ruby-debug
View
6 spec/spec_helper.rb
@@ -1,7 +1,3 @@
-require 'spec'
-require 'rubygems'
-require 'ruby-debug' if RUBY_VERSION < '1.9' # ruby-debug does not work on 1.9.1 yet
-
$LOAD_PATH.unshift(File.dirname(__FILE__))
$LOAD_PATH.unshift(File.join(File.dirname(__FILE__), '..', 'lib'))
require 'settingslogic'
@@ -14,5 +10,5 @@
'collision'
end
-Spec::Runner.configure do |config|
+RSpec.configure do |config|
end
Please sign in to comment.
Something went wrong with that request. Please try again.