Permalink
Browse files

Merge pull request #29 from wpeterson/ruby_compat_1.8

Fix Ruby 1.8.7 Compatibility and Gem Dependencies
  • Loading branch information...
binarylogic committed Jan 6, 2012
2 parents 5f55b94 + ccd80c7 commit e8dfc73600b39d03c635b0e368c478a9efcf0bc7
Showing with 18 additions and 6 deletions.
  1. +18 −6 settingslogic.gemspec
View
@@ -44,21 +44,33 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<rake>, [">= 0"])
- s.add_runtime_dependency(%q<jeweler>, [">= 0"])
- s.add_runtime_dependency(%q<rspec>, [">= 0"])
- s.add_runtime_dependency(%q<ruby-debug19>, [">= 0"])
+ s.add_development_dependency(%q<rake>, [">= 0"])
+ s.add_development_dependency(%q<jeweler>, [">= 0"])
+ s.add_development_dependency(%q<rspec>, [">= 0"])
+ if RUBY_VERSION < "1.9"
+ s.add_development_dependency(%q<ruby-debug>, [">= 0"])
+ else
+ s.add_development_dependency(%q<ruby-debug19>, [">= 0"])
+ end
else
s.add_dependency(%q<rake>, [">= 0"])
s.add_dependency(%q<jeweler>, [">= 0"])
s.add_dependency(%q<rspec>, [">= 0"])
- s.add_dependency(%q<ruby-debug19>, [">= 0"])
+ if RUBY_VERSION < "1.9"
+ s.add_dependency(%q<ruby-debug>, [">= 0"])
+ else
+ s.add_dependency(%q<ruby-debug19>, [">= 0"])
+ end
end
else
s.add_dependency(%q<rake>, [">= 0"])
s.add_dependency(%q<jeweler>, [">= 0"])
s.add_dependency(%q<rspec>, [">= 0"])
- s.add_dependency(%q<ruby-debug19>, [">= 0"])
+ if RUBY_VERSION < "1.9"
+ s.add_dependency(%q<ruby-debug>, [">= 0"])
+ else
+ s.add_dependency(%q<ruby-debug19>, [">= 0"])
+ end
end
end

0 comments on commit e8dfc73

Please sign in to comment.