Skip to content
Permalink
Browse files

Deprecated support for Ruby 1.9

- New gem pushed v0.3.13.0
- Adds Travis test for Ruby 2.5.1
  • Loading branch information...
lmrodriguezr committed Aug 5, 2019
1 parent b595710 commit 4620b9ff1d158bffe2d6cd55ab3853d24383949d
Showing with 6 additions and 10 deletions.
  1. +1 −5 .travis.yml
  2. +1 −1 lib/miga/version.rb
  3. +1 −1 manual/part2/requirements.md
  4. +1 −1 manual/part2/requirements/source.md
  5. +1 −1 miga-base.gemspec
  6. +1 −1 utils/requirements.txt
@@ -7,13 +7,9 @@ matrix:
- rvm: 2.1.5
env: REMOTE_TESTS=true
after_script: "bundle exec codeclimate-test-reporter"
# Test with JRuby (for the GUI)
#- rvm: jruby-9.0.5.0
# env: JRUBY_TESTS=true JRUBY_OPTS="-d"
# jdk: openjdk7
# Additional tests with standard versions
- rvm: 1.9.3
- rvm: 2.3.0
- rvm: 2.5.1
- rvm: ruby-head
script: "bundle exec rake test:all"
cache: bundler
@@ -10,7 +10,7 @@ module MiGA
# - Float representing the major.minor version.
# - Integer representing gem releases of the current version.
# - Integer representing minor changes that require new version number.
VERSION = [0.3, 12, 1]
VERSION = [0.3, 13, 0]

##
# Nickname for the current major.minor version.
@@ -2,7 +2,7 @@

MiGA requires a system (single computer, cluster, or cloud-computing
infrastructure) with Linux or MacOS. If you simply want to access projects
previously processed, all you need is `ruby` 1.9+ (recommended 2.3+) and the
previously processed, all you need is `ruby` 2.1+ (recommended 2.3+) and the
[required gems](#ruby-libraries). If you want to use MiGA to process your data,
please continue these instructions.

@@ -5,7 +5,7 @@
If you don't have apt-get, Homebrew, or conda, here's the list of requirements
and URLs with installation instructions:

* **Ruby**: https://www.ruby-lang.org/. Required: v1.9+, recommended: v2.3+.
* **Ruby**: https://www.ruby-lang.org/. Required: v2.1+, recommended: v2.3+.
* **Python**: https://www.python.org/.
* **R**: http://www.r-project.org/.
* **SQLite3**: https://www.sqlite.org/.
@@ -29,7 +29,7 @@ Gem::Specification.new do |s|
# Testing requires "shush" from daemons, first introduced in v1.2.4
s.add_runtime_dependency 'json', '> 1.8', '< 3'
s.add_runtime_dependency 'sqlite3', '~> 1.3'
s.required_ruby_version = '>= 1.9'
s.required_ruby_version = '>= 2.1'

# Docs + tests
s.extra_rdoc_files << 'README.md'
@@ -1,6 +1,6 @@
Software Test exec Website Notes
-------- --------- ------- -----
Ruby ruby https://www.ruby-lang.org/ Required version: 1.9+
Ruby ruby https://www.ruby-lang.org/ Required version: 2.1+
Python python https://www.python.org/
R R http://www.r-project.org/
SQLite3 sqlite3 https://www.sqlite.org/

0 comments on commit 4620b9f

Please sign in to comment.
You can’t perform that action at this time.