Skip to content
Permalink
Browse files

Update requirements

Some version upgrades required to simplify the requirements scheme
  • Loading branch information...
lmrodriguezr committed Aug 25, 2019
1 parent dd124ad commit 7c1a1307fbc2836de691463ab7e1f7131a340993
Showing with 4 additions and 5 deletions.
  1. +4 −5 miga-base.gemspec
@@ -25,17 +25,16 @@ Gem::Specification.new do |s|
s.executables << 'miga'

# Dependencies
s.add_runtime_dependency 'daemons', '~> 1.2', '>= 1.2.4'
# Testing requires "shush" from daemons, first introduced in v1.2.4
s.add_runtime_dependency 'json', '> 1.8', '< 3'
s.add_runtime_dependency 'sqlite3', '~> 1.3'
s.add_runtime_dependency 'daemons', '~> 1.3'
s.add_runtime_dependency 'json', '~> 2'
s.add_runtime_dependency 'sqlite3', '~> 1.4'
s.required_ruby_version = '>= 2.1'

# Docs + tests
s.extra_rdoc_files << 'README.md'
s.rdoc_options = %w(lib README.md --main README.md)
s.rdoc_options << '--title' << s.summary
s.add_development_dependency 'rake', '~> 11'
s.add_development_dependency 'rake', '~> 12'
s.add_development_dependency 'test-unit', '~> 3'

end

0 comments on commit 7c1a130

Please sign in to comment.
You can’t perform that action at this time.