New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add recipe for seer #11263

Merged
merged 20 commits into from Oct 16, 2018

Conversation

Projects
None yet
2 participants
@johnlees
Copy link
Contributor

johnlees commented Oct 8, 2018

This is an attempt to resurrect #5005 from @Slugger70 now that the newer gcc libraries are available.

It almost works, but I am getting a little out of my depth so was hoping to solicit some advice from @bioconda/core here.

The compiling is failing at the linking stage, I think because the gcc version used here is different from that used to compile the boost dependency.
Would it be best to try and recompile the necessary boost library as part of this recipe?
Also, would it be best to perform static linking to avoid these issues on the running machines?

Many thanks!

@johnlees

This comment has been minimized.

Copy link
Contributor Author

johnlees commented Oct 8, 2018

Also I'm not sure I understand the second linting error - I have the line:

  build:
    - {{ compiler('cxx') }}

in meta.yaml

@johnlees

This comment has been minimized.

Copy link
Contributor Author

johnlees commented Oct 8, 2018

Ok, reading the docs I see this is because of the libgcc dependency.
While seer can be compiled with gcc 4.8, to run it requires libgcc > 4.9, as it uses the regex functions (part of the standard used by gcc 4.8, but not implemented in the library until 4.9).

Would it be best to turn off this linting, or try with the standard compiler?

@bgruening

This comment has been minimized.

Copy link
Member

bgruening commented Oct 8, 2018

Hi @johnlees! fn needed to be removed and libgcc.

@bgruening

This comment has been minimized.

Copy link
Member

bgruening commented Oct 8, 2018

Consider using the new compiler toolchain by adding this file to your recipe: https://github.com/bioconda/bioconda-recipes/blob/master/recipes/kmc/conda_build_config.yaml

johnlees added some commits Oct 9, 2018

@johnlees

This comment has been minimized.

Copy link
Contributor Author

johnlees commented Oct 9, 2018

This is still failing at the boost linking stage. I wonder if the gcc-7.3 label might work, but I don't know how to specify this in the meta.yaml.
Alternatively, should I compile the program options boost module as part of the recipe?

johnlees added some commits Oct 10, 2018

@johnlees

This comment has been minimized.

Copy link
Contributor Author

johnlees commented Oct 12, 2018

@bioconda/core any idea why this worked in c66d8cb (https://circleci.com/gh/bioconda/bioconda-recipes/29475) but is now failing now the build is not being run.
The error seems to be an issue with an undefined symbol from lapack

@johnlees

This comment has been minimized.

Copy link
Contributor Author

johnlees commented Oct 12, 2018

Is there a way to force this to rebuild?

@johnlees

This comment has been minimized.

Copy link
Contributor Author

johnlees commented Oct 15, 2018

(continuing to make notes to self here)
I think this could be due to the armadillo wrapper. Try with -DARMA_DONT_USE_WRAPPER

@johnlees

This comment has been minimized.

Copy link
Contributor Author

johnlees commented Oct 16, 2018

I've finally got this to work! @bioconda/core could you please review?

This was hard, but I learnt a lot about conda!

@bgruening
Copy link
Member

bgruening left a comment

Thanks @johnlees to put so much effort in it. Just two tiny recommendations. After fixing this, feel free to merge.

Show resolved Hide resolved recipes/seer/build.sh
Show resolved Hide resolved recipes/seer/meta.yaml Outdated
Show resolved Hide resolved recipes/seer/meta.yaml Outdated

@johnlees johnlees merged commit 86ce3b8 into master Oct 16, 2018

3 checks passed

ci/circleci: lint Your tests passed on CircleCI!
Details
ci/circleci: test-linux Your tests passed on CircleCI!
Details
ci/circleci: test-macos Your tests passed on CircleCI!
Details

@bgruening bgruening deleted the seer branch Oct 19, 2018

bgruening added a commit that referenced this pull request Oct 31, 2018

[BULK] fix bioconductor-tissueenrich (#11720)
* taxonkit 0.2.5 (#11318)

* Update csvtk (#11319)

* taxonkit 0.2.5

* csvtk 0.15.0

* bumping GROOT to 0.8.1 (#11323)

* HiCMatrix version 3 (#11322)

* Correcting dependencies

* Version 3 of HiCMatrix, the October release

* Update confindr to 0.4.3 (#11330)

* Drop-seq_tools: Version 2.0.0 (#11326)

* Update meta.yaml
* Update build.sh

some tool names changed to fit Camel case

* Update motus to build only for python3 (#11331)

* Update fpa to 0.2 version (#11333)

* update taxonkit to 0.3.0 (#11339)

* ntcard 1.1.0 (#11338)

* Update rgi (#11335)

* first commit

* update dependencies list

* change source to github

* change build number

* testing circleci

* update meta and build

* fix build

* move build script into meta

* remove older recipes

* line fix in bootstrap.py

* change python & matplotlib versions; add build.sh file

* add preprocessing selector to skip python 2.7

* move build script into meta.yaml

* Revert "line fix in bootstrap.py"

This reverts commit 5ac1ecd.

* Update gmap to version 2018-07-04. (#11332)

MAX_READLENGTH environment variable has been disused since 2016-08-16.

* Upgrade r-biodb to 1.2.0a. (#11341)

* Upgrade r-biodb to 1.2.0a.

* Update meta.yaml

* Updated ont-tombo to version 1.5. (#11329)

* Updated ont-tombo to version 1.5.

* Updated with actual github release version hash.

* remove graphicsmagick (#11342)

* Build  kraken2 for osx (#11343)

* First try for a bcalm recipes (#11344)

* New: cgpbigwig (BigWig manipulation); Update: bcbio (#11347)

- cgpbigwig (https://github.com/cancerit/cgpBigWig) provides bigwig
  generation and manipulation command line tools including bam to bigwig
  conversion.
- bcbio: fixes for QC on variants and peddy for CWL runs

* Try avoid some dependancy (#11349)

* Update TreeBest to commit c9d3a2e35276c825577ec945b229e975c32078d8 (#11348)

* Update TreeBest to commit c9d3a2e35276c825577ec945b229e975c32078d8

Also add about:home .

* Workaround conda-forge/bison-feedstock#7

* Better bcalm recipes (#11350)

* Try avoid some dependancy

* Correct mess in build number, sorry

* R biodb (#11351)

* rebuild r-biodb

* trigger build

* Add recipe for pypairs (#11356)

* Update smoove to 0.2.1. (#11360)

* Update duphold to 0.0.9. (#11359)

* Update goleft to 0.2.0 (#11361)

* Bump slicedimage to 1.0.0 (#11362)

* Bump slicedimage to 1.0.1 (#11365)

* Added new versions for biopet-sampleconfig (#11268)

* perl-velvetoptimiser: update to 2.2.6 (#11369)

* update to 2.2.6

* remove unneeded patch

* Scanpy upgrade (#11371)

* Bump version

* Upgrade Scanpy

* Bump starfish to 0.0.25 (#11370)

* bumping groot to 0.8.2 (#11374)

* vep: bump subversion (#11367)

* Updated Krocus 1.0.1 (#11355)

* Add tiptoft

* Fix meta.yaml for tiptoft

* Add build script

* Updated krocus 1.0.1

* Add tiptoft 0.1.4 (#11352)

* Add tiptoft

* Fix meta.yaml for tiptoft

* Add build script

* Kodoja v0.0.9 (#11373)

* Add recipe for seer (#11263)

* Add recipe for seer

* lets try this

* Add newer compiler

* Using boost-cpp

* messed up version string

* Attempt building boost

* Use c++11 in boost

* Use python for boost install

* Correct python version spec

* try with different python version

* Fix b2 command

* Fix popd command

* build and link boost program options statically

* Fix tests

* Match dependency order

* Link openblas instead of blas

* Forcing rebuild with openblas

* Don't use armadillo wrapper

* Making review changes. Also trying original tests

* Previous tests were correct

* Add recipe for the translate-gard npm package version 1.0.3 (#11364)

* Fix umi tools (#11376)

 umi_tools: clean up dependencies

* add support tools to PATH (#11379)

* Bump to v2.2.1 (#11380)

* Bump starfish to 0.0.26 (#11378)

* Update fpa to 0.3 (#11375)

* Update fpa to 0.3

* Correct error in sha256

* Reset build number

* Update trial to 2.5.5 (#11386)

* Update: bioconductor-titancna; 1.19.1 with hg38 support (#11388)

* Update: bioconductor-titancna; 1.19.1 with hg38 support

* Pin to R 3.4 to avoid pulling in 3.3 and 3.5 during mulled

* Add r-polysat version 1.7-3 (#11384)

* Update biomart version so that compatible with r351 (#11366)

* Update biomart version so that compatible with r351

* Update meta.yaml

reset build number as per https://bioconda.github.io/guidelines.html#buildnum

* Update entrez-direct to 10.0.20180927. (#11387)

* Added recipe for SonicParanoid 1.0.13 (#11271)

* Added recipe for SonicParanoid 1.0.13

* removed 'x.x' for numpy, added basic test

* fixed linter related errors

* compiler set to cxx and added host section (same build error!)

* removed host section

* moved numpy and cython to host section; restored build: noarch: python; added LICENSE.md

* removed build: noarch

* added build and extra sections

* set build number to 0; removed skip build; added python3 minimum version; added test for all executables.

* restored sh python module as requirement

* added Make to run; updated release to latest commit

* remove c compiler from meta.yaml

* modified build.sh to compile source codel added make in build section

* updated to latest commit

* updated to latest version with make included in setup.py

* reverted build.sh to the simplest version (python setup.py install)

* Add perl-json to build requirements to allow meme-chip to run to completion. Change meme-chip to use dreme-py3 instead of dreme if building with python 3. (#11389)

* Bump IgBLAST to 1.9.0 (#11393)

Bump IgBLAST to 1.9.0

Re-package the binary version this time. There are problems building the
source version when the configure script reaches this step:
"trying to build the NCBI SRA/VDB Toolkit from GitHub"

The previous problem about the binaries linking against libbz2.so, for
which we had no conda package, is now solved.

Also, this saves about 45 minutes compilation time.

* Add consan (#11395)

* Add consan

* Skip osx

* Update: vardict, vardict-java 1.5.7 (#11394)

* Update: vardict, vardict-java 1.5.7

Latest vardict-java release and corresponding vardict with bug fixes
after testing with 1.5.6

* Reduce test output to try and fix build problems

* Experiment 2 for build problems: remove r-base from run

* Experiment 3 for build problems: add r-base in host

* update recipe for 3.9.1 (#11397)

* evofold2 (#11396)

* evofold2

* wrapper

* Update meta.yaml

* minor

* Update rnastructure to 6.1. (#11400)

* Ctat mut (#11401)

* updating version number

* correct URL

* proper hash

* Revert "Ctat mut (#11401)" (#11402)

This reverts commit 6db10ac.

* update version (#11403)

* any2fasta 0.4.2 (new formula) (#11407)

* W4mclassfilter v0.98.9 (#11385)

* Added files to build version 0.98.9

* Update meta.yaml

* Update meta.yaml

* updated SonicParanoid recipe to version 1.0.14 (#11409)

* updated SonicParanoid recipe to version 1.0.14

* Update to version 1.0.2 of PopDel (#11398)

* Update to version 1.0.2 of PopDel

Update to version 1.0.2.

* Reset build number to 0

* PacBio: require Meson 0.48.1 for all recipes (#11090)

* Meson 0.47 inserted duplicate RPATHs in
  macOS binaries, causing `install_name_tool`
  failures when installing the package.
  Requiring 0.48.1 ensures we do not run into
  these issues anymore in the future.

* rebuild with latest openmpi (#11411)

* Remove kfoots from the blacklist (#11416)

* Update gseapy to 0.9.7 (#11417)

* Update gseapy to 0.9.7

* remove noarch

* Add SC3 as dependency (#11427)

* Add recipe for r-poppr (#11418)

* Update knitr version because of Issue: rstudio/rmarkdown#1271 (#11412)

* Update IQ-TREE to 1.6.7.1 (#11429)

* Update IQ-TREE to 1.6.7.1

* Change build number

* Update: r-deconstructsigs with fixes for hg38 (#11431)

The 1.8.0 release, from 2016, has some issues with hg38 and other
custom genomes that are fixed in development (raerose01/deconstructSigs#27).
There hasn't been a new release pushed so this rolls these into a new
sub-version and makes them available.

* Update entrez-direct to 10.2.20181018. (#11432)

* Add assembly-scan recipe (#11425)

* remove python 2.7 skip (#11424)

Preparation for rnaQUAST

* Add fastq-scan recipe (#11415)

* Add patch to fix racon/rampler path in racon_wrapper. (#11434)

Fixes #11405.

* meme rebuild (#11433)

* Update nanocomp to 0.23.1 (#11436)

* Update nanocomp to 0.23.1

* remove noarch

* Update abricate to 0.8.10 (#11446)

* Update angsd to 0.923 (#11445)

* Update alfred to 0.1.13 (#11444)

* Update alfred to 0.1.13

* Try w/o patch

* Update antarna to 2.0.6 (#11442)

* Update admixtools to 5.1 (#11443)

* Update admixtools to 5.1

* Let makefile choose which bins to install

* Update alignstats to 0.5 (#11441)

* Update xatlas to 0.2.1 (#11437)

* r-gpca (#11428)

* r-gpca

* r-gpca recipe

* Update meta.yaml

* Removed All Comments

* gseapy bump version 0.9.8 (#11440)

* gseapy bump version 0.9.8

* version

* titancna: fix for hg38, remove conda build hacks (#11447)

* titancna: fix for hg38, remove conda build hacks

* Re-add r-base 3.4 pin to avoid 3.5 errors

* Hmmlearn older version (#11450)

* Adding pygtftk

* removed pygtftk from master

* add older version of hmmlearn

* Add card_trick (#11451)

* Add card_trick

* Restrict to py3

* Update checkm-genome to 1.0.12 (#11455)

* Bump drep (#11457)

* Update squid to 1.5 (#11466)

* Update ncbi-ngs-sdk to 2.9.3 (#11467)

* elprep: bumped major version (#11414)

* elprep: bumped major version

* fixed hash

* fix download link, fixed licence

* fixed tests

* skip osx build

* FRED2 as a conda package (#11469)

* Attempt to get FRED2 as a conda package

* SHA update

* 99 little bugs in the code

* Fix things Björn mentioned

* add rnaQUAST recipe (#11470)

* Update bioconda-utils to 0.14.9 (#11454)

* Rapidup (#11474)

* Update to v0.7

* Update Buildnumber

* rapid: update to v0.6

* rapid: update to v0.6

* update grid (#11478)

* Adding biobb_model recipe (#11472)

* Updated wtdbg to v2.1 (#11486)

* update stream to 0.2.6 (#11483)

* update stream to 0.2.2

* update stream to 0.2.3

* update stream to 0.2.4

* update stream to 0.2.4

* update stream to 0.2.4

* update stream to 0.2.5

* update stream to 0.2.6

* Update meta.yaml (#11487)

* Update connectome-workbench to 1.3.2 (#11468)

Now needs QT 5.7

* Update deblur to 1.1.0 (#11500)

* Update domclust to 1.2.8 (#11498)

* WisecondorX: bump version (#11501)

* Bump as GitHub wasn't working yesterday (#11502)

* Added recipe for Sequenza (#10367)

* Added recipe for Sequenza

* Removed fn entry in source section

* Trying with only one URL

* copynumber is a bioconductor package

* Added missing requirements section

* Removed mailing list address

* Added doi

* Added license_file

* Trying with different  license_file path

* Fred2 bump (#11503)

* Bump as GitHub wasn't working yesterday

* Fix licence etc

* Scanpy scripts (#11413)

Doing squash and merge as requested by @nh3 

* Bump version

* First implementation of scanpy-scripts bioconda recipe.

* fix path in build.sh

* Remove "noarch" flag as requested by bioconda recipe checklist

* Add a post install notice that post install test needs bats-core.

* Add more dependencies

* Skip building for python versions other than 3.6

* Target v0.0.2 which has non-ascii characters removed

* Lower version requirement for pandas and matplotlib to be the same as scanpy

* Requirement matplotlib>=3.0.0, declare noarch

* New: hmftools-cobalt; Update: hmftools-purple (#11507)

- hmftools-cobalt: Add latest version of PURPLE associated read counter,
  COBALT, with support for hg38.
- hmftools-purple: PURPLE release with hg38 support.

* Update Picard to 2.18.15. (#11505)

* Genenotebook (#11476)

* genenotebook recipe

* About

* Package name

* License

* sha256sum

* Update build.sh

* Make bin dir

* Change ln to cp

* New symlink strategy

* Build from prebundled tarball

* genenotebook v0.1.2

* version fix

* retry

* fix

* build number

* genenotebook v0.1.3

* restore build procedure

* Fix summary

* dependency versions

* v0.1.5

* Update pinning (#11514)

* Bump build number for updated dependency (#11510)

* Bump build number for updated dependency

* Try adding r-base to host requirements

* Try adding other requirements to host

* Pin to R version

* Update meta.yaml

* Update meta.yaml

* Update meta.yaml

* Tweak dependency version syntax

* Pin R and package versions correctly

* PacBio: Update pbcore to 1.6.5 (#11513)

* Bump r seurat scripts version (#11292)

* Bump version

* Remove noarch

* Could wrongly quoted version be causing an issue?

* Tweak pinning to try and fix CI error

* seqcluster:fix UMI detection. (#11511)

* seqcluster:fix UMI detection.

* Fix dependency

* quast 5.0.1 (#11479)

* quast 5.0.1

* quast 5.0.1: remove third-party site packages from the distibution pack

* quast 5.0.1: skip Glimmer in test

* quast 5.0.1: joblib and simplejson dependencies added to meta.yaml (Setuptools downloading is disabled in conda build)

* quast 5.0.1: explicit joblib and simplejson dependencies removed (Setuptools downloading is disabled in conda build)

* quast 5.0.1: Python 2 and 3 compatible code in build.sh

* wcX bugfixes (#11508)

* wcX bugfixes

* fixed shasum

* Update fastspar to 0.0.7 (#11515)

* Update iqtree to 1.6.7.2 (#11525)

* Update illumina-interop to 1.1.6 (#11523)

* Update hapbin to 1.3.0 (#11522)

* Update hlama to 3.0.1 (#11520)

* Update gb_taxonomy_tools to 1.0.1 (#11519)

* Update gffcompare to 0.10.5 (#11517)

* Update fast5seek to 0.1.1 (#11516)

* Update deepbinner to 0.2.0 (#11499)

* Update deepbinner to 0.2.0

* Update meta.yaml

Try same fix as in #11240

* Update ncbi-vdb to 2.9.3 (#11550)

* Update mikado to 1.2.4 (#11549)

* Update perl-pcap to 3.5.2 (#11543)

* Update python-hyphy-python to 0.1.9 (#11545)

* Update mlst to 2.15.2 (#11547)

* Update perl-sanger-cgp-vcf to 2.2.1 (#11542)

* Update merfishtools to 1.5.0 (#11537)

* Update perl-sanger-cgp-vagrent to 3.3.3 (#11536)

* Update nonpareil to 3.3.3 (#11535)

* Update prophex to 0.1.1 (#11532)

* Update krakenuniq to 0.5.3 (#11527)

* Update novoplasty to 2.7.2 (#11530)

* Update minced to 0.3.2 (#11529)

* Update mapdamage2 to 2.0.8 (#11528)

* Update perl-sanger-cgp-allelecount to 4.0.0 (#11538)

* Update pyvolve to 0.9.0 (#11531)

* Genenotebook (#11512)

* genenotebook recipe

* About

* Package name

* License

* sha256sum

* Update build.sh

* Make bin dir

* Change ln to cp

* New symlink strategy

* Build from prebundled tarball

* genenotebook v0.1.2

* version fix

* retry

* fix

* build number

* genenotebook v0.1.3

* restore build procedure

* Fix summary

* dependency versions

* v0.1.5

* version fix

* add plek (#11554)

* Update pyimzml to 1.2.4 (#11534)

* Bump shovill (#11555)

* PacBio: Update minimum pbcore version (#11556)

* We want all users of PacBio tools to be able to
  use our utilities with pbmm2 alignments.

* Add recipe for translate-gard v1.0.4 (#11557)

* bioconductor-rnaseqsamplesizedata (#11475)

* Adding Recipe for bioconductor-rnaseqsamplesizedata

* Updated metadata for RnaSeqSampleSizeData

* nextflow 18.10.1 (#11558)

* Update raxml to 8.2.12 (#11567)

* Update r-fgwas to 0.3.6 (#11566)

* Update rapid to 0.7 (#11565)

* Update r-spieceasi to 1.0.2 (#11564)

* Update rcorrector to 1.0.3.1 (#11562)

* Update quicktree to 2.4 (#11560)

* Update paladin to 1.4.4 (#11541)

* Update paladin to 1.4.4

* delete md5

* Update build.sh

* Update build.sh

* Fix and unblacklist Tadarida-D (#11568)

* Add recipe for rgt

* Fix and un-blacklist tadarida-d

* Remove RGT

* bumping groot (#11575)

* update pymzml (#11573)

* Add bioconductor-rnaseqsamplesize (#11559)

* Add bioconductor-rnaseqsamplesize

* Update recipe

* Fixing some URLs

* Update dependencies missing

* Update trumicount to 0.9.11 (#11576)

* Update ConFindr to 0.4.4 (#11578)

* Added new versions for biopet-scatterregions (#11572)

* Added new versions for biopet-bamstats (#11571)

* R ggbiplot (#11584)

* add R -e 'httr::set_config(httr::config(ssl_verifypeer = 0L)); install.packages(devtools, repos=http://mirrors.ebi.ac.uk/CRAN/); library(devtools); install_github(vqv/ggbiplot); library(ggbiplot)'

* add r-ggbiplot

* update meta.yaml

* update meta.yaml

* update

* update

* update

* update

* update

* update

* update

* update

* update

* fix errors

* fix errors number 1

* Update rebaler to 0.1.2 (#11563)

* Update rebaler to 0.1.2

* Remove fn

* bump graphclust (#11585)

* Update seqyclean to 1.10.09 (#11589)

* Update stringmlst to 0.5.1 (#11590)

* Update snp-dists to 0.6.2 (#11592)

* Update snippy to 4.3.3 (#11596)

* Update canu to 1.8 (#11600)

* Update starfish to 0.0.27 (#11599)

* Update womtool to 36 (#11594)

* Update telseq to 0.0.2 (#11598)

* Update snp-sites to 2.4.1 (#11588)

* Added recipe for pydemult: Streamed and parallel demultiplexing of fastq files (#11471)

* Added recipe for pydemult

* Bumped version in favor of py3.5

* bump vcf2db to latest commit (#11601)

* bump vcf2db to latest commit

* fix shasum

* Fixing source url

* Update: TitanCNA; hg38 cytoband support and fix for normalization (#11604)

* megan (#11046)

* megan6: initial commit

* megan6: intermediate commit

* megan: made tests work

* megan: doc improvement

* megan: added osx dmg file

* megan: add java to build requirements

* megan: removed new line

* megan: removed osx sources

* Update meta.yaml

* bumping hulk (#11607)

* Update hotspot3d to 1.8.2 (#11521)

* Update hotspot3d to 1.8.2

* Add perl-json as dependency

* Add perl-archive-extract as dependency

* Fqzcomp (#11606)

* Added recipe for fqzcomp

* There is no configure script

* Maybe this works

* Added gcc as build requirement

* Removed gcc again (lint issue)

* Maybe these exports will do the trick

* Nope!

* Added cxx as host requirement

* Compilers are only allowed in build section

* There is no need for make install

* Copy-paste error...

* Add vcf-annotator recipe (#11481)

* Add vcf-annotator recipe

* added pyvcf dependency

* Update meta.yaml

* stacks: fix for @ in exe_path (#11580)

* stacks: fix for @ in exe_path

* stacks: fixed path

* New version with bugfix and different progressiveMauve version. (#11613)

* Sspupdate (#11614)

* New version with bugfix and different progressiveMauve version.

* Keeping old version as folder.

* Push build number.

* Update SVDB to version 1.3.0 (#11506)

* 	new file:   recipes/svdb/1.1.2/meta.yaml
	renamed:    reipes/svdb/svdb.patch -> recipes/svdb/1.1.2/svdb.patch
	modified:   recipes/svdb/meta.yaml

* 	deleted:    1.1.2/meta.yaml
	deleted:    1.1.2/svdb.patch

* Bump nanosim (#11608)

* Bump nanosim

* Add scipy as dep

* Add recipe for perl-number-range (#11621)

* New build for grid (#11620)

* update grid

* update build num

* Recipe for das_tool 1.1.1 (#10528)

* recipe for das_tool 1.1.1

* Add recipe for sompy (#11624)

* cmake modified to build with NDEBUG (#11328)

* cmake modified to build with NDEBUG

* Update meta.yaml

* new build with fasta test

* new build with fasta test

* Fix and unblacklist TwoPaCo (#11622)

* Add recipe for TwoPaCo

* Unblacklist twopaco

* Modify and unblacklist recipe for ESTmapper (#11623)

* Modify and unblacklist recipe for ESTmapper

* Add patch

* Modify and unblacklist recipe for Metaseq (#11625)

* Fix recipe for metaseq and remove from blacklist

* Remove build.sh

* nextflow 18.10.1 build 2 (#11630)

* Add Clust (#11619)

* Add clust

* Clean recipe

* Add "noarch"

* Add DOI

* Add build file

* Python 2.7

* Fix scikit-learn dependency

* Trigger new build

* Update: PureCN (multicore) and PURPLE (plotting X libraries) (#11631)

- PureCN: adds support for specifying cores on command line
- PURPLE: adds X library dependencies required for creating
  plots

* scripts/travis-run.sh: added a cleaner method to check for env vars (#11612)

* Increase the number of k value usable in bcalm (request by @Malfoy) (#11610)

* Increase the number of k value usable in bcalm (request by @Malfoy)

* Change compilation parameter to reduce memory impact of compilation

* Update anndata to 0.6.11 (#11637)

* Update nglview to 1.1.7 (#11643)

* Update binsanity to 0.2.7.1 (#11644)

* Update cgat-core to 0.5.4 (#11645)

* Update nanosv to 1.2.2 (#11673)

* Update abeona to 0.36.0 (#11670)

* Update pyfaidx to 0.5.5.2 (#11659)

* Update agfusion to 1.23 (#11668)

* Update iqtree to 1.6.8 (#11686)

* update iqtree to 1.6.8

* Trigger rebuild

* Update validators to 0.12.2 (#11672)

* Update python-edlib to 1.2.3.post1 (#11664)

* update for Purge Haplotigs (#11690)

* Update loompy to 2.0.16 (#11667)

* Update loompy to 2.0.16

* Update meta.yaml

* IgBLAST 1.10.0 (#11693)

* Update wtforms-alchemy to 0.16.7 (#11679)

* Update sickle to 0.6.4 (#11663)

* Update sickle to 0.6.4

* Remove fn and libgcc runtime dep

* Update confindr to 0.4.5 (#11696)

* Batvi (#11695)

* batvi initial

* Guideline compatibility..

* Dummy test section..

* Missing java dependency..

* use openjdk instead of java-jdk ..

* source specified in github ..

* trigger build (package did not have batindel directory) ..

* update SHA256 ..

* update SHA256 ..

* Update pythonpy to 0.4.11 (#11661)

* Update cortexpy to 0.45.6 (#11660)

* Update sevenbridges-python to 0.16.0 (#11674)

* Update solvebio to 2.7.0 (#11657)

* Update mathstats to 0.2.6.5 (#11656)

* Update goatools to 0.8.9 (#11641)

* Add gnies (#11627)

* Add gnies

* noarch python

* Update meta.yaml

* Add recipe for SKA v1.0 (#11581)

* Add recipe for SKA v1.0
* Add lib path for zlib
* Older gcc
* Correct install dir
* Try static linking
* Dynamic linking on OS X
* ldd command test
* correct program
* Remove ldd command

* Add recipe for transit version 2.3.1 (#11701)

* Add recipe for transit version 2.3.1

* Use skip, add spaces.

* Update meta.yaml (#11699)

* remove pyqi (#11704)

* Update python-chado to 2.2.0 (#11714)

* update python-chado

* 2.2.1

* Update vcfanno to 0.3.1 (#11710)

* FGMP-1.0.1 (#11278)

* FGMP-1.0.1 recipe
* remove unncessary build info

* add r-nabor (#11716)

* update stream to 0.2.2

* update stream to 0.2.3

* update stream to 0.2.4

* update stream to 0.2.4

* update stream to 0.2.4

* update stream to 0.2.5

* update stream to 0.2.6

* add r-nabor recipe

* update r-nabor recipe

* update r-nabor recipe

* r-pctgcdata (#11715)

* r-pctgcdata

* r-pctgcdata - fix

* r-pctgcdata - fix

* Update meta.yaml

* Fix plek by a new branch (#11605)

* Modify the PLEK recipe

* Start fixing PLEK, though it requires compilation

* update build.sh

* update yaml

* fix build.sh

* update build.sh

* Update recipe for plek

* add bioconductor-chromvar recipe (#11718)

* add bioconductor-chromvar recipe

* fix bioconductor-tissueenrich

* Apparently the popdel recipe didn't get correctly merged

* Final merge conflicts

bgruening added a commit that referenced this pull request Oct 31, 2018

merge bulk into master (#11728)
* update mzr as a test

* Begin building for R 3.5.1 (#11252)

* Bump everything for R 3.5.1

* Fix most of the linting issues

* Update blacklist

* Revert "Fix most of the linting issues"

This reverts commit a271e50.

* should_not_use_fn

* More fixes

* Fix incorrect yaml

* Should really fix the linting blacklist stuff

* Fix many recipes

* Fix some linting

* Fix r-wicket

* Update derfinder

* Pin to a given bioconductor release.

* Add missing packages

* Restore identifiers to bioconductor packages

* Restore extra information to R packages

* Update R bulk (#11283)

* fixed incorrect doi of publication (#11175)

* Added recipe for kinSimRiboswitch (#10838)

Added recipe for kinSimRiboswitch, a pipeline for simulating the folding
kinetics of RNA switches.

* update multiqc-bcbio (#11187)

* Add recipe for PopDel (#11181)

* Add recipe for PopDel

* Add clang and clangxx to build config

* update seqbuster (#11190)

* update seqbuster

* fix build

* fix test

* Update pyseer to 1.1.2 (#11172)

* bump sourmash (#11197)

* Update BASIC to v1.4.1 (#11195)

* Update BASIC to v1.4.1

* Trigger circleci

* Fix build number

* Update nf-core-1.2 (#11191)

* Update nf-core-1.2

* Update build script

* Update to InterMine 1.11.0 (#11182)

* Update meta.yaml

* Update meta.yaml

* Update meta.yaml

* Add tinyfasta-0.1.0 (#11177)

* Add tinyfasta

* Update build script

* Fix structure of build section

* Bumping snippy  (#11198)

* Remove older version

* Bump snippy

* VEP: bump major version (#11201)

* VEP: bump major version

* VEP: bumped plugin major version

* VEP: update plugin install

Download and install all plugin modules, instead of just a selection

* Update: PureCN to latest devel (1.11.13); wrapper scripts (#11200)

* Update: PureCN to latest devel (1.11.13); wrapper scripts

PureCN development (https://github.com/lima1/PureCN) has several
improvements over the BioC 3.6 release for handling multiple VCF input
types, and is back compatible with R 3.4.1 so still builds cleanly
with two new dependencies.

Also exposes PureCN wrapper scripts for running from the command line.
Prefixes ambiguous scripts with PureCN_.

* Try pinning to 3.4 to avoid 3.5.1 builds which we don't want yet

* add cassiopee release 1.0.9 (#11168)

* add cassiopee release 1.0.9

* update to conda build 3

* remove old version backup and use sha256 for source

* Bump abeona version to 0.26.0 (#11202)

* Bump abeona version to 0.24.0

* Bump abeona version to 0.26.0

* Update LexMapr to v0.1.2 (#11192)

* Update LexMapr to v0.1.2

* Add rdflib dep

* Update svtyper to 0.7.0 (#11196)

* Update svtyper to 0.7.0

* Add recipe for perl-gtdbtk (#11194)

* Add recipe for perl-gtdbtk

* New recipe for RFMix (#11205)

* New recipe for RFMix
* updated version number information
* updated version number information
* updated version number information

* initial purge_haplotigs commit (#11049)

* initial purge_haplotigs commit
* bioconda revisions, updating test commands to run the pipeline on the test dataset
* rolling back test commands

* Add recipe for fsm-lite (#11209)

* Add recipe for fsm-lite
* Add prefix to make
* Remove v from version string

* Updated reparation_blast to version v.1.0.7 (#11210)

* Update sambamba to 0.6.8 (#11212)

* Bump sambamba to 0.6.8

* It's somewhat annoying that missing_hash is thrown even if uses_git_url is specified.

* Set some environment variables

* The compiled binary is in a different place now

* ldc provides some libraries that are linked against.

* mtbseq: update recipe (#11110)

* changed download location/add test

* remove test

* Confindr (#11217)

* Update confindr to 0.4.2

* Fix typo in specifying version of pysam

* Update Genenotebook to v0.1.4 (#11218)

* genenotebook recipe

* About

* Package name

* License

* sha256sum

* Update build.sh

* Make bin dir

* Change ln to cp

* New symlink strategy

* Build from prebundled tarball

* genenotebook v0.1.2

* version fix

* retry

* fix

* build number

* genenotebook v0.1.3

* restore build procedure

* Fix summary

* updating to 0.1.3 (#11221)

* sartools1.6.6 (#11222)

* Perl bio automatedannotation (#11216)

* Initial recipe for Bio-AutomatedAnnotation

* Change URL

* Run cpanm tests

* Temporarily set HOME

* Use cpan version instead

* Add more depencencies

* Set bioperl version

* unset bioperl version, add bioperl-run

* New release including version in modules

* Remove comments

* build -> host

* Upgrade r-biodb to v1.1.2. (#11213)

* Upgrade r-biodb to v1.1.2.
* Remove old versions of r-biodb.
* Comment out libgfortran.

* PeptideShaker: updated to version 1.16.30 & SearchGUI: updated to version 3.3.5 (#11215)

* PeptideShaker: updated to version 1.16.30

- Bugfix: HOME was still being used when folder with customised reports was specified.
- Bugfix: Made it possible to use the MzidCLI options directly on the PeptideShakerCLI command line.

* SearchGUI: updated to version 3.3.5.

- BUG FIX: Cleanup of the temp path options when used as options for the other command lines.
- FEATURE IMPROVEMENT: Updated Comet to 2018.01 rev. 2.
- LIBRARY UPDATE: Updated utilities to version 4.12.8.

* Update meta.yaml (#11227)

* Svtools 0.4.0 (#11208)

* Remove directories for old svtools versions

* Update svtools to v0.4.0

* Move build number back to 0

* Anvio 52 (#11230)

* Incrementing version to 5.2. Splitting out anvio-minimal package to just install the pip package. The anvio package will install it and all the most likely companion software.

* Remove cgat-scripts from blacklist. (#11228)

* Add new formula: bazam 1.0.1  (#11229)

* Update gatk4 to 4.0.10.0 (#11224)

* Add recipe for gtdbtk 0.1.3 (#11211)

* Add recipe for gtdbtk

* Added initial htstream recipe (#11113)

* HTStream is a fast, quality control pipeline for Hight Throughput Sequencing data. The difference between HTStream and other pipelines is that HTStreams uses a tab delimited fastq format which allows for streaming from application to application. This streaming creates some awesome efficiencies when processing HTS data.

* DeepTools 3.1.3 (#11226)

* PacBio: Update `pbmm2` to version 0.10.0 (#11225)

* fastqc: update to version 0.11.8 (#11214)

* fastqc: update to version 0.11.8

* Update meta.yaml

* Phame (#11223)

* mac recipe and added bioperl

*  changing bill number

* added no osx

* adding new version

* removed separate recipe for mac, dont need it

* now running same recipe for mac and linux

* fixed the way fasttrees version was being parsed

* minor change test

* adding detailed description

* restaging the build number

* new version

* Make sure to use bioperl and perl 5.26

* Updated ngs-bits to version 2018_10 (#11235)

* PacBio: Update `pbsv2` to version 2.0.2 (#11236)

* Update VSEARCH to 2.8.5 (#11239)

* Fix shorah recipe and remove from blacklist. (#11241)

* Fix shorah recipe and remove from blacklist.

* Fix blas variant.

* Remove imports from tests.

* unicycler 0.4.7 (#11240)

* unicycler 0.4.7

* unicycler: Work around ValueError: invalid

Unicycler thinks the terminal has 0 columns and produces this error:
File "/usr/local/Cellar/python/3.7.0/Frameworks/Python.framework/Versions/3.7/lib/python3.7/textwrap.py", line 248, in _wrap_chunks
raise ValueError("invalid width %r (must be > 0)" % self.width)
ValueError: invalid width -5 (must be > 0)

* Octopus: update to 0.5.1-beta (#11244)

* New: PURPLE SV caller; Update: VarDictJava (1.5.6), PureCN (#11247)

- PURPLE SV and heterogeneity caller for somatic tumor/normal samples.
- VarDictJava -- 1.5.6 release with fixes for SV calling
- PureCN -- add signature dependency and update with fixes for test
  samples.

* Dinucleotide patterns analysis tools v1.0 (#11245)

* Dinucleotide patterns analysis tools v1.0

* Lets try it, it seems to work locally for me.

* Enable SpoTyping_plot.r (#11248)

* rerun again (#11233)

* rerun again

* Update meta.yaml

* Delete build.sh

* Update segway dependency optbuild to 0.2 (#10459)

* Update segway dependency optbuild to 0.2

* Update build and architecture requirements for optbuild 0.2

* Add six as a dependency to the optbuild recipe

* Dinucleotide patterns analysis tools v1. / Add prefix dnp- to the package names (#11249)

* Add prefix dnp- to the package names

* Update build.sh

* Update build.sh

* Bump beast version to 1.10.2 (#11250)

* add maxquant (#11253)

* add mayquant

* relax tests

* PacBio: Update `pbmm2` to version 0.10.1 (#11256)

* PacBio: Update `pbmm2` to version 0.10.1-1 (#11257)

* remove xsv recipe (#11259)

* add blast dependency (#11258)

* Added riborex recipe (#11251)

* Added riborex recipe

* Relaxed version constraints

* Pinned r-core for fdr tools

* fixed the r-base stuff upstream

* Update meta.yaml

* fix graphprot (#11234)

* increase build number

* remove from blacklist

* use cxx instead of c

* move coreutoils to build section

* set additional paths

* patch makefile

* blind try

* update patch

* explicitely copy from src_dir

* update deprecated prefix variable

* Revert "update deprecated prefix variable"

This reverts commit 2559439.

* update deprecated prefix variable

* try moving to host section

* Bump mash (#11264)

* Add fmlrc (#11265)

* Add fmlrc

* add doi

* PacBio: Update pb-falcon to 0.2.4. (#11266)

* Add kopt recipe (#11269)

* Genomepy 0.5.2 (#11267)

* release 0.5.2 of genomepy

* trigger new build

* remove genomepy from blacklist

* locale for osx

* updated locale test

* PacBio: Update pb-assembly to 0.0.2. Bumped the pinned version for pb-falcon. (#11275)

* Update mmseqs2 recipe to new release 6-f5a1c (#11272)

* Update yacrd to version 0.4.1 (#11273)

* Add scprep (#11270)

* Add scprep

* All of these should not be needed as host dep

* Metawrap preqs2 (#11242)

* fixed issues

* fixed issues

* added tests

* fixed tab

* gemma 0.98 (#11254)

* gemma 0.98

* gemma 0.98

Leave gsl and zlib out of runtime dependencies

* Add DCA recipe (#11274)

* Add DCA recipe

* add noarch and doi

* remove skip

* Fix a bunch of packages that are actually in bioconductor and try to fix bioconductor-rhtslib

* Various fixes for bulk and trigger a rebuild (#11313)

* Various fixes, at least 4 packages (and their dependencies) should still fail (#11320)

* A few fixes, remove a package from the blacklist since it prevents trumicounts from building. (#11336)

* Fix various recipes (#11354)

* Fix various recipes

* Fix more recipes

* Various CRAN package fixes, since they all lack license files (#11372)

* Various CRAN package fixes, since they all lack license files

* Fix the r-dartr recipe

* There is a light at the end of the tunnel (#11381)

* There is a light at the end of the tunnel

* Licenses no longer exist

* [BULK] Fixes for R/Bioconductor packages (#11406)

* Require `r-base >=3.5` for some packages

* Fix various CRAN packages lacking license file

* Add missing libnetcdf requirement to bioconductor-mzr

* Remove r-alakazam (moved to conda-forge)

Fix linting issue:
```
recipes/r-alakazam	in_other_channels	{'exists_in_channels': {'conda-forge'}, 'fix': 'consider deprecating'}	{'conda-forge'}	consider deprecating
```

* [BULK] Many R 3.5 only packages (#11410)

* [BULK] Bulk update 191018b (#11419)

* update mzr as a test

* Begin building for R 3.5.1 (#11252)

* Bump everything for R 3.5.1

* Fix most of the linting issues

* Update blacklist

* Revert "Fix most of the linting issues"

This reverts commit a271e50.

* should_not_use_fn

* More fixes

* Fix incorrect yaml

* Should really fix the linting blacklist stuff

* Fix many recipes

* Fix some linting

* Fix r-wicket

* Update derfinder

* Pin to a given bioconductor release.

* Add missing packages

* Restore identifiers to bioconductor packages

* Restore extra information to R packages

* Update R bulk (#11283)

* fixed incorrect doi of publication (#11175)

* Added recipe for kinSimRiboswitch (#10838)

Added recipe for kinSimRiboswitch, a pipeline for simulating the folding
kinetics of RNA switches.

* update multiqc-bcbio (#11187)

* Add recipe for PopDel (#11181)

* Add recipe for PopDel

* Add clang and clangxx to build config

* update seqbuster (#11190)

* update seqbuster

* fix build

* fix test

* Update pyseer to 1.1.2 (#11172)

* bump sourmash (#11197)

* Update BASIC to v1.4.1 (#11195)

* Update BASIC to v1.4.1

* Trigger circleci

* Fix build number

* Update nf-core-1.2 (#11191)

* Update nf-core-1.2

* Update build script

* Update to InterMine 1.11.0 (#11182)

* Update meta.yaml

* Update meta.yaml

* Update meta.yaml

* Add tinyfasta-0.1.0 (#11177)

* Add tinyfasta

* Update build script

* Fix structure of build section

* Bumping snippy  (#11198)

* Remove older version

* Bump snippy

* VEP: bump major version (#11201)

* VEP: bump major version

* VEP: bumped plugin major version

* VEP: update plugin install

Download and install all plugin modules, instead of just a selection

* Update: PureCN to latest devel (1.11.13); wrapper scripts (#11200)

* Update: PureCN to latest devel (1.11.13); wrapper scripts

PureCN development (https://github.com/lima1/PureCN) has several
improvements over the BioC 3.6 release for handling multiple VCF input
types, and is back compatible with R 3.4.1 so still builds cleanly
with two new dependencies.

Also exposes PureCN wrapper scripts for running from the command line.
Prefixes ambiguous scripts with PureCN_.

* Try pinning to 3.4 to avoid 3.5.1 builds which we don't want yet

* add cassiopee release 1.0.9 (#11168)

* add cassiopee release 1.0.9

* update to conda build 3

* remove old version backup and use sha256 for source

* Bump abeona version to 0.26.0 (#11202)

* Bump abeona version to 0.24.0

* Bump abeona version to 0.26.0

* Update LexMapr to v0.1.2 (#11192)

* Update LexMapr to v0.1.2

* Add rdflib dep

* Update svtyper to 0.7.0 (#11196)

* Update svtyper to 0.7.0

* Add recipe for perl-gtdbtk (#11194)

* Add recipe for perl-gtdbtk

* New recipe for RFMix (#11205)

* New recipe for RFMix
* updated version number information
* updated version number information
* updated version number information

* initial purge_haplotigs commit (#11049)

* initial purge_haplotigs commit
* bioconda revisions, updating test commands to run the pipeline on the test dataset
* rolling back test commands

* Add recipe for fsm-lite (#11209)

* Add recipe for fsm-lite
* Add prefix to make
* Remove v from version string

* Updated reparation_blast to version v.1.0.7 (#11210)

* Update sambamba to 0.6.8 (#11212)

* Bump sambamba to 0.6.8

* It's somewhat annoying that missing_hash is thrown even if uses_git_url is specified.

* Set some environment variables

* The compiled binary is in a different place now

* ldc provides some libraries that are linked against.

* mtbseq: update recipe (#11110)

* changed download location/add test

* remove test

* Confindr (#11217)

* Update confindr to 0.4.2

* Fix typo in specifying version of pysam

* Update Genenotebook to v0.1.4 (#11218)

* genenotebook recipe

* About

* Package name

* License

* sha256sum

* Update build.sh

* Make bin dir

* Change ln to cp

* New symlink strategy

* Build from prebundled tarball

* genenotebook v0.1.2

* version fix

* retry

* fix

* build number

* genenotebook v0.1.3

* restore build procedure

* Fix summary

* updating to 0.1.3 (#11221)

* sartools1.6.6 (#11222)

* Perl bio automatedannotation (#11216)

* Initial recipe for Bio-AutomatedAnnotation

* Change URL

* Run cpanm tests

* Temporarily set HOME

* Use cpan version instead

* Add more depencencies

* Set bioperl version

* unset bioperl version, add bioperl-run

* New release including version in modules

* Remove comments

* build -> host

* Upgrade r-biodb to v1.1.2. (#11213)

* Upgrade r-biodb to v1.1.2.
* Remove old versions of r-biodb.
* Comment out libgfortran.

* PeptideShaker: updated to version 1.16.30 & SearchGUI: updated to version 3.3.5 (#11215)

* PeptideShaker: updated to version 1.16.30

- Bugfix: HOME was still being used when folder with customised reports was specified.
- Bugfix: Made it possible to use the MzidCLI options directly on the PeptideShakerCLI command line.

* SearchGUI: updated to version 3.3.5.

- BUG FIX: Cleanup of the temp path options when used as options for the other command lines.
- FEATURE IMPROVEMENT: Updated Comet to 2018.01 rev. 2.
- LIBRARY UPDATE: Updated utilities to version 4.12.8.

* Update meta.yaml (#11227)

* Svtools 0.4.0 (#11208)

* Remove directories for old svtools versions

* Update svtools to v0.4.0

* Move build number back to 0

* Anvio 52 (#11230)

* Incrementing version to 5.2. Splitting out anvio-minimal package to just install the pip package. The anvio package will install it and all the most likely companion software.

* Remove cgat-scripts from blacklist. (#11228)

* Add new formula: bazam 1.0.1  (#11229)

* Update gatk4 to 4.0.10.0 (#11224)

* Add recipe for gtdbtk 0.1.3 (#11211)

* Add recipe for gtdbtk

* Added initial htstream recipe (#11113)

* HTStream is a fast, quality control pipeline for Hight Throughput Sequencing data. The difference between HTStream and other pipelines is that HTStreams uses a tab delimited fastq format which allows for streaming from application to application. This streaming creates some awesome efficiencies when processing HTS data.

* DeepTools 3.1.3 (#11226)

* PacBio: Update `pbmm2` to version 0.10.0 (#11225)

* fastqc: update to version 0.11.8 (#11214)

* fastqc: update to version 0.11.8

* Update meta.yaml

* Phame (#11223)

* mac recipe and added bioperl

*  changing bill number

* added no osx

* adding new version

* removed separate recipe for mac, dont need it

* now running same recipe for mac and linux

* fixed the way fasttrees version was being parsed

* minor change test

* adding detailed description

* restaging the build number

* new version

* Make sure to use bioperl and perl 5.26

* Updated ngs-bits to version 2018_10 (#11235)

* PacBio: Update `pbsv2` to version 2.0.2 (#11236)

* Update VSEARCH to 2.8.5 (#11239)

* Fix shorah recipe and remove from blacklist. (#11241)

* Fix shorah recipe and remove from blacklist.

* Fix blas variant.

* Remove imports from tests.

* unicycler 0.4.7 (#11240)

* unicycler 0.4.7

* unicycler: Work around ValueError: invalid

Unicycler thinks the terminal has 0 columns and produces this error:
File "/usr/local/Cellar/python/3.7.0/Frameworks/Python.framework/Versions/3.7/lib/python3.7/textwrap.py", line 248, in _wrap_chunks
raise ValueError("invalid width %r (must be > 0)" % self.width)
ValueError: invalid width -5 (must be > 0)

* Octopus: update to 0.5.1-beta (#11244)

* New: PURPLE SV caller; Update: VarDictJava (1.5.6), PureCN (#11247)

- PURPLE SV and heterogeneity caller for somatic tumor/normal samples.
- VarDictJava -- 1.5.6 release with fixes for SV calling
- PureCN -- add signature dependency and update with fixes for test
  samples.

* Dinucleotide patterns analysis tools v1.0 (#11245)

* Dinucleotide patterns analysis tools v1.0

* Lets try it, it seems to work locally for me.

* Enable SpoTyping_plot.r (#11248)

* rerun again (#11233)

* rerun again

* Update meta.yaml

* Delete build.sh

* Update segway dependency optbuild to 0.2 (#10459)

* Update segway dependency optbuild to 0.2

* Update build and architecture requirements for optbuild 0.2

* Add six as a dependency to the optbuild recipe

* Dinucleotide patterns analysis tools v1. / Add prefix dnp- to the package names (#11249)

* Add prefix dnp- to the package names

* Update build.sh

* Update build.sh

* Bump beast version to 1.10.2 (#11250)

* add maxquant (#11253)

* add mayquant

* relax tests

* PacBio: Update `pbmm2` to version 0.10.1 (#11256)

* PacBio: Update `pbmm2` to version 0.10.1-1 (#11257)

* remove xsv recipe (#11259)

* add blast dependency (#11258)

* Added riborex recipe (#11251)

* Added riborex recipe

* Relaxed version constraints

* Pinned r-core for fdr tools

* fixed the r-base stuff upstream

* Update meta.yaml

* fix graphprot (#11234)

* increase build number

* remove from blacklist

* use cxx instead of c

* move coreutoils to build section

* set additional paths

* patch makefile

* blind try

* update patch

* explicitely copy from src_dir

* update deprecated prefix variable

* Revert "update deprecated prefix variable"

This reverts commit 2559439.

* update deprecated prefix variable

* try moving to host section

* Bump mash (#11264)

* Add fmlrc (#11265)

* Add fmlrc

* add doi

* PacBio: Update pb-falcon to 0.2.4. (#11266)

* Add kopt recipe (#11269)

* Genomepy 0.5.2 (#11267)

* release 0.5.2 of genomepy

* trigger new build

* remove genomepy from blacklist

* locale for osx

* updated locale test

* PacBio: Update pb-assembly to 0.0.2. Bumped the pinned version for pb-falcon. (#11275)

* Update mmseqs2 recipe to new release 6-f5a1c (#11272)

* Update yacrd to version 0.4.1 (#11273)

* Add scprep (#11270)

* Add scprep

* All of these should not be needed as host dep

* Metawrap preqs2 (#11242)

* fixed issues

* fixed issues

* added tests

* fixed tab

* gemma 0.98 (#11254)

* gemma 0.98

* gemma 0.98

Leave gsl and zlib out of runtime dependencies

* Add DCA recipe (#11274)

* Add DCA recipe

* add noarch and doi

* remove skip

* Fix a bunch of packages that are actually in bioconductor and try to fix bioconductor-rhtslib

* Various fixes for bulk and trigger a rebuild (#11313)

* Various fixes, at least 4 packages (and their dependencies) should still fail (#11320)

* A few fixes, remove a package from the blacklist since it prevents trumicounts from building. (#11336)

* Fix various recipes (#11354)

* Fix various recipes

* Fix more recipes

* Various CRAN package fixes, since they all lack license files (#11372)

* Various CRAN package fixes, since they all lack license files

* Fix the r-dartr recipe

* There is a light at the end of the tunnel (#11381)

* There is a light at the end of the tunnel

* Licenses no longer exist

* [BULK] Fixes for R/Bioconductor packages (#11406)

* Require `r-base >=3.5` for some packages

* Fix various CRAN packages lacking license file

* Add missing libnetcdf requirement to bioconductor-mzr

* Remove r-alakazam (moved to conda-forge)

Fix linting issue:
```
recipes/r-alakazam	in_other_channels	{'exists_in_channels': {'conda-forge'}, 'fix': 'consider deprecating'}	{'conda-forge'}	consider deprecating
```

* [BULK] Many R 3.5 only packages (#11410)

* Update pinning to R>=3.5 and a few runtime dependencies.

* CSAW is R 3.5 only

* Packages using beachmat are 3.5 only

* Packages using bioconductor-singlecellexperiment are R 3.5 only

* [BULK] Don't use r-base >=3.5, use a conda_build_config.yaml instead (#11452)

* Don't use r-base >=3.5, use a conda_build_config.yaml instead

* blacklist r-phangorn

* Update variancepartition

* R 3.5 for packages requiring singlecellexperiment

* Update a few packages

* Update a number of recipes (#11482)

* Update ensemblVEP and derfinder (#11504)

* Bulk update 251018 (#11577)

* [BULK] various package updates

* blacklist bioconductor-mzr

* A couple tweaks

* [BULK] Update 261018 (#11611)

* Apparently the r-rgeos bit works properly now.

* Add tissueenrich and try to fix scpipe on Linux

* A meaningless change just to trigger an update in bulk. (#11618)

* [BULK] update 271018 (#11628)

* Bump bioconductor-esetvis

* Fix yaqcaffy

* Fix more

* Another R 3.5 recipe

* [BULK] update 281018 (#11689)

* Add some files

* Fix arrayexpress

* Fix another 2

* Blacklist a bunch of bioconductor recipes that aren't likely to get built for a variety of reasons (mostly due to mzR). (#11697)

* Update blacklist (#11706)

* [BULK] fix bioconductor-tissueenrich (#11720)

* taxonkit 0.2.5 (#11318)

* Update csvtk (#11319)

* taxonkit 0.2.5

* csvtk 0.15.0

* bumping GROOT to 0.8.1 (#11323)

* HiCMatrix version 3 (#11322)

* Correcting dependencies

* Version 3 of HiCMatrix, the October release

* Update confindr to 0.4.3 (#11330)

* Drop-seq_tools: Version 2.0.0 (#11326)

* Update meta.yaml
* Update build.sh

some tool names changed to fit Camel case

* Update motus to build only for python3 (#11331)

* Update fpa to 0.2 version (#11333)

* update taxonkit to 0.3.0 (#11339)

* ntcard 1.1.0 (#11338)

* Update rgi (#11335)

* first commit

* update dependencies list

* change source to github

* change build number

* testing circleci

* update meta and build

* fix build

* move build script into meta

* remove older recipes

* line fix in bootstrap.py

* change python & matplotlib versions; add build.sh file

* add preprocessing selector to skip python 2.7

* move build script into meta.yaml

* Revert "line fix in bootstrap.py"

This reverts commit 5ac1ecd.

* Update gmap to version 2018-07-04. (#11332)

MAX_READLENGTH environment variable has been disused since 2016-08-16.

* Upgrade r-biodb to 1.2.0a. (#11341)

* Upgrade r-biodb to 1.2.0a.

* Update meta.yaml

* Updated ont-tombo to version 1.5. (#11329)

* Updated ont-tombo to version 1.5.

* Updated with actual github release version hash.

* remove graphicsmagick (#11342)

* Build  kraken2 for osx (#11343)

* First try for a bcalm recipes (#11344)

* New: cgpbigwig (BigWig manipulation); Update: bcbio (#11347)

- cgpbigwig (https://github.com/cancerit/cgpBigWig) provides bigwig
  generation and manipulation command line tools including bam to bigwig
  conversion.
- bcbio: fixes for QC on variants and peddy for CWL runs

* Try avoid some dependancy (#11349)

* Update TreeBest to commit c9d3a2e35276c825577ec945b229e975c32078d8 (#11348)

* Update TreeBest to commit c9d3a2e35276c825577ec945b229e975c32078d8

Also add about:home .

* Workaround conda-forge/bison-feedstock#7

* Better bcalm recipes (#11350)

* Try avoid some dependancy

* Correct mess in build number, sorry

* R biodb (#11351)

* rebuild r-biodb

* trigger build

* Add recipe for pypairs (#11356)

* Update smoove to 0.2.1. (#11360)

* Update duphold to 0.0.9. (#11359)

* Update goleft to 0.2.0 (#11361)

* Bump slicedimage to 1.0.0 (#11362)

* Bump slicedimage to 1.0.1 (#11365)

* Added new versions for biopet-sampleconfig (#11268)

* perl-velvetoptimiser: update to 2.2.6 (#11369)

* update to 2.2.6

* remove unneeded patch

* Scanpy upgrade (#11371)

* Bump version

* Upgrade Scanpy

* Bump starfish to 0.0.25 (#11370)

* bumping groot to 0.8.2 (#11374)

* vep: bump subversion (#11367)

* Updated Krocus 1.0.1 (#11355)

* Add tiptoft

* Fix meta.yaml for tiptoft

* Add build script

* Updated krocus 1.0.1

* Add tiptoft 0.1.4 (#11352)

* Add tiptoft

* Fix meta.yaml for tiptoft

* Add build script

* Kodoja v0.0.9 (#11373)

* Add recipe for seer (#11263)

* Add recipe for seer

* lets try this

* Add newer compiler

* Using boost-cpp

* messed up version string

* Attempt building boost

* Use c++11 in boost

* Use python for boost install

* Correct python version spec

* try with different python version

* Fix b2 command

* Fix popd command

* build and link boost program options statically

* Fix tests

* Match dependency order

* Link openblas instead of blas

* Forcing rebuild with openblas

* Don't use armadillo wrapper

* Making review changes. Also trying original tests

* Previous tests were correct

* Add recipe for the translate-gard npm package version 1.0.3 (#11364)

* Fix umi tools (#11376)

 umi_tools: clean up dependencies

* add support tools to PATH (#11379)

* Bump to v2.2.1 (#11380)

* Bump starfish to 0.0.26 (#11378)

* Update fpa to 0.3 (#11375)

* Update fpa to 0.3

* Correct error in sha256

* Reset build number

* Update trial to 2.5.5 (#11386)

* Update: bioconductor-titancna; 1.19.1 with hg38 support (#11388)

* Update: bioconductor-titancna; 1.19.1 with hg38 support

* Pin to R 3.4 to avoid pulling in 3.3 and 3.5 during mulled

* Add r-polysat version 1.7-3 (#11384)

* Update biomart version so that compatible with r351 (#11366)

* Update biomart version so that compatible with r351

* Update meta.yaml

reset build number as per https://bioconda.github.io/guidelines.html#buildnum

* Update entrez-direct to 10.0.20180927. (#11387)

* Added recipe for SonicParanoid 1.0.13 (#11271)

* Added recipe for SonicParanoid 1.0.13

* removed 'x.x' for numpy, added basic test

* fixed linter related errors

* compiler set to cxx and added host section (same build error!)

* removed host section

* moved numpy and cython to host section; restored build: noarch: python; added LICENSE.md

* removed build: noarch

* added build and extra sections

* set build number to 0; removed skip build; added python3 minimum version; added test for all executables.

* restored sh python module as requirement

* added Make to run; updated release to latest commit

* remove c compiler from meta.yaml

* modified build.sh to compile source codel added make in build section

* updated to latest commit

* updated to latest version with make included in setup.py

* reverted build.sh to the simplest version (python setup.py install)

* Add perl-json to build requirements to allow meme-chip to run to completion. Change meme-chip to use dreme-py3 instead of dreme if building with python 3. (#11389)

* Bump IgBLAST to 1.9.0 (#11393)

Bump IgBLAST to 1.9.0

Re-package the binary version this time. There are problems building the
source version when the configure script reaches this step:
"trying to build the NCBI SRA/VDB Toolkit from GitHub"

The previous problem about the binaries linking against libbz2.so, for
which we had no conda package, is now solved.

Also, this saves about 45 minutes compilation time.

* Add consan (#11395)

* Add consan

* Skip osx

* Update: vardict, vardict-java 1.5.7 (#11394)

* Update: vardict, vardict-java 1.5.7

Latest vardict-java release and corresponding vardict with bug fixes
after testing with 1.5.6

* Reduce test output to try and fix build problems

* Experiment 2 for build problems: remove r-base from run

* Experiment 3 for build problems: add r-base in host

* update recipe for 3.9.1 (#11397)

* evofold2 (#11396)

* evofold2

* wrapper

* Update meta.yaml

* minor

* Update rnastructure to 6.1. (#11400)

* Ctat mut (#11401)

* updating version number

* correct URL

* proper hash

* Revert "Ctat mut (#11401)" (#11402)

This reverts commit 6db10ac.

* update version (#11403)

* any2fasta 0.4.2 (new formula) (#11407)

* W4mclassfilter v0.98.9 (#11385)

* Added files to build version 0.98.9

* Update meta.yaml

* Update meta.yaml

* updated SonicParanoid recipe to version 1.0.14 (#11409)

* updated SonicParanoid recipe to version 1.0.14

* Update to version 1.0.2 of PopDel (#11398)

* Update to version 1.0.2 of PopDel

Update to version 1.0.2.

* Reset build number to 0

* PacBio: require Meson 0.48.1 for all recipes (#11090)

* Meson 0.47 inserted duplicate RPATHs in
  macOS binaries, causing `install_name_tool`
  failures when installing the package.
  Requiring 0.48.1 ensures we do not run into
  these issues anymore in the future.

* rebuild with latest openmpi (#11411)

* Remove kfoots from the blacklist (#11416)

* Update gseapy to 0.9.7 (#11417)

* Update gseapy to 0.9.7

* remove noarch

* Add SC3 as dependency (#11427)

* Add recipe for r-poppr (#11418)

* Update knitr version because of Issue: rstudio/rmarkdown#1271 (#11412)

* Update IQ-TREE to 1.6.7.1 (#11429)

* Update IQ-TREE to 1.6.7.1

* Change build number

* Update: r-deconstructsigs with fixes for hg38 (#11431)

The 1.8.0 release, from 2016, has some issues with hg38 and other
custom genomes that are fixed in development (raerose01/deconstructSigs#27).
There hasn't been a new release pushed so this rolls these into a new
sub-version and makes them available.

* Update entrez-direct to 10.2.20181018. (#11432)

* Add assembly-scan recipe (#11425)

* remove python 2.7 skip (#11424)

Preparation for rnaQUAST

* Add fastq-scan recipe (#11415)

* Add patch to fix racon/rampler path in racon_wrapper. (#11434)

Fixes #11405.

* meme rebuild (#11433)

* Update nanocomp to 0.23.1 (#11436)

* Update nanocomp to 0.23.1

* remove noarch

* Update abricate to 0.8.10 (#11446)

* Update angsd to 0.923 (#11445)

* Update alfred to 0.1.13 (#11444)

* Update alfred to 0.1.13

* Try w/o patch

* Update antarna to 2.0.6 (#11442)

* Update admixtools to 5.1 (#11443)

* Update admixtools to 5.1

* Let makefile choose which bins to install

* Update alignstats to 0.5 (#11441)

* Update xatlas to 0.2.1 (#11437)

* r-gpca (#11428)

* r-gpca

* r-gpca recipe

* Update meta.yaml

* Removed All Comments

* gseapy bump version 0.9.8 (#11440)

* gseapy bump version 0.9.8

* version

* titancna: fix for hg38, remove conda build hacks (#11447)

* titancna: fix for hg38, remove conda build hacks

* Re-add r-base 3.4 pin to avoid 3.5 errors

* Hmmlearn older version (#11450)

* Adding pygtftk

* removed pygtftk from master

* add older version of hmmlearn

* Add card_trick (#11451)

* Add card_trick

* Restrict to py3

* Update checkm-genome to 1.0.12 (#11455)

* Bump drep (#11457)

* Update squid to 1.5 (#11466)

* Update ncbi-ngs-sdk to 2.9.3 (#11467)

* elprep: bumped major version (#11414)

* elprep: bumped major version

* fixed hash

* fix download link, fixed licence

* fixed tests

* skip osx build

* FRED2 as a conda package (#11469)

* Attempt to get FRED2 as a conda package

* SHA update

* 99 little bugs in the code

* Fix things Björn mentioned

* add rnaQUAST recipe (#11470)

* Update bioconda-utils to 0.14.9 (#11454)

* Rapidup (#11474)

* Update to v0.7

* Update Buildnumber

* rapid: update to v0.6

* rapid: update to v0.6

* update grid (#11478)

* Adding biobb_model recipe (#11472)

* Updated wtdbg to v2.1 (#11486)

* update stream to 0.2.6 (#11483)

* update stream to 0.2.2

* update stream to 0.2.3

* update stream to 0.2.4

* update stream to 0.2.4

* update stream to 0.2.4

* update stream to 0.2.5

* update stream to 0.2.6

* Update meta.yaml (#11487)

* Update connectome-workbench to 1.3.2 (#11468)

Now needs QT 5.7

* Update deblur to 1.1.0 (#11500)

* Update domclust to 1.2.8 (#11498)

* WisecondorX: bump version (#11501)

* Bump as GitHub wasn't working yesterday (#11502)

* Added recipe for Sequenza (#10367)

* Added recipe for Sequenza

* Removed fn entry in source section

* Trying with only one URL

* copynumber is a bioconductor package

* Added missing requirements section

* Removed mailing list address

* Added doi

* Added license_file

* Trying with different  license_file path

* Fred2 bump (#11503)

* Bump as GitHub wasn't working yesterday

* Fix licence etc

* Scanpy scripts (#11413)

Doing squash and merge as requested by @nh3 

* Bump version

* First implementation of scanpy-scripts bioconda recipe.

* fix path in build.sh

* Remove "noarch" flag as requested by bioconda recipe checklist

* Add a post install notice that post install test needs bats-core.

* Add more dependencies

* Skip building for python versions other than 3.6

* Target v0.0.2 which has non-ascii characters removed

* Lower version requirement for pandas and matplotlib to be the same as scanpy

* Requirement matplotlib>=3.0.0, declare noarch

* New: hmftools-cobalt; Update: hmftools-purple (#11507)

- hmftools-cobalt: Add latest version of PURPLE associated read counter,
  COBALT, with support for hg38.
- hmftools-purple: PURPLE release with hg38 support.

* Update Picard to 2.18.15. (#11505)

* Genenotebook (#11476)

* genenotebook recipe

* About

* Package name

* License

* sha256sum

* Update build.sh

* Make bin dir

* Change ln to cp

* New symlink strategy

* Build from prebundled tarball

* genenotebook v0.1.2

* version fix

* retry

* fix

* build number

* genenotebook v0.1.3

* restore build procedure

* Fix summary

* dependency versions

* v0.1.5

* Update pinning (#11514)

* Bump build number for updated dependency (#11510)

* Bump build number for updated dependency

* Try adding r-base to host requirements

* Try adding other requirements to host

* Pin to R version

* Update meta.yaml

* Update meta.yaml

* Update meta.yaml

* Tweak dependency version syntax

* Pin R and package versions correctly

* PacBio: Update pbcore to 1.6.5 (#11513)

* Bump r seurat scripts version (#11292)

* Bump version

* Remove noarch

* Could wrongly quoted version be causing an issue?

* Tweak pinning to try and fix CI error

* seqcluster:fix UMI detection. (#11511)

* seqcluster:fix UMI detection.

* Fix dependency

* quast 5.0.1 (#11479)

* quast 5.0.1

* quast 5.0.1: remove third-party site packages from the distibution pack

* quast 5.0.1: skip Glimmer in test

* quast 5.0.1: joblib and simplejson dependencies added to meta.yaml (Setuptools downloading is disabled in conda build)

* quast 5.0.1: explicit joblib and simplejson dependencies removed (Setuptools downloading is disabled in conda build)

* quast 5.0.1: Python 2 and 3 compatible code in build.sh

* wcX bugfixes (#11508)

* wcX bugfixes

* fixed shasum

* Update fastspar to 0.0.7 (#11515)

* Update iqtree to 1.6.7.2 (#11525)

* Update illumina-interop to 1.1.6 (#11523)

* Update hapbin to 1.3.0 (#11522)

* Update hlama to 3.0.1 (#11520)

* Update gb_taxonomy_tools to 1.0.1 (#11519)

* Update gffcompare to 0.10.5 (#11517)

* Update fast5seek to 0.1.1 (#11516)

* Update deepbinner to 0.2.0 (#11499)

* Update deepbinner to 0.2.0

* Update meta.yaml

Try same fix as in #11240

* Update ncbi-vdb to 2.9.3 (#11550)

* Update mikado to 1.2.4 (#11549)

* Update perl-pcap to 3.5.2 (#11543)

* Update python-hyphy-python to 0.1.9 (#11545)

* Update mlst to 2.15.2 (#11547)

* Update perl-sanger-cgp-vcf to 2.2.1 (#11542)

* Update merfishtools to 1.5.0 (#11537)

* Update perl-sanger-cgp-vagrent to 3.3.3 (#11536)

* Update nonpareil to 3.3.3 (#11535)

* Update prophex to 0.1.1 (#11532)

* Update krakenuniq to 0.5.3 (#11527)

* Update novoplasty to 2.7.2 (#11530)

* Update minced to 0.3.2 (#11529)

* Update mapdamage2 to 2.0.8 (#11528)

* Update perl-sanger-cgp-allelecount to 4.0.0 (#11538)

* Update pyvolve to 0.9.0 (#11531)

* Genenotebook (#11512)

* genenotebook recipe

* About

* Package name

* License

* sha256sum

* Update build.sh

* Make bin dir

* Change ln to cp

* New symlink strategy

* Build from prebundled tarball

* genenotebook v0.1.2

* version fix

* retry

* fix

* build number

* genenotebook v0.1.3

* restore build procedure

* Fix summary

* dependency versions

* v0.1.5

* version fix

* add plek (#11554)

* Update pyimzml to 1.2.4 (#11534)

* Bump shovill (#11555)

* PacBio: Update minimum pbcore version (#11556)

* We want all users of PacBio tools to be able to
  use our utilities with pbmm2 alignments.

* Add recipe for translate-gard v1.0.4 (#11557)

* bioconductor-rnaseqsamplesizedata (#11475)

* Adding Recipe for bioconductor-rnaseqsamplesizedata

* Updated metadata for RnaSeqSampleSizeData

* nextflow 18.10.1 (#11558)

* Update raxml to 8.2.12 (#11567)

* Update r-fgwas to 0.3.6 (#11566)

* Update rapid to 0.7 (#11565)

* Update r-spieceasi to 1.0.2 (#11564)

* Update rcorrector to 1.0.3.1 (#11562)

* Update quicktree to 2.4 (#11560)

* Update paladin to 1.4.4 (#11541)

* Update paladin to 1.4.4

* delete md5

* Update build.sh

* Update build.sh

* Fix and unblacklist Tadarida-D (#11568)

* Add recipe for rgt

* Fix and un-blacklist tadarida-d

* Remove RGT

* bumping groot (#11575)

* update pymzml (#11573)

* Add bioconductor-rnaseqsamplesize (#11559)

* Add bioconductor-rnaseqsamplesize

* Update recipe

* Fixing some URLs

* Update dependencies missing

* Update trumicount to 0.9.11 (#11576)

* Update ConFindr to 0.4.4 (#11578)

* Added new versions for biopet-scatterregions (#11572)

* Added new versions for biopet-bamstats (#11571)

* R ggbiplot (#11584)

* add R -e 'httr::set_config(httr::config(ssl_verifypeer = 0L)); install.packages(devtools, repos=http://mirrors.ebi.ac.uk/CRAN/); library(devtools); install_github(vqv/ggbiplot); library(ggbiplot)'

* add r-ggbiplot

* update meta.yaml

* update meta.yaml

* update

* update

* update

* update

* update

* update

* update

* update

* update

* fix errors

* fix errors number 1

* Update rebaler to 0.1.2 (#11563)

* Update rebaler to 0.1.2

* Remove fn

* bump graphclust (#11585)

* Update seqyclean to 1.10.09 (#11589)

* Update stringmlst to 0.5.1 (#11590)

* Update snp-dists to 0.6.2 (#11592)

* Update snippy to 4.3.3 (#11596)

* Update canu to 1.8 (#11600)

* Update starfish to 0.0.27 (#11599)

* Update womtool to 36 (#11594)

* Update telseq to 0.0.2 (#11598)

* Update snp-sites to 2.4.1 (#11588)

* Added recipe for pydemult: Streamed and parallel demultiplexing of fastq files (#11471)

* Added recipe for pydemult

* Bumped version in favor of py3.5

* bump vcf2db to latest commit (#11601)

* bump vcf2db to latest commit

* fix shasum

* Fixing source url

* Update: TitanCNA; hg38 cytoband support and fix for normalization (#11604)

* megan (#11046)

* megan6: initial commit

* megan6: intermediate commit

* megan: made tests work

* megan: doc improvement

* megan: added osx dmg file

* megan: add java to build requirements

* megan: removed new line

* megan: removed osx sources

* Update meta.yaml

* bumping hulk (#11607)

* Update hotspot3d to 1.8.2 (#11521)

* Update hotspot3d to 1.8.2

* Add perl-json as dependency

* Add perl-archive-extract as dependency

* Fqzcomp (#11606)

* Added recipe for fqzcomp

* There is no configure script

* Maybe this works

* Added gcc as build requirement

* Removed gcc again (lint issue)

* Maybe these exports will do the trick

* Nope!

* Added cxx as host requirement

* Compilers are only allowed in build section

* There is no need for make install

* Copy-paste error...

* Add vcf-annotator recipe (#11481)

* Add vcf-annotator recipe

* added pyvcf dependency

* Update meta.yaml

* stacks: fix for @ in exe_path (#11580)

* stacks: fix for @ in exe_path

* stacks: fixed path

* New version with bugfix and different progressiveMauve version. (#11613)

* Sspupdate (#11614)

* New version with bugfix and different progressiveMauve version.

* Keeping old version as folder.

* Push build number.

* Update SVDB to version 1.3.0 (#11506)

* 	new file:   recipes/svdb/1.1.2/meta.yaml
	renamed:    reipes/svdb/svdb.patch -> recipes/svdb/1.1.2/svdb.patch
	modified:   recipes/svdb/meta.yaml

* 	deleted:    1.1.2/meta.yaml
	deleted:    1.1.2/svdb.patch

* Bump nanosim (#11608)

* Bump nanosim

* Add scipy as dep

* Add recipe for perl-number-range (#11621)

* New build for grid (#11620)

* update grid

* update build num

* Recipe for das_tool 1.1.1 (#10528)

* recipe for das_tool 1.1.1

* Add recipe for sompy (#11624)

* cmake modified to build with NDEBUG (#11328)

* cmake modified to build with NDEBUG

* Update meta.yaml

* new build with fasta test

* new build with fasta test

* Fix and unblacklist TwoPaCo (#11622)

* Add recipe for TwoPaCo

* Unblacklist twopaco

* Modify and unblacklist recipe for ESTmapper (#11623)

* Modify and unblacklist recipe for ESTmapper

* Add patch

* Modify and unblacklist recipe for Metaseq (#11625)

* Fix recipe for metaseq and remove from blacklist

* Remove build.sh

* nextflow 18.10.1 build 2 (#11630)

* Add Clust (#11619)

* Add clust

* Clean recipe

* Add "noarch"

* Add DOI

* Add build file

* Python 2.7

* Fix scikit-learn dependency

* Trigger new build

* Update: PureCN (multicore) and PURPLE (plotting X libraries) (#11631)

- PureCN: adds support for specifying cores on command line
- PURPLE: adds X library dependencies required for creating
  plots

* scripts/travis-run.sh: added a cleaner method to check for env vars (#11612)

* Increase the number of k value usable in bcalm (request by @Malfoy) (#11610)

* Increase the number of k value usable in bcalm (request by @Malfoy)

* Change compilation parameter to reduce memory impact of compilation

* Update anndata to 0.6.11 (#11637)

* Update nglview to 1.1.7 (#11643)

* Update binsanity to 0.2.7.1 (#11644)

* Update cgat-core to 0.5.4 (#11645)

* Update nanosv to 1.2.2 (#11673)

* Update abeona to 0.36.0 (#11670)

* Update pyfaidx to 0.5.5.2 (#11659)

* Update agfusion to 1.23 (#11668)

* Update iqtree to 1.6.8 (#11686)

* update iqtree to 1.6.8

* Trigger rebuild

* Update validators to 0.12.2 (#11672)

* Update python-edlib to 1.2.3.post1 (#11664)

* update for Purge Haplotigs (#11690)

* Update loompy to 2.0.16 (#11667)

* Update loompy to 2.0.16

* Update meta.yaml

* IgBLAST 1.10.0 (#11693)

* Update wtforms-alchemy to 0.16.7 (#11679)

* Update sickle to 0.6.4 (#11663)

* Update sickle to 0.6.4

* Remove fn and libgcc runtime dep

* Update confindr to 0.4.5 (#11696)

* Batvi (#11695)

* batvi initial

* Guideline compatibility..

* Dummy test section..

* Missing java dependency..

* use openjdk instead of java-jdk ..

* source specified in github ..

* trigger build (package did not have batindel directory) ..

* update SHA256 ..

* update SHA256 ..

* Update pythonpy to 0.4.11 (#11661)

* Update cortexpy to 0.45.6 (#11660)

* Update sevenbridges-python to 0.16.0 (#11674)

* Update solvebio to 2.7.0 (#11657)

* Update mathstats to 0.2.6.5 (#11656)

* Update goatools to 0.8.9 (#11641)

* Add gnies (#11627)

* Add gnies

* noarch python

* Update meta.yaml

* Add recipe for SKA v1.0 (#11581)

* Add recipe for SKA v1.0
* Add lib path for zlib
* Older gcc
* Correct install dir
* Try static linking
* Dynamic linking on OS X
* ldd command test
* correct program
* Remove ldd command

* Add recipe for transit version 2.3.1 (#11701)

* Add recipe for transit version 2.3.1

* Use skip, add spaces.

* Update meta.yaml (#11699)

* remove pyqi (#11704)

* Update python-chado to 2.2.0 (#11714)

* update python-chado

* 2.2.1

* Update vcfanno to 0.3.1 (#11710)

* FGMP-1.0.1 (#11278)

* FGMP-1.0.1 recipe
* remove unncessary build info

* add r-nabor (#11716)

* update stream to 0.2.2

* update stream to 0.2.3

* update stream to 0.2.4

* update stream to 0.2.4

* update stream to 0.2.4

* update stream to 0.2.5

* update stream to 0.2.6

* add r-nabor recipe

* update r-nabor recipe

* update r-nabor recipe

* r-pctgcdata (#11715)

* r-pctgcdata

* r-pctgcdata - fix

* r-pctgcdata - fix

* Update meta.yaml

* Fix plek by a new branch (#11605)

* Modify the PLEK recipe

* Start fixing PLEK, though it requires compilation

* update build.sh

* update yaml

* fix build.sh

* update build.sh

* Update recipe for plek

* add bioconductor-chromvar recipe (#11718)

* add bioconductor-chromvar recipe

* fix bioconductor-tissueenrich

* Apparently the popdel recipe didn't get correctly merged

* Final merge conflicts

karel-brinda added a commit that referenced this pull request Oct 31, 2018

merge bulk into master (#11728)
* update mzr as a test

* Begin building for R 3.5.1 (#11252)

* Bump everything for R 3.5.1

* Fix most of the linting issues

* Update blacklist

* Revert "Fix most of the linting issues"

This reverts commit a271e50.

* should_not_use_fn

* More fixes

* Fix incorrect yaml

* Should really fix the linting blacklist stuff

* Fix many recipes

* Fix some linting

* Fix r-wicket

* Update derfinder

* Pin to a given bioconductor release.

* Add missing packages

* Restore identifiers to bioconductor packages

* Restore extra information to R packages

* Update R bulk (#11283)

* fixed incorrect doi of publication (#11175)

* Added recipe for kinSimRiboswitch (#10838)

Added recipe for kinSimRiboswitch, a pipeline for simulating the folding
kinetics of RNA switches.

* update multiqc-bcbio (#11187)

* Add recipe for PopDel (#11181)

* Add recipe for PopDel

* Add clang and clangxx to build config

* update seqbuster (#11190)

* update seqbuster

* fix build

* fix test

* Update pyseer to 1.1.2 (#11172)

* bump sourmash (#11197)

* Update BASIC to v1.4.1 (#11195)

* Update BASIC to v1.4.1

* Trigger circleci

* Fix build number

* Update nf-core-1.2 (#11191)

* Update nf-core-1.2

* Update build script

* Update to InterMine 1.11.0 (#11182)

* Update meta.yaml

* Update meta.yaml

* Update meta.yaml

* Add tinyfasta-0.1.0 (#11177)

* Add tinyfasta

* Update build script

* Fix structure of build section

* Bumping snippy  (#11198)

* Remove older version

* Bump snippy

* VEP: bump major version (#11201)

* VEP: bump major version

* VEP: bumped plugin major version

* VEP: update plugin install

Download and install all plugin modules, instead of just a selection

* Update: PureCN to latest devel (1.11.13); wrapper scripts (#11200)

* Update: PureCN to latest devel (1.11.13); wrapper scripts

PureCN development (https://github.com/lima1/PureCN) has several
improvements over the BioC 3.6 release for handling multiple VCF input
types, and is back compatible with R 3.4.1 so still builds cleanly
with two new dependencies.

Also exposes PureCN wrapper scripts for running from the command line.
Prefixes ambiguous scripts with PureCN_.

* Try pinning to 3.4 to avoid 3.5.1 builds which we don't want yet

* add cassiopee release 1.0.9 (#11168)

* add cassiopee release 1.0.9

* update to conda build 3

* remove old version backup and use sha256 for source

* Bump abeona version to 0.26.0 (#11202)

* Bump abeona version to 0.24.0

* Bump abeona version to 0.26.0

* Update LexMapr to v0.1.2 (#11192)

* Update LexMapr to v0.1.2

* Add rdflib dep

* Update svtyper to 0.7.0 (#11196)

* Update svtyper to 0.7.0

* Add recipe for perl-gtdbtk (#11194)

* Add recipe for perl-gtdbtk

* New recipe for RFMix (#11205)

* New recipe for RFMix
* updated version number information
* updated version number information
* updated version number information

* initial purge_haplotigs commit (#11049)

* initial purge_haplotigs commit
* bioconda revisions, updating test commands to run the pipeline on the test dataset
* rolling back test commands

* Add recipe for fsm-lite (#11209)

* Add recipe for fsm-lite
* Add prefix to make
* Remove v from version string

* Updated reparation_blast to version v.1.0.7 (#11210)

* Update sambamba to 0.6.8 (#11212)

* Bump sambamba to 0.6.8

* It's somewhat annoying that missing_hash is thrown even if uses_git_url is specified.

* Set some environment variables

* The compiled binary is in a different place now

* ldc provides some libraries that are linked against.

* mtbseq: update recipe (#11110)

* changed download location/add test

* remove test

* Confindr (#11217)

* Update confindr to 0.4.2

* Fix typo in specifying version of pysam

* Update Genenotebook to v0.1.4 (#11218)

* genenotebook recipe

* About

* Package name

* License

* sha256sum

* Update build.sh

* Make bin dir

* Change ln to cp

* New symlink strategy

* Build from prebundled tarball

* genenotebook v0.1.2

* version fix

* retry

* fix

* build number

* genenotebook v0.1.3

* restore build procedure

* Fix summary

* updating to 0.1.3 (#11221)

* sartools1.6.6 (#11222)

* Perl bio automatedannotation (#11216)

* Initial recipe for Bio-AutomatedAnnotation

* Change URL

* Run cpanm tests

* Temporarily set HOME

* Use cpan version instead

* Add more depencencies

* Set bioperl version

* unset bioperl version, add bioperl-run

* New release including version in modules

* Remove comments

* build -> host

* Upgrade r-biodb to v1.1.2. (#11213)

* Upgrade r-biodb to v1.1.2.
* Remove old versions of r-biodb.
* Comment out libgfortran.

* PeptideShaker: updated to version 1.16.30 & SearchGUI: updated to version 3.3.5 (#11215)

* PeptideShaker: updated to version 1.16.30

- Bugfix: HOME was still being used when folder with customised reports was specified.
- Bugfix: Made it possible to use the MzidCLI options directly on the PeptideShakerCLI command line.

* SearchGUI: updated to version 3.3.5.

- BUG FIX: Cleanup of the temp path options when used as options for the other command lines.
- FEATURE IMPROVEMENT: Updated Comet to 2018.01 rev. 2.
- LIBRARY UPDATE: Updated utilities to version 4.12.8.

* Update meta.yaml (#11227)

* Svtools 0.4.0 (#11208)

* Remove directories for old svtools versions

* Update svtools to v0.4.0

* Move build number back to 0

* Anvio 52 (#11230)

* Incrementing version to 5.2. Splitting out anvio-minimal package to just install the pip package. The anvio package will install it and all the most likely companion software.

* Remove cgat-scripts from blacklist. (#11228)

* Add new formula: bazam 1.0.1  (#11229)

* Update gatk4 to 4.0.10.0 (#11224)

* Add recipe for gtdbtk 0.1.3 (#11211)

* Add recipe for gtdbtk

* Added initial htstream recipe (#11113)

* HTStream is a fast, quality control pipeline for Hight Throughput Sequencing data. The difference between HTStream and other pipelines is that HTStreams uses a tab delimited fastq format which allows for streaming from application to application. This streaming creates some awesome efficiencies when processing HTS data.

* DeepTools 3.1.3 (#11226)

* PacBio: Update `pbmm2` to version 0.10.0 (#11225)

* fastqc: update to version 0.11.8 (#11214)

* fastqc: update to version 0.11.8

* Update meta.yaml

* Phame (#11223)

* mac recipe and added bioperl

*  changing bill number

* added no osx

* adding new version

* removed separate recipe for mac, dont need it

* now running same recipe for mac and linux

* fixed the way fasttrees version was being parsed

* minor change test

* adding detailed description

* restaging the build number

* new version

* Make sure to use bioperl and perl 5.26

* Updated ngs-bits to version 2018_10 (#11235)

* PacBio: Update `pbsv2` to version 2.0.2 (#11236)

* Update VSEARCH to 2.8.5 (#11239)

* Fix shorah recipe and remove from blacklist. (#11241)

* Fix shorah recipe and remove from blacklist.

* Fix blas variant.

* Remove imports from tests.

* unicycler 0.4.7 (#11240)

* unicycler 0.4.7

* unicycler: Work around ValueError: invalid

Unicycler thinks the terminal has 0 columns and produces this error:
File "/usr/local/Cellar/python/3.7.0/Frameworks/Python.framework/Versions/3.7/lib/python3.7/textwrap.py", line 248, in _wrap_chunks
raise ValueError("invalid width %r (must be > 0)" % self.width)
ValueError: invalid width -5 (must be > 0)

* Octopus: update to 0.5.1-beta (#11244)

* New: PURPLE SV caller; Update: VarDictJava (1.5.6), PureCN (#11247)

- PURPLE SV and heterogeneity caller for somatic tumor/normal samples.
- VarDictJava -- 1.5.6 release with fixes for SV calling
- PureCN -- add signature dependency and update with fixes for test
  samples.

* Dinucleotide patterns analysis tools v1.0 (#11245)

* Dinucleotide patterns analysis tools v1.0

* Lets try it, it seems to work locally for me.

* Enable SpoTyping_plot.r (#11248)

* rerun again (#11233)

* rerun again

* Update meta.yaml

* Delete build.sh

* Update segway dependency optbuild to 0.2 (#10459)

* Update segway dependency optbuild to 0.2

* Update build and architecture requirements for optbuild 0.2

* Add six as a dependency to the optbuild recipe

* Dinucleotide patterns analysis tools v1. / Add prefix dnp- to the package names (#11249)

* Add prefix dnp- to the package names

* Update build.sh

* Update build.sh

* Bump beast version to 1.10.2 (#11250)

* add maxquant (#11253)

* add mayquant

* relax tests

* PacBio: Update `pbmm2` to version 0.10.1 (#11256)

* PacBio: Update `pbmm2` to version 0.10.1-1 (#11257)

* remove xsv recipe (#11259)

* add blast dependency (#11258)

* Added riborex recipe (#11251)

* Added riborex recipe

* Relaxed version constraints

* Pinned r-core for fdr tools

* fixed the r-base stuff upstream

* Update meta.yaml

* fix graphprot (#11234)

* increase build number

* remove from blacklist

* use cxx instead of c

* move coreutoils to build section

* set additional paths

* patch makefile

* blind try

* update patch

* explicitely copy from src_dir

* update deprecated prefix variable

* Revert "update deprecated prefix variable"

This reverts commit 2559439.

* update deprecated prefix variable

* try moving to host section

* Bump mash (#11264)

* Add fmlrc (#11265)

* Add fmlrc

* add doi

* PacBio: Update pb-falcon to 0.2.4. (#11266)

* Add kopt recipe (#11269)

* Genomepy 0.5.2 (#11267)

* release 0.5.2 of genomepy

* trigger new build

* remove genomepy from blacklist

* locale for osx

* updated locale test

* PacBio: Update pb-assembly to 0.0.2. Bumped the pinned version for pb-falcon. (#11275)

* Update mmseqs2 recipe to new release 6-f5a1c (#11272)

* Update yacrd to version 0.4.1 (#11273)

* Add scprep (#11270)

* Add scprep

* All of these should not be needed as host dep

* Metawrap preqs2 (#11242)

* fixed issues

* fixed issues

* added tests

* fixed tab

* gemma 0.98 (#11254)

* gemma 0.98

* gemma 0.98

Leave gsl and zlib out of runtime dependencies

* Add DCA recipe (#11274)

* Add DCA recipe

* add noarch and doi

* remove skip

* Fix a bunch of packages that are actually in bioconductor and try to fix bioconductor-rhtslib

* Various fixes for bulk and trigger a rebuild (#11313)

* Various fixes, at least 4 packages (and their dependencies) should still fail (#11320)

* A few fixes, remove a package from the blacklist since it prevents trumicounts from building. (#11336)

* Fix various recipes (#11354)

* Fix various recipes

* Fix more recipes

* Various CRAN package fixes, since they all lack license files (#11372)

* Various CRAN package fixes, since they all lack license files

* Fix the r-dartr recipe

* There is a light at the end of the tunnel (#11381)

* There is a light at the end of the tunnel

* Licenses no longer exist

* [BULK] Fixes for R/Bioconductor packages (#11406)

* Require `r-base >=3.5` for some packages

* Fix various CRAN packages lacking license file

* Add missing libnetcdf requirement to bioconductor-mzr

* Remove r-alakazam (moved to conda-forge)

Fix linting issue:
```
recipes/r-alakazam	in_other_channels	{'exists_in_channels': {'conda-forge'}, 'fix': 'consider deprecating'}	{'conda-forge'}	consider deprecating
```

* [BULK] Many R 3.5 only packages (#11410)

* [BULK] Bulk update 191018b (#11419)

* update mzr as a test

* Begin building for R 3.5.1 (#11252)

* Bump everything for R 3.5.1

* Fix most of the linting issues

* Update blacklist

* Revert "Fix most of the linting issues"

This reverts commit a271e50.

* should_not_use_fn

* More fixes

* Fix incorrect yaml

* Should really fix the linting blacklist stuff

* Fix many recipes

* Fix some linting

* Fix r-wicket

* Update derfinder

* Pin to a given bioconductor release.

* Add missing packages

* Restore identifiers to bioconductor packages

* Restore extra information to R packages

* Update R bulk (#11283)

* fixed incorrect doi of publication (#11175)

* Added recipe for kinSimRiboswitch (#10838)

Added recipe for kinSimRiboswitch, a pipeline for simulating the folding
kinetics of RNA switches.

* update multiqc-bcbio (#11187)

* Add recipe for PopDel (#11181)

* Add recipe for PopDel

* Add clang and clangxx to build config

* update seqbuster (#11190)

* update seqbuster

* fix build

* fix test

* Update pyseer to 1.1.2 (#11172)

* bump sourmash (#11197)

* Update BASIC to v1.4.1 (#11195)

* Update BASIC to v1.4.1

* Trigger circleci

* Fix build number

* Update nf-core-1.2 (#11191)

* Update nf-core-1.2

* Update build script

* Update to InterMine 1.11.0 (#11182)

* Update meta.yaml

* Update meta.yaml

* Update meta.yaml

* Add tinyfasta-0.1.0 (#11177)

* Add tinyfasta

* Update build script

* Fix structure of build section

* Bumping snippy  (#11198)

* Remove older version

* Bump snippy

* VEP: bump major version (#11201)

* VEP: bump major version

* VEP: bumped plugin major version

* VEP: update plugin install

Download and install all plugin modules, instead of just a selection

* Update: PureCN to latest devel (1.11.13); wrapper scripts (#11200)

* Update: PureCN to latest devel (1.11.13); wrapper scripts

PureCN development (https://github.com/lima1/PureCN) has several
improvements over the BioC 3.6 release for handling multiple VCF input
types, and is back compatible with R 3.4.1 so still builds cleanly
with two new dependencies.

Also exposes PureCN wrapper scripts for running from the command line.
Prefixes ambiguous scripts with PureCN_.

* Try pinning to 3.4 to avoid 3.5.1 builds which we don't want yet

* add cassiopee release 1.0.9 (#11168)

* add cassiopee release 1.0.9

* update to conda build 3

* remove old version backup and use sha256 for source

* Bump abeona version to 0.26.0 (#11202)

* Bump abeona version to 0.24.0

* Bump abeona version to 0.26.0

* Update LexMapr to v0.1.2 (#11192)

* Update LexMapr to v0.1.2

* Add rdflib dep

* Update svtyper to 0.7.0 (#11196)

* Update svtyper to 0.7.0

* Add recipe for perl-gtdbtk (#11194)

* Add recipe for perl-gtdbtk

* New recipe for RFMix (#11205)

* New recipe for RFMix
* updated version number information
* updated version number information
* updated version number information

* initial purge_haplotigs commit (#11049)

* initial purge_haplotigs commit
* bioconda revisions, updating test commands to run the pipeline on the test dataset
* rolling back test commands

* Add recipe for fsm-lite (#11209)

* Add recipe for fsm-lite
* Add prefix to make
* Remove v from version string

* Updated reparation_blast to version v.1.0.7 (#11210)

* Update sambamba to 0.6.8 (#11212)

* Bump sambamba to 0.6.8

* It's somewhat annoying that missing_hash is thrown even if uses_git_url is specified.

* Set some environment variables

* The compiled binary is in a different place now

* ldc provides some libraries that are linked against.

* mtbseq: update recipe (#11110)

* changed download location/add test

* remove test

* Confindr (#11217)

* Update confindr to 0.4.2

* Fix typo in specifying version of pysam

* Update Genenotebook to v0.1.4 (#11218)

* genenotebook recipe

* About

* Package name

* License

* sha256sum

* Update build.sh

* Make bin dir

* Change ln to cp

* New symlink strategy

* Build from prebundled tarball

* genenotebook v0.1.2

* version fix

* retry

* fix

* build number

* genenotebook v0.1.3

* restore build procedure

* Fix summary

* updating to 0.1.3 (#11221)

* sartools1.6.6 (#11222)

* Perl bio automatedannotation (#11216)

* Initial recipe for Bio-AutomatedAnnotation

* Change URL

* Run cpanm tests

* Temporarily set HOME

* Use cpan version instead

* Add more depencencies

* Set bioperl version

* unset bioperl version, add bioperl-run

* New release including version in modules

* Remove comments

* build -> host

* Upgrade r-biodb to v1.1.2. (#11213)

* Upgrade r-biodb to v1.1.2.
* Remove old versions of r-biodb.
* Comment out libgfortran.

* PeptideShaker: updated to version 1.16.30 & SearchGUI: updated to version 3.3.5 (#11215)

* PeptideShaker: updated to version 1.16.30

- Bugfix: HOME was still being used when folder with customised reports was specified.
- Bugfix: Made it possible to use the MzidCLI options directly on the PeptideShakerCLI command line.

* SearchGUI: updated to version 3.3.5.

- BUG FIX: Cleanup of the temp path options when used as options for the other command lines.
- FEATURE IMPROVEMENT: Updated Comet to 2018.01 rev. 2.
- LIBRARY UPDATE: Updated utilities to version 4.12.8.

* Update meta.yaml (#11227)

* Svtools 0.4.0 (#11208)

* Remove directories for old svtools versions

* Update svtools to v0.4.0

* Move build number back to 0

* Anvio 52 (#11230)

* Incrementing version to 5.2. Splitting out anvio-minimal package to just install the pip package. The anvio package will install it and all the most likely companion software.

* Remove cgat-scripts from blacklist. (#11228)

* Add new formula: bazam 1.0.1  (#11229)

* Update gatk4 to 4.0.10.0 (#11224)

* Add recipe for gtdbtk 0.1.3 (#11211)

* Add recipe for gtdbtk

* Added initial htstream recipe (#11113)

* HTStream is a fast, quality control pipeline for Hight Throughput Sequencing data. The difference between HTStream and other pipelines is that HTStreams uses a tab delimited fastq format which allows for streaming from application to application. This streaming creates some awesome efficiencies when processing HTS data.

* DeepTools 3.1.3 (#11226)

* PacBio: Update `pbmm2` to version 0.10.0 (#11225)

* fastqc: update to version 0.11.8 (#11214)

* fastqc: update to version 0.11.8

* Update meta.yaml

* Phame (#11223)

* mac recipe and added bioperl

*  changing bill number

* added no osx

* adding new version

* removed separate recipe for mac, dont need it

* now running same recipe for mac and linux

* fixed the way fasttrees version was being parsed

* minor change test

* adding detailed description

* restaging the build number

* new version

* Make sure to use bioperl and perl 5.26

* Updated ngs-bits to version 2018_10 (#11235)

* PacBio: Update `pbsv2` to version 2.0.2 (#11236)

* Update VSEARCH to 2.8.5 (#11239)

* Fix shorah recipe and remove from blacklist. (#11241)

* Fix shorah recipe and remove from blacklist.

* Fix blas variant.

* Remove imports from tests.

* unicycler 0.4.7 (#11240)

* unicycler 0.4.7

* unicycler: Work around ValueError: invalid

Unicycler thinks the terminal has 0 columns and produces this error:
File "/usr/local/Cellar/python/3.7.0/Frameworks/Python.framework/Versions/3.7/lib/python3.7/textwrap.py", line 248, in _wrap_chunks
raise ValueError("invalid width %r (must be > 0)" % self.width)
ValueError: invalid width -5 (must be > 0)

* Octopus: update to 0.5.1-beta (#11244)

* New: PURPLE SV caller; Update: VarDictJava (1.5.6), PureCN (#11247)

- PURPLE SV and heterogeneity caller for somatic tumor/normal samples.
- VarDictJava -- 1.5.6 release with fixes for SV calling
- PureCN -- add signature dependency and update with fixes for test
  samples.

* Dinucleotide patterns analysis tools v1.0 (#11245)

* Dinucleotide patterns analysis tools v1.0

* Lets try it, it seems to work locally for me.

* Enable SpoTyping_plot.r (#11248)

* rerun again (#11233)

* rerun again

* Update meta.yaml

* Delete build.sh

* Update segway dependency optbuild to 0.2 (#10459)

* Update segway dependency optbuild to 0.2

* Update build and architecture requirements for optbuild 0.2

* Add six as a dependency to the optbuild recipe

* Dinucleotide patterns analysis tools v1. / Add prefix dnp- to the package names (#11249)

* Add prefix dnp- to the package names

* Update build.sh

* Update build.sh

* Bump beast version to 1.10.2 (#11250)

* add maxquant (#11253)

* add mayquant

* relax tests

* PacBio: Update `pbmm2` to version 0.10.1 (#11256)

* PacBio: Update `pbmm2` to version 0.10.1-1 (#11257)

* remove xsv recipe (#11259)

* add blast dependency (#11258)

* Added riborex recipe (#11251)

* Added riborex recipe

* Relaxed version constraints

* Pinned r-core for fdr tools

* fixed the r-base stuff upstream

* Update meta.yaml

* fix graphprot (#11234)

* increase build number

* remove from blacklist

* use cxx instead of c

* move coreutoils to build section

* set additional paths

* patch makefile

* blind try

* update patch

* explicitely copy from src_dir

* update deprecated prefix variable

* Revert "update deprecated prefix variable"

This reverts commit 2559439.

* update deprecated prefix variable

* try moving to host section

* Bump mash (#11264)

* Add fmlrc (#11265)

* Add fmlrc

* add doi

* PacBio: Update pb-falcon to 0.2.4. (#11266)

* Add kopt recipe (#11269)

* Genomepy 0.5.2 (#11267)

* release 0.5.2 of genomepy

* trigger new build

* remove genomepy from blacklist

* locale for osx

* updated locale test

* PacBio: Update pb-assembly to 0.0.2. Bumped the pinned version for pb-falcon. (#11275)

* Update mmseqs2 recipe to new release 6-f5a1c (#11272)

* Update yacrd to version 0.4.1 (#11273)

* Add scprep (#11270)

* Add scprep

* All of these should not be needed as host dep

* Metawrap preqs2 (#11242)

* fixed issues

* fixed issues

* added tests

* fixed tab

* gemma 0.98 (#11254)

* gemma 0.98

* gemma 0.98

Leave gsl and zlib out of runtime dependencies

* Add DCA recipe (#11274)

* Add DCA recipe

* add noarch and doi

* remove skip

* Fix a bunch of packages that are actually in bioconductor and try to fix bioconductor-rhtslib

* Various fixes for bulk and trigger a rebuild (#11313)

* Various fixes, at least 4 packages (and their dependencies) should still fail (#11320)

* A few fixes, remove a package from the blacklist since it prevents trumicounts from building. (#11336)

* Fix various recipes (#11354)

* Fix various recipes

* Fix more recipes

* Various CRAN package fixes, since they all lack license files (#11372)

* Various CRAN package fixes, since they all lack license files

* Fix the r-dartr recipe

* There is a light at the end of the tunnel (#11381)

* There is a light at the end of the tunnel

* Licenses no longer exist

* [BULK] Fixes for R/Bioconductor packages (#11406)

* Require `r-base >=3.5` for some packages

* Fix various CRAN packages lacking license file

* Add missing libnetcdf requirement to bioconductor-mzr

* Remove r-alakazam (moved to conda-forge)

Fix linting issue:
```
recipes/r-alakazam	in_other_channels	{'exists_in_channels': {'conda-forge'}, 'fix': 'consider deprecating'}	{'conda-forge'}	consider deprecating
```

* [BULK] Many R 3.5 only packages (#11410)

* Update pinning to R>=3.5 and a few runtime dependencies.

* CSAW is R 3.5 only

* Packages using beachmat are 3.5 only

* Packages using bioconductor-singlecellexperiment are R 3.5 only

* [BULK] Don't use r-base >=3.5, use a conda_build_config.yaml instead (#11452)

* Don't use r-base >=3.5, use a conda_build_config.yaml instead

* blacklist r-phangorn

* Update variancepartition

* R 3.5 for packages requiring singlecellexperiment

* Update a few packages

* Update a number of recipes (#11482)

* Update ensemblVEP and derfinder (#11504)

* Bulk update 251018 (#11577)

* [BULK] various package updates

* blacklist bioconductor-mzr

* A couple tweaks

* [BULK] Update 261018 (#11611)

* Apparently the r-rgeos bit works properly now.

* Add tissueenrich and try to fix scpipe on Linux

* A meaningless change just to trigger an update in bulk. (#11618)

* [BULK] update 271018 (#11628)

* Bump bioconductor-esetvis

* Fix yaqcaffy

* Fix more

* Another R 3.5 recipe

* [BULK] update 281018 (#11689)

* Add some files

* Fix arrayexpress

* Fix another 2

* Blacklist a bunch of bioconductor recipes that aren't likely to get built for a variety of reasons (mostly due to mzR). (#11697)

* Update blacklist (#11706)

* [BULK] fix bioconductor-tissueenrich (#11720)

* taxonkit 0.2.5 (#11318)

* Update csvtk (#11319)

* taxonkit 0.2.5

* csvtk 0.15.0

* bumping GROOT to 0.8.1 (#11323)

* HiCMatrix version 3 (#11322)

* Correcting dependencies

* Version 3 of HiCMatrix, the October release

* Update confindr to 0.4.3 (#11330)

* Drop-seq_tools: Version 2.0.0 (#11326)

* Update meta.yaml
* Update build.sh

some tool names changed to fit Camel case

* Update motus to build only for python3 (#11331)

* Update fpa to 0.2 version (#11333)

* update taxonkit to 0.3.0 (#11339)

* ntcard 1.1.0 (#11338)

* Update rgi (#11335)

* first commit

* update dependencies list

* change source to github

* change build number

* testing circleci

* update meta and build

* fix build

* move build script into meta

* remove older recipes

* line fix in bootstrap.py

* change python & matplotlib versions; add build.sh file

* add preprocessing selector to skip python 2.7

* move build script into meta.yaml

* Revert "line fix in bootstrap.py"

This reverts commit 5ac1ecd.

* Update gmap to version 2018-07-04. (#11332)

MAX_READLENGTH environment variable has been disused since 2016-08-16.

* Upgrade r-biodb to 1.2.0a. (#11341)

* Upgrade r-biodb to 1.2.0a.

* Update meta.yaml

* Updated ont-tombo to version 1.5. (#11329)

* Updated ont-tombo to version 1.5.

* Updated with actual github release version hash.

* remove graphicsmagick (#11342)

* Build  kraken2 for osx (#11343)

* First try for a bcalm recipes (#11344)

* New: cgpbigwig (BigWig manipulation); Update: bcbio (#11347)

- cgpbigwig (https://github.com/cancerit/cgpBigWig) provides bigwig
  generation and manipulation command line tools including bam to bigwig
  conversion.
- bcbio: fixes for QC on variants and peddy for CWL runs

* Try avoid some dependancy (#11349)

* Update TreeBest to commit c9d3a2e35276c825577ec945b229e975c32078d8 (#11348)

* Update TreeBest to commit c9d3a2e35276c825577ec945b229e975c32078d8

Also add about:home .

* Workaround conda-forge/bison-feedstock#7

* Better bcalm recipes (#11350)

* Try avoid some dependancy

* Correct mess in build number, sorry

* R biodb (#11351)

* rebuild r-biodb

* trigger build

* Add recipe for pypairs (#11356)

* Update smoove to 0.2.1. (#11360)

* Update duphold to 0.0.9. (#11359)

* Update goleft to 0.2.0 (#11361)

* Bump slicedimage to 1.0.0 (#11362)

* Bump slicedimage to 1.0.1 (#11365)

* Added new versions for biopet-sampleconfig (#11268)

* perl-velvetoptimiser: update to 2.2.6 (#11369)

* update to 2.2.6

* remove unneeded patch

* Scanpy upgrade (#11371)

* Bump version

* Upgrade Scanpy

* Bump starfish to 0.0.25 (#11370)

* bumping groot to 0.8.2 (#11374)

* vep: bump subversion (#11367)

* Updated Krocus 1.0.1 (#11355)

* Add tiptoft

* Fix meta.yaml for tiptoft

* Add build script

* Updated krocus 1.0.1

* Add tiptoft 0.1.4 (#11352)

* Add tiptoft

* Fix meta.yaml for tiptoft

* Add build script

* Kodoja v0.0.9 (#11373)

* Add recipe for seer (#11263)

* Add recipe for seer

* lets try this

* Add newer compiler

* Using boost-cpp

* messed up version string

* Attempt building boost

* Use c++11 in boost

* Use python for boost install

* Correct python version spec

* try with different python version

* Fix b2 command

* Fix popd command

* build and link boost program options statically

* Fix tests

* Match dependency order

* Link openblas instead of blas

* Forcing rebuild with openblas

* Don't use armadillo wrapper

* Making review changes. Also trying original tests

* Previous tests were correct

* Add recipe for the translate-gard npm package version 1.0.3 (#11364)

* Fix umi tools (#11376)

 umi_tools: clean up dependencies

* add support tools to PATH (#11379)

* Bump to v2.2.1 (#11380)

* Bump starfish to 0.0.26 (#11378)

* Update fpa to 0.3 (#11375)

* Update fpa to 0.3

* Correct error in sha256

* Reset build number

* Update trial to 2.5.5 (#11386)

* Update: bioconductor-titancna; 1.19.1 with hg38 support (#11388)

* Update: bioconductor-titancna; 1.19.1 with hg38 support

* Pin to R 3.4 to avoid pulling in 3.3 and 3.5 during mulled

* Add r-polysat version 1.7-3 (#11384)

* Update biomart version so that compatible with r351 (#11366)

* Update biomart version so that compatible with r351

* Update meta.yaml

reset build number as per https://bioconda.github.io/guidelines.html#buildnum

* Update entrez-direct to 10.0.20180927. (#11387)

* Added recipe for SonicParanoid 1.0.13 (#11271)

* Added recipe for SonicParanoid 1.0.13

* removed 'x.x' for numpy, added basic test

* fixed linter related errors

* compiler set to cxx and added host section (same build error!)

* removed host section

* moved numpy and cython to host section; restored build: noarch: python; added LICENSE.md

* removed build: noarch

* added build and extra sections

* set build number to 0; removed skip build; added python3 minimum version; added test for all executables.

* restored sh python module as requirement

* added Make to run; updated release to latest commit

* remove c compiler from meta.yaml

* modified build.sh to compile source codel added make in build section

* updated to latest commit

* updated to latest version with make included in setup.py

* reverted build.sh to the simplest version (python setup.py install)

* Add perl-json to build requirements to allow meme-chip to run to completion. Change meme-chip to use dreme-py3 instead of dreme if building with python 3. (#11389)

* Bump IgBLAST to 1.9.0 (#11393)

Bump IgBLAST to 1.9.0

Re-package the binary version this time. There are problems building the
source version when the configure script reaches this step:
"trying to build the NCBI SRA/VDB Toolkit from GitHub"

The previous problem about the binaries linking against libbz2.so, for
which we had no conda package, is now solved.

Also, this saves about 45 minutes compilation time.

* Add consan (#11395)

* Add consan

* Skip osx

* Update: vardict, vardict-java 1.5.7 (#11394)

* Update: vardict, vardict-java 1.5.7

Latest vardict-java release and corresponding vardict with bug fixes
after testing with 1.5.6

* Reduce test output to try and fix build problems

* Experiment 2 for build problems: remove r-base from run

* Experiment 3 for build problems: add r-base in host

* update recipe for 3.9.1 (#11397)

* evofold2 (#11396)

* evofold2

* wrapper

* Update meta.yaml

* minor

* Update rnastructure to 6.1. (#11400)

* Ctat mut (#11401)

* updating version number

* correct URL

* proper hash

* Revert "Ctat mut (#11401)" (#11402)

This reverts commit 6db10ac.

* update version (#11403)

* any2fasta 0.4.2 (new formula) (#11407)

* W4mclassfilter v0.98.9 (#11385)

* Added files to build version 0.98.9

* Update meta.yaml

* Update meta.yaml

* updated SonicParanoid recipe to version 1.0.14 (#11409)

* updated SonicParanoid recipe to version 1.0.14

* Update to version 1.0.2 of PopDel (#11398)

* Update to version 1.0.2 of PopDel

Update to version 1.0.2.

* Reset build number to 0

* PacBio: require Meson 0.48.1 for all recipes (#11090)

* Meson 0.47 inserted duplicate RPATHs in
  macOS binaries, causing `install_name_tool`
  failures when installing the package.
  Requiring 0.48.1 ensures we do not run into
  these issues anymore in the future.

* rebuild with latest openmpi (#11411)

* Remove kfoots from the blacklist (#11416)

* Update gseapy to 0.9.7 (#11417)

* Update gseapy to 0.9.7

* remove noarch

* Add SC3 as dependency (#11427)

* Add recipe for r-poppr (#11418)

* Update knitr version because of Issue: rstudio/rmarkdown#1271 (#11412)

* Update IQ-TREE to 1.6.7.1 (#11429)

* Update IQ-TREE to 1.6.7.1

* Change build number

* Update: r-deconstructsigs with fixes for hg38 (#11431)

The 1.8.0 release, from 2016, has some issues with hg38 and other
custom genomes that are fixed in development (raerose01/deconstructSigs#27).
There hasn't been a new release pushed so this rolls these into a new
sub-version and makes them available.

* Update entrez-direct to 10.2.20181018. (#11432)

* Add assembly-scan recipe (#11425)

* remove python 2.7 skip (#11424)

Preparation for rnaQUAST

* Add fastq-scan recipe (#11415)

* Add patch to fix racon/rampler path in racon_wrapper. (#11434)

Fixes #11405.

* meme rebuild (#11433)

* Update nanocomp to 0.23.1 (#11436)

* Update nanocomp to 0.23.1

* remove noarch

* Update abricate to 0.8.10 (#11446)

* Update angsd to 0.923 (#11445)

* Update alfred to 0.1.13 (#11444)

* Update alfred to 0.1.13

* Try w/o patch

* Update antarna to 2.0.6 (#11442)

* Update admixtools to 5.1 (#11443)

* Update admixtools to 5.1

* Let makefile choose which bins to install

* Update alignstats to 0.5 (#11441)

* Update xatlas to 0.2.1 (#11437)

* r-gpca (#11428)

* r-gpca

* r-gpca recipe

* Update meta.yaml

* Removed All Comments

* gseapy bump version 0.9.8 (#11440)

* gseapy bump version 0.9.8

* version

* titancna: fix for hg38, remove conda build hacks (#11447)

* titancna: fix for hg38, remove conda build hacks

* Re-add r-base 3.4 pin to avoid 3.5 errors

* Hmmlearn older version (#11450)

* Adding pygtftk

* removed pygtftk from master

* add older version of hmmlearn

* Add card_trick (#11451)

* Add card_trick

* Restrict to py3

* Update checkm-genome to 1.0.12 (#11455)

* Bump drep (#11457)

* Update squid to 1.5 (#11466)

* Update ncbi-ngs-sdk to 2.9.3 (#11467)

* elprep: bumped major version (#11414)

* elprep: bumped major version

* fixed hash

* fix download link, fixed licence

* fixed tests

* skip osx build

* FRED2 as a conda package (#11469)

* Attempt to get FRED2 as a conda package

* SHA update

* 99 little bugs in the code

* Fix things Björn mentioned

* add rnaQUAST recipe (#11470)

* Update bioconda-utils to 0.14.9 (#11454)

* Rapidup (#11474)

* Update to v0.7

* Update Buildnumber

* rapid: update to v0.6

* rapid: update to v0.6

* update grid (#11478)

* Adding biobb_model recipe (#11472)

* Updated wtdbg to v2.1 (#11486)

* update stream to 0.2.6 (#11483)

* update stream to 0.2.2

* update stream to 0.2.3

* update stream to 0.2.4

* update stream to 0.2.4

* update stream to 0.2.4

* update stream to 0.2.5

* update stream to 0.2.6

* Update meta.yaml (#11487)

* Update connectome-workbench to 1.3.2 (#11468)

Now needs QT 5.7

* Update deblur to 1.1.0 (#11500)

* Update domclust to 1.2.8 (#11498)

* WisecondorX: bump version (#11501)

* Bump as GitHub wasn't working yesterday (#11502)

* Added recipe for Sequenza (#10367)

* Added recipe for Sequenza

* Removed fn entry in source section

* Trying with only one URL

* copynumber is a bioconductor package

* Added missing requirements section

* Removed mailing list address

* Added doi

* Added license_file

* Trying with different  license_file path

* Fred2 bump (#11503)

* Bump as GitHub wasn't working yesterday

* Fix licence etc

* Scanpy scripts (#11413)

Doing squash and merge as requested by @nh3 

* Bump version

* First implementation of scanpy-scripts bioconda recipe.

* fix path in build.sh

* Remove "noarch" flag as requested by bioconda recipe checklist

* Add a post install notice that post install test needs bats-core.

* Add more dependencies

* Skip building for python versions other than 3.6

* Target v0.0.2 which has non-ascii characters removed

* Lower version requirement for pandas and matplotlib to be the same as scanpy

* Requirement matplotlib>=3.0.0, declare noarch

* New: hmftools-cobalt; Update: hmftools-purple (#11507)

- hmftools-cobalt: Add latest version of PURPLE associated read counter,
  COBALT, with support for hg38.
- hmftools-purple: PURPLE release with hg38 support.

* Update Picard to 2.18.15. (#11505)

* Genenotebook (#11476)

* genenotebook recipe

* About

* Package name

* License

* sha256sum

* Update build.sh

* Make bin dir

* Change ln to cp

* New symlink strategy

* Build from prebundled tarball

* genenotebook v0.1.2

* version fix

* retry

* fix

* build number

* genenotebook v0.1.3

* restore build procedure

* Fix summary

* dependency versions

* v0.1.5

* Update pinning (#11514)

* Bump build number for updated dependency (#11510)

* Bump build number for updated dependency

* Try adding r-base to host requirements

* Try adding other requirements to host

* Pin to R version

* Update meta.yaml

* Update meta.yaml

* Update meta.yaml

* Tweak dependency version syntax

* Pin R and package versions correctly

* PacBio: Update pbcore to 1.6.5 (#11513)

* Bump r seurat scripts version (#11292)

* Bump version

* Remove noarch

* Could wrongly quoted version be causing an issue?

* Tweak pinning to try and fix CI error

* seqcluster:fix UMI detection. (#11511)

* seqcluster:fix UMI detection.

* Fix dependency

* quast 5.0.1 (#11479)

* quast 5.0.1

* quast 5.0.1: remove third-party site packages from the distibution pack

* quast 5.0.1: skip Glimmer in test

* quast 5.0.1: joblib and simplejson dependencies added to meta.yaml (Setuptools downloading is disabled in conda build)

* quast 5.0.1: explicit joblib and simplejson dependencies removed (Setuptools downloading is disabled in conda build)

* quast 5.0.1: Python 2 and 3 compatible code in build.sh

* wcX bugfixes (#11508)

* wcX bugfixes

* fixed shasum

* Update fastspar to 0.0.7 (#11515)

* Update iqtree to 1.6.7.2 (#11525)

* Update illumina-interop to 1.1.6 (#11523)

* Update hapbin to 1.3.0 (#11522)

* Update hlama to 3.0.1 (#11520)

* Update gb_taxonomy_tools to 1.0.1 (#11519)

* Update gffcompare to 0.10.5 (#11517)

* Update fast5seek to 0.1.1 (#11516)

* Update deepbinner to 0.2.0 (#11499)

* Update deepbinner to 0.2.0

* Update meta.yaml

Try same fix as in #11240

* Update ncbi-vdb to 2.9.3 (#11550)

* Update mikado to 1.2.4 (#11549)

* Update perl-pcap to 3.5.2 (#11543)

* Update python-hyphy-python to 0.1.9 (#11545)

* Update mlst to 2.15.2 (#11547)

* Update perl-sanger-cgp-vcf to 2.2.1 (#11542)

* Update merfishtools to 1.5.0 (#11537)

* Update perl-sanger-cgp-vagrent to 3.3.3 (#11536)

* Update nonpareil to 3.3.3 (#11535)

* Update prophex to 0.1.1 (#11532)

* Update krakenuniq to 0.5.3 (#11527)

* Update novoplasty to 2.7.2 (#11530)

* Update minced to 0.3.2 (#11529)

* Update mapdamage2 to 2.0.8 (#11528)

* Update perl-sanger-cgp-allelecount to 4.0.0 (#11538)

* Update pyvolve to 0.9.0 (#11531)

* Genenotebook (#11512)

* genenotebook recipe

* About

* Package name

* License

* sha256sum

* Update build.sh

* Make bin dir

* Change ln to cp

* New symlink strategy

* Build from prebundled tarball

* genenotebook v0.1.2

* version fix

* retry

* fix

* build number

* genenotebook v0.1.3

* restore build procedure

* Fix summary

* dependency versions

* v0.1.5

* version fix

* add plek (#11554)

* Update pyimzml to 1.2.4 (#11534)

* Bump shovill (#11555)

* PacBio: Update minimum pbcore version (#11556)

* We want all users of PacBio tools to be able to
  use our utilities with pbmm2 alignments.

* Add recipe for translate-gard v1.0.4 (#11557)

* bioconductor-rnaseqsamplesizedata (#11475)

* Adding Recipe for bioconductor-rnaseqsamplesizedata

* Updated metadata for RnaSeqSampleSizeData

* nextflow 18.10.1 (#11558)

* Update raxml to 8.2.12 (#11567)

* Update r-fgwas to 0.3.6 (#11566)

* Update rapid to 0.7 (#11565)

* Update r-spieceasi to 1.0.2 (#11564)

* Update rcorrector to 1.0.3.1 (#11562)

* Update quicktree to 2.4 (#11560)

* Update paladin to 1.4.4 (#11541)

* Update paladin to 1.4.4

* delete md5

* Update build.sh

* Update build.sh

* Fix and unblacklist Tadarida-D (#11568)

* Add recipe for rgt

* Fix and un-blacklist tadarida-d

* Remove RGT

* bumping groot (#11575)

* update pymzml (#11573)

* Add bioconductor-rnaseqsamplesize (#11559)

* Add bioconductor-rnaseqsamplesize

* Update recipe

* Fixing some URLs

* Update dependencies missing

* Update trumicount to 0.9.11 (#11576)

* Update ConFindr to 0.4.4 (#11578)

* Added new versions for biopet-scatterregions (#11572)

* Added new versions for biopet-bamstats (#11571)

* R ggbiplot (#11584)

* add R -e 'httr::set_config(httr::config(ssl_verifypeer = 0L)); install.packages(devtools, repos=http://mirrors.ebi.ac.uk/CRAN/); library(devtools); install_github(vqv/ggbiplot); library(ggbiplot)'

* add r-ggbiplot

* update meta.yaml

* update meta.yaml

* update

* update

* update

* update

* update

* update

* update

* update

* update

* fix errors

* fix errors number 1

* Update rebaler to 0.1.2 (#11563)

* Update rebaler to 0.1.2

* Remove fn

* bump graphclust (#11585)

* Update seqyclean to 1.10.09 (#11589)

* Update stringmlst to 0.5.1 (#11590)

* Update snp-dists to 0.6.2 (#11592)

* Update snippy to 4.3.3 (#11596)

* Update canu to 1.8 (#11600)

* Update starfish to 0.0.27 (#11599)

* Update womtool to 36 (#11594)

* Update telseq to 0.0.2 (#11598)

* Update snp-sites to 2.4.1 (#11588)

* Added recipe for pydemult: Streamed and parallel demultiplexing of fastq files (#11471)

* Added recipe for pydemult

* Bumped version in favor of py3.5

* bump vcf2db to latest commit (#11601)

* bump vcf2db to latest commit

* fix shasum

* Fixing source url

* Update: TitanCNA; hg38 cytoband support and fix for normalization (#11604)

* megan (#11046)

* megan6: initial commit

* megan6: intermediate commit

* megan: made tests work

* megan: doc improvement

* megan: added osx dmg file

* megan: add java to build requirements

* megan: removed new line

* megan: removed osx sources

* Update meta.yaml

* bumping hulk (#11607)

* Update hotspot3d to 1.8.2 (#11521)

* Update hotspot3d to 1.8.2

* Add perl-json as dependency

* Add perl-archive-extract as dependency

* Fqzcomp (#11606)

* Added recipe for fqzcomp

* There is no configure script

* Maybe this works

* Added gcc as build requirement

* Removed gcc again (lint issue)

* Maybe these exports will do the trick

* Nope!

* Added cxx as host requirement

* Compilers are only allowed in build section

* There is no need for make install

* Copy-paste error...

* Add vcf-annotator recipe (#11481)

* Add vcf-annotator recipe

* added pyvcf dependency

* Update meta.yaml

* stacks: fix for @ in exe_path (#11580)

* stacks: fix for @ in exe_path

* stacks: fixed path

* New version with bugfix and different progressiveMauve version. (#11613)

* Sspupdate (#11614)

* New version with bugfix and different progressiveMauve version.

* Keeping old version as folder.

* Push build number.

* Update SVDB to version 1.3.0 (#11506)

* 	new file:   recipes/svdb/1.1.2/meta.yaml
	renamed:    reipes/svdb/svdb.patch -> recipes/svdb/1.1.2/svdb.patch
	modified:   recipes/svdb/meta.yaml

* 	deleted:    1.1.2/meta.yaml
	deleted:    1.1.2/svdb.patch

* Bump nanosim (#11608)

* Bump nanosim

* Add scipy as dep

* Add recipe for perl-number-range (#11621)

* New build for grid (#11620)

* update grid

* update build num

* Recipe for das_tool 1.1.1 (#10528)

* recipe for das_tool 1.1.1

* Add recipe for sompy (#11624)

* cmake modified to build with NDEBUG (#11328)

* cmake modified to build with NDEBUG

* Update meta.yaml

* new build with fasta test

* new build with fasta test

* Fix and unblacklist TwoPaCo (#11622)

* Add recipe for TwoPaCo

* Unblacklist twopaco

* Modify and unblacklist recipe for ESTmapper (#11623)

* Modify and unblacklist recipe for ESTmapper

* Add patch

* Modify and unblacklist recipe for Metaseq (#11625)

* Fix recipe for metaseq and remove from blacklist

* Remove build.sh

* nextflow 18.10.1 build 2 (#11630)

* Add Clust (#11619)

* Add clust

* Clean recipe

* Add "noarch"

* Add DOI

* Add build file

* Python 2.7

* Fix scikit-learn dependency

* Trigger new build

* Update: PureCN (multicore) and PURPLE (plotting X libraries) (#11631)

- PureCN: adds support for specifying cores on command line
- PURPLE: adds X library dependencies required for creating
  plots

* scripts/travis-run.sh: added a cleaner method to check for env vars (#11612)

* Increase the number of k value usable in bcalm (request by @Malfoy) (#11610)

* Increase the number of k value usable in bcalm (request by @Malfoy)

* Change compilation parameter to reduce memory impact of compilation

* Update anndata to 0.6.11 (#11637)

* Update nglview to 1.1.7 (#11643)

* Update binsanity to 0.2.7.1 (#11644)

* Update cgat-core to 0.5.4 (#11645)

* Update nanosv to 1.2.2 (#11673)

* Update abeona to 0.36.0 (#11670)

* Update pyfaidx to 0.5.5.2 (#11659)

* Update agfusion to 1.23 (#11668)

* Update iqtree to 1.6.8 (#11686)

* update iqtree to 1.6.8

* Trigger rebuild

* Update validators to 0.12.2 (#11672)

* Update python-edlib to 1.2.3.post1 (#11664)

* update for Purge Haplotigs (#11690)

* Update loompy to 2.0.16 (#11667)

* Update loompy to 2.0.16

* Update meta.yaml

* IgBLAST 1.10.0 (#11693)

* Update wtforms-alchemy to 0.16.7 (#11679)

* Update sickle to 0.6.4 (#11663)

* Update sickle to 0.6.4

* Remove fn and libgcc runtime dep

* Update confindr to 0.4.5 (#11696)

* Batvi (#11695)

* batvi initial

* Guideline compatibility..

* Dummy test section..

* Missing java dependency..

* use openjdk instead of java-jdk ..

* source specified in github ..

* trigger build (package did not have batindel directory) ..

* update SHA256 ..

* update SHA256 ..

* Update pythonpy to 0.4.11 (#11661)

* Update cortexpy to 0.45.6 (#11660)

* Update sevenbridges-python to 0.16.0 (#11674)

* Update solvebio to 2.7.0 (#11657)

* Update mathstats to 0.2.6.5 (#11656)

* Update goatools to 0.8.9 (#11641)

* Add gnies (#11627)

* Add gnies

* noarch python

* Update meta.yaml

* Add recipe for SKA v1.0 (#11581)

* Add recipe for SKA v1.0
* Add lib path for zlib
* Older gcc
* Correct install dir
* Try static linking
* Dynamic linking on OS X
* ldd command test
* correct program
* Remove ldd command

* Add recipe for transit version 2.3.1 (#11701)

* Add recipe for transit version 2.3.1

* Use skip, add spaces.

* Update meta.yaml (#11699)

* remove pyqi (#11704)

* Update python-chado to 2.2.0 (#11714)

* update python-chado

* 2.2.1

* Update vcfanno to 0.3.1 (#11710)

* FGMP-1.0.1 (#11278)

* FGMP-1.0.1 recipe
* remove unncessary build info

* add r-nabor (#11716)

* update stream to 0.2.2

* update stream to 0.2.3

* update stream to 0.2.4

* update stream to 0.2.4

* update stream to 0.2.4

* update stream to 0.2.5

* update stream to 0.2.6

* add r-nabor recipe

* update r-nabor recipe

* update r-nabor recipe

* r-pctgcdata (#11715)

* r-pctgcdata

* r-pctgcdata - fix

* r-pctgcdata - fix

* Update meta.yaml

* Fix plek by a new branch (#11605)

* Modify the PLEK recipe

* Start fixing PLEK, though it requires compilation

* update build.sh

* update yaml

* fix build.sh

* update build.sh

* Update recipe for plek

* add bioconductor-chromvar recipe (#11718)

* add bioconductor-chromvar recipe

* fix bioconductor-tissueenrich

* Apparently the popdel recipe didn't get correctly merged

* Final merge conflicts

PauAndrio added a commit that referenced this pull request Nov 4, 2018