Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Updated version info for 1.6.0 release. Modified upgrade doc to be mo…

…re concise and not duplicate other documentation.
  • Loading branch information...
commit 998227e0c39dd8ce7f8a57f28960ae0fa094f5cd 1 parent e3fe2f0
@jairideout jairideout authored
View
2  doc/index.rst
@@ -26,7 +26,7 @@ Download QIIME
* Virtual Box: The QIIME Virtual Box is an Ubuntu Linux virtual machine, pre-loaded with QIIME and its dependencies. This is the quickest way to start using QIIME. To get the Virtual Box, please `see Virtual Box documentation <./install/virtual_box.html>`_.
- * Stable Release: Currently the most stable version of QIIME is our |release| release, which you can `download here <https://github.com/downloads/qiime/qiime/Qiime-1.6.0.tar.gz>`_.
+ * Stable Release: Currently the most stable version of QIIME is our |release| release, which you can `download here <ftp://thebeast.colorado.edu/pub/qiime-releases/qiime-1.6.0.tar.gz>`_.
* Development Version: QIIME is under very active development. To get the latest development version of QIIME, you access our git repository, which is hosted on GitHub. While this code is subject to minor changes in interface, it will provide access to the latest and greatest features. The official web documentation is likely to be out-of-date with respect to the development software. You should instead refer to the documentation in Qiime/doc. Check out the latest version of QIIME using git with the command::
View
10 doc/install/install.rst
@@ -110,7 +110,7 @@ First, change to the directory where you would like to download QIIME::
Stable Release
^^^^^^^^^^^^^^
-Currently the most stable version of QIIME is our |release| release, which you can download from `here <https://github.com/downloads/qiime/qiime/Qiime-1.6.0.tar.gz>`_.
+Currently the most stable version of QIIME is our |release| release, which you can download from `here <ftp://thebeast.colorado.edu/pub/qiime-releases/qiime-1.6.0.tar.gz>`_.
Latest Development Version
^^^^^^^^^^^^^^^^^^^^^^^^^^
@@ -126,11 +126,11 @@ Unpacking QIIME (release only)
------------------------------
After downloading the QIIME release tar file you'll need to unpack the code. For simplicity in this document, we will assume that you have downloaded QIIME to the directory ``/home/qiime/``.
-Unpack the release Qiime tar file with the commands::
+Unpack the release .tar.gz file with the commands::
- cd /home/qiime_user
- tar -xvzf Qiime-1.6.0.tar.gz
- ln -s /home/qiime/Qiime-1.6.0 /home/qiime/Qiime
+ cd /home/qiime
+ tar -xvzf qiime-1.6.0.tar.gz
+ ln -s /home/qiime/qiime-1.6.0 /home/qiime/Qiime
If you have downloaded the development version from GitHub, QIIME is already unpacked.
View
28 doc/install/upgrade.rst
@@ -2,24 +2,22 @@
Upgrading to the latest version of QIIME
========================================
-This page documents how to install a new version of QIIME from an installation of the previous version. It should also be possible to follow the steps to upgrade from older versions to the most recent version, but it's best to review all steps in that case to ensure that you won't be performing unnecessary steps.
+This page describes various ways to upgrade your QIIME installation to a new version.
For a detailed history of the most notable changes between versions see the `QIIME ChangeLog <https://github.com/qiime/qiime/blob/master/ChangeLog.md>`_. This points to the most recent version, so will usually also give a preview of the changes that are coming in the next version of QIIME.
-1.5.0 to 1.5.0-dev (Linux)
+Linux users
+-----------
+If you have QIIME installed on a Linux machine, the easiest way to upgrade is by using the `qiime-deploy <https://github.com/qiime/qiime-deploy>`_ tool. The `qiime-deploy <https://github.com/qiime/qiime-deploy>`_ website has instructions for how to upgrade an existing installation.
+
+Virtual Machine (VM) users
--------------------------
-If you want to use the development version of QIIME on any Linux box, we
-recommend using the `qiime-deploy <https://github.com/qiime/qiime-deploy>`_
-tool to perform the upgrade.
+If you run QIIME from within a virtual machine, download the latest QIIME image and follow the install instructions :ref:`virtual_box`.
-1.4.0 to 1.5.0 (QIIME Virtual Machines)
----------------------------------------
-The new version of the QIIME virtual machine (VM) is based on Ubuntu 12.04 (LTS) due to this upgrade in the operating system we can not support autoupdates. Thus we suggest downloading a new full VM and following the install instructions :ref:`virtual_box`.
+Amazon Web Services (AWS) users
+-------------------------------
+If you run QIIME using the AWS EC2 service, visit `this page <http://qiime.org/home_static/dataFiles.html>`_ for the latest QIIME AMI.
-1.4.0 to 1.5.0 (general)
-------------------------
- * mothur support has been updated to use its latest version 1.25.0, which can be found `here <http://www.mothur.org/w/images/6/6d/Mothur.1.25.0.zip>`_.
- * rtax support has been added, which can be found `here <http://dev.davidsoergel.com/trac/rtax>`_.
- * pplacer support has been added, which can be found `here <http://matsen.fhcrc.org/pplacer/builds/pplacer-v1.1-Linux.tar.gz>`_.
- * raxml support has been updated to use its latest version 7.3.0, which can be found `here <ftp://thebeast.colorado.edu/pub/QIIME-v1.5.0-dependencies/stamatak-standard-RAxML-5_7_2012.tgz>`_.
- * usearch support has been updated to use its latest version 5.2.32, which can be found `here <http://www.drive5.com/usearch/>`_.
+Mac OS X users / Native QIIME installation
+------------------------------------------
+If you run QIIME on Mac OS X or have a native install (e.g. you are not using `qiime-deploy <https://github.com/qiime/qiime-deploy>`_ to install QIIME on Linux), you will need to manually upgrade the versions of QIIME's dependencies that have changed. To see a complete list of required dependency versions, please see `this page <install.html>`_. For a list of dependency versions that have changed between QIIME releases, please see the `QIIME ChangeLog <https://github.com/qiime/qiime/blob/master/ChangeLog.md>`_.
View
2  requirements.txt
@@ -1,3 +1,3 @@
-PyCogent>=1.5.1
+cogent>=1.5.3
matplotlib=1.1.0
numpy>=1.5.1
View
4 setup.py
@@ -69,8 +69,8 @@ def build_denoiser():
pycogent_version = tuple([int(v) \
for v in re.split("[^\d]", cogent.__version__) if v.isdigit()])
-if pycogent_version < (1,5):
- print "PyCogent >= 1.5.0 required, but %s is installed." % cogent.__version__
+if pycogent_version < (1,5,3):
+ print "PyCogent >= 1.5.3 required, but %s is installed." % cogent.__version__
exit(1)
if app_path("ghc"):
Please sign in to comment.
Something went wrong with that request. Please try again.