New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Running example scripts errors #86

Closed
joshuajnoble opened this Issue Aug 7, 2013 · 7 comments

Comments

Projects
None yet
4 participants
@joshuajnoble

joshuajnoble commented Aug 7, 2013

This could just be a matter of updating the example calls or maybe something more significant, or something that's getting misconfigured using the install instructions from here

WA-003458-AP:openbr joshua.noble$ br -algorithm FaceRecognition \
>      -compare data/MEDS/img/S354-01-t10_01.jpg data/MEDS/img/S354-02-t10_01.jpg \
>      -compare data/MEDS/img/S354-01-t10_01.jpg data/MEDS/img/S386-04-t10_01.jpg
Set algorithm to FaceRecognition
Comparing data/MEDS/img/S354-01-t10_01.jpg and data/MEDS/img/S354-02-t10_01.jpg
OpenCV Error: Assertion failed (map1.size().area() > 0) in remap, file /Users/joshua.noble/Downloads/opencv-2.4.5/modules/imgproc/src/imgwarp.cpp, line 2940
Warning: Exception triggered when processing data/MEDS/img/S354-01-t10_01.jpg[Affine_0=(223,242), Affine_1=(314,244), DFFS=0, FTE=false, FTO=false, Face=(147,145,250,250), First_Eye=(223,242), Gallery=data/MEDS/img/S354-01-t10_01.jpg, Index=0, Points=[(223,242), (314,244)], Rects=[(147,145,250,250)], Second_Eye=(314,244)] with transform RndSubspace
  File: /Users/joshua.noble/code/openbr/openbr/openbr_plugin.cpp
  Function: void _project(const br::Transform *, const br::Template *, br::Template *)
  Line: 1144
Fatal: Empty template.
  File: /Users/joshua.noble/code/openbr/./openbr/openbr_plugin.h
  Function: const cv::Mat &br::Template::m() const
  Line: 330
Abort trap: 6
@jklontz

This comment has been minimized.

Show comment
Hide comment
@jklontz

jklontz Aug 7, 2013

Member

Is this from the 0.3 release or the head of the master branch?

On Wed, Aug 7, 2013 at 2:57 AM, joshua noble notifications@github.comwrote:

This could just be a matter of updating the example callshttp://openbiometrics.org/doxygen/latest/group__cli.htmlor maybe something more significant, or something that's getting
misconfigured using the install instructions from herehttp://openbiometrics.org/doxygen/latest/installation.html

WA-003458-AP:openbr joshua.noble$ br -algorithm FaceRecognition \

 -compare data/MEDS/img/S354-01-t10_01.jpg data/MEDS/img/S354-02-t10_01.jpg \
 -compare data/MEDS/img/S354-01-t10_01.jpg data/MEDS/img/S386-04-t10_01.jpg

Set algorithm to FaceRecognition
Comparing data/MEDS/img/S354-01-t10_01.jpg and data/MEDS/img/S354-02-t10_01.jpg
OpenCV Error: Assertion failed (map1.size().area() > 0) in remap, file /Users/joshua.noble/Downloads/opencv-2.4.5/modules/imgproc/src/imgwarp.cpp, line 2940
Warning: Exception triggered when processing data/MEDS/img/S354-01-t10_01.jpg[Affine_0=(223,242), Affine_1=(314,244), DFFS=0, FTE=false, FTO=false, Face=(147,145,250,250), First_Eye=(223,242), Gallery=data/MEDS/img/S354-01-t10_01.jpg, Index=0, Points=[(223,242), (314,244)], Rects=[(147,145,250,250)], Second_Eye=(314,244)] with transform RndSubspace
File: /Users/joshua.noble/code/openbr/openbr/openbr_plugin.cpp
Function: void _project(const br::Transform *, const br::Template *, br::Template *)
Line: 1144
Fatal: Empty template.
File: /Users/joshua.noble/code/openbr/./openbr/openbr_plugin.h
Function: const cv::Mat &br::Template::m() const
Line: 330
Abort trap: 6


Reply to this email directly or view it on GitHubhttps://github.com/biometrics/openbr/issues/86
.

Member

jklontz commented Aug 7, 2013

Is this from the 0.3 release or the head of the master branch?

On Wed, Aug 7, 2013 at 2:57 AM, joshua noble notifications@github.comwrote:

This could just be a matter of updating the example callshttp://openbiometrics.org/doxygen/latest/group__cli.htmlor maybe something more significant, or something that's getting
misconfigured using the install instructions from herehttp://openbiometrics.org/doxygen/latest/installation.html

WA-003458-AP:openbr joshua.noble$ br -algorithm FaceRecognition \

 -compare data/MEDS/img/S354-01-t10_01.jpg data/MEDS/img/S354-02-t10_01.jpg \
 -compare data/MEDS/img/S354-01-t10_01.jpg data/MEDS/img/S386-04-t10_01.jpg

Set algorithm to FaceRecognition
Comparing data/MEDS/img/S354-01-t10_01.jpg and data/MEDS/img/S354-02-t10_01.jpg
OpenCV Error: Assertion failed (map1.size().area() > 0) in remap, file /Users/joshua.noble/Downloads/opencv-2.4.5/modules/imgproc/src/imgwarp.cpp, line 2940
Warning: Exception triggered when processing data/MEDS/img/S354-01-t10_01.jpg[Affine_0=(223,242), Affine_1=(314,244), DFFS=0, FTE=false, FTO=false, Face=(147,145,250,250), First_Eye=(223,242), Gallery=data/MEDS/img/S354-01-t10_01.jpg, Index=0, Points=[(223,242), (314,244)], Rects=[(147,145,250,250)], Second_Eye=(314,244)] with transform RndSubspace
File: /Users/joshua.noble/code/openbr/openbr/openbr_plugin.cpp
Function: void _project(const br::Transform *, const br::Template *, br::Template *)
Line: 1144
Fatal: Empty template.
File: /Users/joshua.noble/code/openbr/./openbr/openbr_plugin.h
Function: const cv::Mat &br::Template::m() const
Line: 330
Abort trap: 6


Reply to this email directly or view it on GitHubhttps://github.com/biometrics/openbr/issues/86
.

@ghost ghost assigned jklontz Aug 7, 2013

@joshuajnoble

This comment has been minimized.

Show comment
Hide comment
@joshuajnoble

joshuajnoble Aug 7, 2013

That's actually from 0.3. I'm pulling down head right now to try that.

joshuajnoble commented Aug 7, 2013

That's actually from 0.3. I'm pulling down head right now to try that.

@joshuajnoble

This comment has been minimized.

Show comment
Hide comment
@joshuajnoble

joshuajnoble Aug 8, 2013

Trying this with master/head gives the same result. Also, running test after following the installation instructions and running downloadDatasets.sh gives:

$ make test
Running tests...
Test project /Users/joshua.noble/code/OpenBR/openbr/build
    Start 1: br_initialize
1/8 Test #1: br_initialize ......................   Passed    5.57 sec
    Start 2: br_objects
2/8 Test #2: br_objects .........................***Exception: Other  9.63 sec
    Start 3: br_draw_face_detection
3/8 Test #3: br_draw_face_detection .............***Exception: Other  1.39 sec
    Start 4: age_estimation_test
4/8 Test #4: age_estimation_test ................***Exception: Other  2.79 sec
    Start 5: face_recognition_test
5/8 Test #5: face_recognition_test ..............***Exception: Other  2.48 sec
    Start 6: face_recognition_evaluation_test
6/8 Test #6: face_recognition_evaluation_test ...***Exception: Other  1.40 sec
    Start 7: face_recognition_search_test
7/8 Test #7: face_recognition_search_test .......***Exception: Other  1.45 sec
    Start 8: gender_estimation_test
8/8 Test #8: gender_estimation_test .............***Exception: Other  1.62 sec

13% tests passed, 7 tests failed out of 8

Total Test time (real) =  26.42 sec

The following tests FAILED:
      2 - br_objects (OTHER_FAULT)
      3 - br_draw_face_detection (OTHER_FAULT)
      4 - age_estimation_test (OTHER_FAULT)
      5 - face_recognition_test (OTHER_FAULT)
      6 - face_recognition_evaluation_test (OTHER_FAULT)
      7 - face_recognition_search_test (OTHER_FAULT)
      8 - gender_estimation_test (OTHER_FAULT)
Errors while running CTest
make: *** [test] Error 8

Maybe just something that needs to be updated in the directions/documentation?

joshuajnoble commented Aug 8, 2013

Trying this with master/head gives the same result. Also, running test after following the installation instructions and running downloadDatasets.sh gives:

$ make test
Running tests...
Test project /Users/joshua.noble/code/OpenBR/openbr/build
    Start 1: br_initialize
1/8 Test #1: br_initialize ......................   Passed    5.57 sec
    Start 2: br_objects
2/8 Test #2: br_objects .........................***Exception: Other  9.63 sec
    Start 3: br_draw_face_detection
3/8 Test #3: br_draw_face_detection .............***Exception: Other  1.39 sec
    Start 4: age_estimation_test
4/8 Test #4: age_estimation_test ................***Exception: Other  2.79 sec
    Start 5: face_recognition_test
5/8 Test #5: face_recognition_test ..............***Exception: Other  2.48 sec
    Start 6: face_recognition_evaluation_test
6/8 Test #6: face_recognition_evaluation_test ...***Exception: Other  1.40 sec
    Start 7: face_recognition_search_test
7/8 Test #7: face_recognition_search_test .......***Exception: Other  1.45 sec
    Start 8: gender_estimation_test
8/8 Test #8: gender_estimation_test .............***Exception: Other  1.62 sec

13% tests passed, 7 tests failed out of 8

Total Test time (real) =  26.42 sec

The following tests FAILED:
      2 - br_objects (OTHER_FAULT)
      3 - br_draw_face_detection (OTHER_FAULT)
      4 - age_estimation_test (OTHER_FAULT)
      5 - face_recognition_test (OTHER_FAULT)
      6 - face_recognition_evaluation_test (OTHER_FAULT)
      7 - face_recognition_search_test (OTHER_FAULT)
      8 - gender_estimation_test (OTHER_FAULT)
Errors while running CTest
make: *** [test] Error 8

Maybe just something that needs to be updated in the directions/documentation?

@jklontz

This comment has been minimized.

Show comment
Hide comment
@jklontz

jklontz Aug 8, 2013

Member

I haven't noticed any issues in the documentation. Did you make sure to run git submodule init & git submodule update, do a clean rebuild, and then reinstall?

If so, what os/compiler are you running? I'll try to reproduce...

Member

jklontz commented Aug 8, 2013

I haven't noticed any issues in the documentation. Did you make sure to run git submodule init & git submodule update, do a clean rebuild, and then reinstall?

If so, what os/compiler are you running? I'll try to reproduce...

@joshuajnoble

This comment has been minimized.

Show comment
Hide comment
@joshuajnoble

joshuajnoble Aug 11, 2013

Whoops, I forgot to run git submodule init and git submodule update and did so, getting this from the tests:

Running tests...
Test project /Users/joshua.noble/code/OpenBR/openbr/build
    Start 1: br_initialize
1/8 Test #1: br_initialize ......................   Passed    4.78 sec
    Start 2: br_objects
2/8 Test #2: br_objects .........................***Exception: SegFault  8.17 sec
    Start 3: br_draw_face_detection
3/8 Test #3: br_draw_face_detection .............   Passed    1.68 sec
    Start 4: age_estimation_test
4/8 Test #4: age_estimation_test ................   Passed   25.73 sec
    Start 5: face_recognition_test
5/8 Test #5: face_recognition_test ..............   Passed    5.45 sec
    Start 6: face_recognition_evaluation_test
6/8 Test #6: face_recognition_evaluation_test ...   Passed    2.01 sec
    Start 7: face_recognition_search_test
7/8 Test #7: face_recognition_search_test .......   Passed   31.29 sec
    Start 8: gender_estimation_test
8/8 Test #8: gender_estimation_test .............   Passed   12.11 sec

88% tests passed, 1 tests failed out of 8

Total Test time (real) =  91.37 sec

The following tests FAILED:
      2 - br_objects (SEGFAULT)
Errors while running CTest
make: **\* [test] Error 8

I'm on OSX 10.7 using llvmgcc42 if you're curious about the br_objects one but I'm going to go ahead and close this issue. Thanks for the help!

joshuajnoble commented Aug 11, 2013

Whoops, I forgot to run git submodule init and git submodule update and did so, getting this from the tests:

Running tests...
Test project /Users/joshua.noble/code/OpenBR/openbr/build
    Start 1: br_initialize
1/8 Test #1: br_initialize ......................   Passed    4.78 sec
    Start 2: br_objects
2/8 Test #2: br_objects .........................***Exception: SegFault  8.17 sec
    Start 3: br_draw_face_detection
3/8 Test #3: br_draw_face_detection .............   Passed    1.68 sec
    Start 4: age_estimation_test
4/8 Test #4: age_estimation_test ................   Passed   25.73 sec
    Start 5: face_recognition_test
5/8 Test #5: face_recognition_test ..............   Passed    5.45 sec
    Start 6: face_recognition_evaluation_test
6/8 Test #6: face_recognition_evaluation_test ...   Passed    2.01 sec
    Start 7: face_recognition_search_test
7/8 Test #7: face_recognition_search_test .......   Passed   31.29 sec
    Start 8: gender_estimation_test
8/8 Test #8: gender_estimation_test .............   Passed   12.11 sec

88% tests passed, 1 tests failed out of 8

Total Test time (real) =  91.37 sec

The following tests FAILED:
      2 - br_objects (SEGFAULT)
Errors while running CTest
make: **\* [test] Error 8

I'm on OSX 10.7 using llvmgcc42 if you're curious about the br_objects one but I'm going to go ahead and close this issue. Thanks for the help!

@caotto

This comment has been minimized.

Show comment
Hide comment
@caotto

caotto Aug 11, 2013

Member

br -objects is relatively fragile, and will break whenever some foolish person (such as myself) pushes a transform that doesn't initialize correctly when given empty inputs, so thanks for the bug report.

Member

caotto commented Aug 11, 2013

br -objects is relatively fragile, and will break whenever some foolish person (such as myself) pushes a transform that doesn't initialize correctly when given empty inputs, so thanks for the bug report.

@terany

This comment has been minimized.

Show comment
Hide comment
@terany

terany Jul 12, 2015

I struggled on the same problem on the last few days, only the br_initialize is passed.
I've followed the installation procedures, and make sure qt4 is not installed.
I've tried on the unbuntu 14 and 13, but got the same result.
What else can I check and to solve the problem?

terany commented Jul 12, 2015

I struggled on the same problem on the last few days, only the br_initialize is passed.
I've followed the installation procedures, and make sure qt4 is not installed.
I've tried on the unbuntu 14 and 13, but got the same result.
What else can I check and to solve the problem?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment