Permalink
Browse files

Avoid warning about C Python 3.3.1 if using PyPy3

  • Loading branch information...
1 parent 6e45a34 commit 41c32c9910338137e29ab73d187113e2250fc6e1 @peterjc peterjc committed Aug 1, 2013
Showing with 3 additions and 3 deletions.
  1. +3 −3 setup.py
View
@@ -71,13 +71,13 @@ def get_yes_or_no(question, default):
elif sys.version_info[:2] == (2, 5):
print("WARNING - Biopython is dropping support for Python 2.5 after this release")
elif sys.version_info[:2] == (3, 0):
- print("Biopython will not work on Python 3.0, please try Python 3.3.2 or later")
+ print("Biopython will not work on Python 3.0, please try Python 3.3 or later")
sys.exit(1)
elif sys.version_info[0] == 3:
if sys.version_info[:2] < (3, 3):
#TODO - Turn off old buildbots/travis and make this an error?
- print("WARNING - For Python 3, we strongly recommend Python 3.3.2 or later.")
- if sys.version_info == (3, 3, 1):
+ print("WARNING - For Python 3, we strongly recommend Python 3.3 or later.")
+ if sys.version_info == (3, 3, 1) and sys.implementation == "cpython":
print("WARNING - Rather than Python 3.3.1, we recommend Python 3.3.0, or 3.3.2, or later.")
import do2to3
python3_source = "build/py%i.%i" % sys.version_info[:2]

0 comments on commit 41c32c9

Please sign in to comment.