Browse files

PDB.PDBParser: no need to import 'with' from __future__

Since we no longer support Python 2.4
  • Loading branch information...
1 parent 1d0d216 commit 52f5bbf3f1bef507aab5876fc8e34d6cd814989e @etal etal committed Nov 8, 2012
Showing with 0 additions and 3 deletions.
  1. +0 −3 Bio/PDB/PDBParser.py
View
3 Bio/PDB/PDBParser.py
@@ -5,9 +5,6 @@
"""Parser for PDB files."""
-# For using with statement in Python 2.5 or Jython
-from __future__ import with_statement
-
import warnings
import numpy

3 comments on commit 52f5bbf

@peterjc
Biopython Project member

We still support Python 2.5 (and Jython 2.5), and they require the from future import:
https://travis-ci.org/biopython/biopython/builds/3115945

@etal

Ack, sorry!

@peterjc
Biopython Project member

Not to worry - the automated tests caught it, and it was trivial to revert. I'd have let you do it but I wanted to apply Christian's ClustalW work last night.

Please sign in to comment.