Permalink
Browse files

Merge pull request #6938

dbacc69 build: If both Qt4 and Qt5 are installed, use Qt5 (Wladimir J. van der Laan)
  • Loading branch information...
laanwj committed Nov 4, 2015
2 parents c702521 + dbacc69 commit 193f7b553e0ad41e6579adbce867ef14866034b0
Showing with 3 additions and 3 deletions.
  1. +1 −1 build-aux/m4/bitcoin_qt.m4
  2. +1 −1 configure.ac
  3. +1 −1 doc/build-unix.md
@@ -50,7 +50,7 @@ AC_DEFUN([BITCOIN_QT_INIT],[
dnl enable qt support
AC_ARG_WITH([gui],
[AS_HELP_STRING([--with-gui@<:@=no|qt4|qt5|auto@:>@],
- [build bitcoin-qt GUI (default=auto, qt4 tried first)])],
+ [build bitcoin-qt GUI (default=auto, qt5 tried first)])],
[
bitcoin_qt_want_version=$withval
if test x$bitcoin_qt_want_version = xyes; then
View
@@ -538,7 +538,7 @@ fi
BITCOIN_QT_INIT
dnl sets $bitcoin_enable_qt, $bitcoin_enable_qt_test, $bitcoin_enable_qt_dbus
-BITCOIN_QT_CONFIGURE([$use_pkgconfig], [qt4])
+BITCOIN_QT_CONFIGURE([$use_pkgconfig], [qt5])
if test x$build_bitcoin_utils$build_bitcoind$bitcoin_enable_qt$use_tests = xnononono; then
use_boost=no
View
@@ -100,7 +100,7 @@ Dependencies for the GUI: Ubuntu & Debian
If you want to build Bitcoin-Qt, make sure that the required packages for Qt development
are installed. Either Qt 5 or Qt 4 are necessary to build the GUI.
-If both Qt 4 and Qt 5 are installed, Qt 4 will be used. Pass `--with-gui=qt5` to configure to choose Qt5.
+If both Qt 4 and Qt 5 are installed, Qt 5 will be used. Pass `--with-gui=qt4` to configure to choose Qt4.
To build without GUI pass `--without-gui`.
To build with Qt 5 (recommended) you need the following:

0 comments on commit 193f7b5

Please sign in to comment.