Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

readme-qt.rst references libdb4.8++-dev which doesn't exist in ubuntu 12.04 #2027

Closed
mdude77 opened this Issue · 9 comments

7 participants

@mdude77

Being a linux nub, I hesitate to try to modify the readme myself.

I tried libdb++dev which pulled in 5.1, which allowed me to start compilng. I then ran into:


src/net.cpp:18:32: fatal error: miniupnpd/miniwget.h: no such file or directory

I then found:


qmake "USE_UPNP=-"

instead of

qmake "USE_UPNP="

that allowed me to fully compile the latest git.

M

@luke-jr

libdb4.8++-dev should be in the Bitcoin PPA. If you compile with any other version, your wallet will not be compatible with other client builds.

Not sure how USE_UPNP=- relates to this issue. Sounds like it's working as expected.

@mdude77

I was referring to https://github.com/bitcoin/bitcoin/blob/master/doc/readme-qt.rst. That makes no mention of Bitcoin PPA. My point is, the instructions, as written, don't work for this version of ubuntu. I'm too ignorant of linux to know if it affects other versions or not.

@robbak
@mdude77

I see that now, regarding the USE_UPNP flag. That was further down, didn't read that far. :( Thanks.

That doesn't seem to help the 4.8 reference though.

@burger2

is this a fix for this problem?

#2055

2fdd1a8

@laanwj
Owner
@laanwj
Owner

build-unix.txt now mentions where the 4.8 package is available, closing

@laanwj laanwj closed this
@scottie

kinda of amusing you are so quick to close the topic without really having any information regarding fix, you simply just assume build-linux.txt mentions it?? for it dosnt... Anyway me and a lot of other people are using 5.1 and will continue to use 5.1 so expect your wallets to be obsolete in good time you will have to transfer your balance to a new wallet.

@sipa
Owner

You're welcome to use 5.1, if you don't want or need compatibility with builds that use 4.8 - the information is just there to not accidentally break people's compatibility. Recent Ubuntu releases do not have dev files for 4.8 anyway, so you'll need to find them in a backport or install them manually. Again, no problem to use a different version if you want.

Also, the long term plan is to get rid of BDB altogether, which has these terrible compatibility problems between versions.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.