New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

End support for Windows XP and older #7681

Closed
laanwj opened this Issue Mar 14, 2016 · 8 comments

Comments

Projects
None yet
7 participants
@laanwj
Member

laanwj commented Mar 14, 2016

Drop support for Windows XP and older - at some point.

Microsoft support for Windows XP ended April 8th, 2014 (https://www.microsoft.com/en-us/WindowsForBusiness/end-of-xp-support). This means that not even critical security updates are being released anymore. This makes it dangerous to run a wallet on this OS.

There are also some strange, apparently random crashes on WinXP with 0.12, see #7674 and #7639.

I haven't heard of any reports of this happening on other versions of windows.

I hope it is possible to debug and fix this, but if not, and it turns out to be truly a WinXP only issue, we'll have to announce this through the appropriate channels.

@laanwj laanwj added the Windows label Mar 14, 2016

@rebroad

This comment has been minimized.

Show comment
Hide comment
@rebroad

rebroad Mar 14, 2016

Contributor

I agree that XP should certainly not be used for wallets, but it would be a shame not to be able to utilise older hardware running XP for use as a full-node.

Contributor

rebroad commented Mar 14, 2016

I agree that XP should certainly not be used for wallets, but it would be a shame not to be able to utilise older hardware running XP for use as a full-node.

@laanwj

This comment has been minimized.

Show comment
Hide comment
@laanwj

laanwj Mar 15, 2016

Member

I agree, for now I'll let this depend on whether #7674 gets resolved before 0.13.0.

We've always had a problem with the windows version not being as actively supported as the linux/osx versions, as most developers use one of those. I doubt anyone is actively developing on XP. But surprise me.

Member

laanwj commented Mar 15, 2016

I agree, for now I'll let this depend on whether #7674 gets resolved before 0.13.0.

We've always had a problem with the windows version not being as actively supported as the linux/osx versions, as most developers use one of those. I doubt anyone is actively developing on XP. But surprise me.

@btcdrak

This comment has been minimized.

Show comment
Hide comment
@btcdrak

btcdrak Mar 23, 2016

Member

@coinyBit2 XP is not officially supported by Microsoft. It's a 3rd party, independent developer called harkaz, source.

Bitcoin Core is financial software so unfortunately cannot responsibly keep supporting a vulnerable platform, regardless of well meaning 3rd party support.

Member

btcdrak commented Mar 23, 2016

@coinyBit2 XP is not officially supported by Microsoft. It's a 3rd party, independent developer called harkaz, source.

Bitcoin Core is financial software so unfortunately cannot responsibly keep supporting a vulnerable platform, regardless of well meaning 3rd party support.

@jonathancross

This comment has been minimized.

Show comment
Hide comment
@jonathancross

jonathancross Apr 7, 2016

Contributor

As someone who had to retire an old XP system recently, I understand how you feel, but I agree with @laanwj and @btcdrak on this one.

utilise older hardware running XP...

The hardware would be much better utilized with Xubuntu or Lubuntu for example. I'd recommend taking the plunge and trying it out.

If the goal is to benefit the Bitcoin network (rather than running a wallet), then we might call into question the benefits such an old system will bring to the network.

Contributor

jonathancross commented Apr 7, 2016

As someone who had to retire an old XP system recently, I understand how you feel, but I agree with @laanwj and @btcdrak on this one.

utilise older hardware running XP...

The hardware would be much better utilized with Xubuntu or Lubuntu for example. I'd recommend taking the plunge and trying it out.

If the goal is to benefit the Bitcoin network (rather than running a wallet), then we might call into question the benefits such an old system will bring to the network.

@laanwj

This comment has been minimized.

Show comment
Hide comment
@laanwj

laanwj Apr 8, 2016

Member

Nicely said @jonathancross

Member

laanwj commented Apr 8, 2016

Nicely said @jonathancross

@tzofeolam

This comment has been minimized.

Show comment
Hide comment
@tzofeolam

tzofeolam May 6, 2016

There seems to be no Windows XP related problem in the Bitcoin Core code itself but in the QT library it uses. And the QT project still supports Windows XP and fixes backward compatibility bugs related to Windows XP. Please read my comment in #7674 and consider either upgrading to the latest QT version or using a custom QT (older version that is currently in use) build with -no-directwrite flag.

tzofeolam commented May 6, 2016

There seems to be no Windows XP related problem in the Bitcoin Core code itself but in the QT library it uses. And the QT project still supports Windows XP and fixes backward compatibility bugs related to Windows XP. Please read my comment in #7674 and consider either upgrading to the latest QT version or using a custom QT (older version that is currently in use) build with -no-directwrite flag.

@diegoviola

This comment has been minimized.

Show comment
Hide comment
@diegoviola

diegoviola Jun 25, 2016

Contributor

Just run Linux.

Contributor

diegoviola commented Jun 25, 2016

Just run Linux.

@HenryBarton

This comment has been minimized.

Show comment
Hide comment
@HenryBarton

HenryBarton Jul 18, 2016

I'm with tzofeolam: Let's upgrade QT in 0.13. XP is very much alive and I hate to see great software drop support for it "just 'cause", even when the program doesn't require modern API's.

HenryBarton commented Jul 18, 2016

I'm with tzofeolam: Let's upgrade QT in 0.13. XP is very much alive and I hate to see great software drop support for it "just 'cause", even when the program doesn't require modern API's.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment