Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Update doc/build-unix.txt #1755

Merged
merged 1 commit into from

7 participants

osmosis Wladimir J. van der Laan Gregory Maxwell BitcoinPullTester Matt Corallo P. Kaufmann stevenwagner
osmosis

how to build on ubuntu 12.04

P. Kaufmann Diapolo commented on the diff
doc/build-unix.txt
((10 lines not shown))
-sudo apt-get install libqrencode-dev
-
-If using Boost 1.37, append -mt to the boost libraries in the makefile.
+Build requirements:
+ sudo apt-get install build-essential
+ sudo apt-get install libssl-dev
+
+for Ubuntu 12.04:
+ sudo apt-get install libdb5.1-dev
+ sudo apt-get install libdb5.1++-dev
+ sudo apt-get install libboost-all-dev
+
+for other Ubuntu & Debian:
+ sudo apt-get install libdb4.8-dev
+ sudo apt-get install libdb4.8++-dev
+ sudo apt-get install libboost1.37-dev
P. Kaufmann
Diapolo added a note

I'm rather sure it would be better to not use such an old Boost version, but if we use that for the Linux build this just reflects it ;).

if thats the case, better update line 59 too. It specifies "Versions used in this release: Boost 1.37". I tested on ubuntu 12.04, so added the name of the newer package accordingly.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Wladimir J. van der Laan
Owner

Is this only for the bitcoind build? Or also bitcoin-qt? Because it includes libqrencode et al which are only used by the GUI.
In that case you also need to add qt4-qmake libqt4-dev

osmosis

thats a good point. Yes, strangely bitcoind does require libqrencode...unless the disable flag is specified. I havent built bitcoin-qt.

Wladimir J. van der Laan
Owner

You must be wrong. I cannot find any mention of even the word 'qr' in makefile.unix.

osmosis

scratch that... I meant libminiupnpc-dev. No, libqrencode is not required. Ill go ahead and add the qt libs to the list.

osmosis

ok, removed libqrencode from build-unix.txt, and left other qt libs out. QR instructions are in readme-qt.rst

Gregory Maxwell
Owner

Hm. Is it wise to add instructions that will have people building binaries which will write wallets the project builds can't read?

Wladimir J. van der Laan
Owner
BitcoinPullTester

Automatic sanity-testing: PASSED, see http://jenkins.bluematt.me/pull-tester/9386e61695cab47d8cd7037489c2cc86ce5ff864 for binaries and test log.

osmosis

I agree, there is no other supported way to build on ubuntu 12.04.
For 'wallets the project builds can't read', do we fail sanely?

doc/build-unix.txt
@@ -61,15 +54,23 @@ Versions used in this release:
Dependency Build Instructions: Ubuntu & Debian
----------------------------------------------
-sudo apt-get install build-essential
-sudo apt-get install libssl-dev
-sudo apt-get install libdb4.8-dev
-sudo apt-get install libdb4.8++-dev
- Boost 1.40+: sudo apt-get install libboost-all-dev
- or Boost 1.37: sudo apt-get install libboost1.37-dev
-sudo apt-get install libqrencode-dev
-
-If using Boost 1.37, append -mt to the boost libraries in the makefile.
+Build requirements:
+ sudo apt-get install build-essential
+ sudo apt-get install libssl-dev
+
+for Ubuntu 12.04:
+ sudo apt-get install libdb5.1-dev

NACK, if anything, tell them to add the ppa and use db4.*++ from there.

Wladimir J. van der Laan Owner
laanwj added a note

Maybe add a warning that it is recommended to build with db 4.x, because wallet compatibility with the binary builds will be lost when converting to db 5.x. If you don't care about compatibility there is no reason to go through the extra trouble of finding a db4.x++ package.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Wladimir J. van der Laan
Owner

This change seems to be accepted apart from the dbc++ version change. If you remove that change for now (and squash into one commit), we can at least merge this.

osmosis

added info for PPA and db compatibility. squashed changes to single commit. should be good to go.

Wladimir J. van der Laan laanwj merged commit 8b1eb56 into from
BitcoinPullTester

Automatic sanity-testing: FAILED MERGE, see http://jenkins.bluematt.me/pull-tester/224222746698db200d4c47e1611219f25fc5aa71 for test log.

This pull does not merge cleanly onto current master

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Sep 11, 2012
  1. stevenwagner

    Cleanup on doc/build-unix.txt

    stevenwagner authored Shen committed
This page is out of date. Refresh to see the latest.
Showing with 22 additions and 17 deletions.
  1. +22 −17 doc/build-unix.txt
39 doc/build-unix.txt
View
@@ -28,7 +28,6 @@ Dependencies
libdb4.8 Berkeley DB Blockchain & wallet storage
libboost Boost C++ Library
miniupnpc UPnP Support Optional firewall-jumping support
- libqrencode QRCode generation Optional QRCode generation
miniupnpc may be used for UPnP port mapping. It can be downloaded from
http://miniupnp.tuxfamily.org/files/. UPnP support is compiled in and
@@ -37,13 +36,7 @@ turned off by default. Set USE_UPNP to a different value to control this:
USE_UPNP=0 (the default) UPnP support turned off by default at runtime
USE_UPNP=1 UPnP support turned on by default at runtime
-libqrencode may be used for QRCode image generation. It can be downloaded
-from http://fukuchi.org/works/qrencode/index.html.en, or installed via
-your package manager. Set USE_QRCODE to control this:
- USE_QRCODE=0 (the default) No QRCode support - libqrcode not required
- USE_QRCODE=1 QRCode support enabled
-
-IPv6 support may be enabled by setting
+IPv6 support may be enabled by setting:
USE_IPV6=1 Enable IPv6 support
Licenses of statically linked libraries:
@@ -61,15 +54,27 @@ Versions used in this release:
Dependency Build Instructions: Ubuntu & Debian
----------------------------------------------
-sudo apt-get install build-essential
-sudo apt-get install libssl-dev
-sudo apt-get install libdb4.8-dev
-sudo apt-get install libdb4.8++-dev
- Boost 1.40+: sudo apt-get install libboost-all-dev
- or Boost 1.37: sudo apt-get install libboost1.37-dev
-sudo apt-get install libqrencode-dev
-
-If using Boost 1.37, append -mt to the boost libraries in the makefile.
+Build requirements:
+ sudo apt-get install build-essential
+ sudo apt-get install libssl-dev
+
+for Ubuntu 12.04:
+ sudo apt-get install libboost-all-dev
+
+ db4.8 packages are available at:
+ https://launchpad.net/~bitcoin/+archive/bitcoin
+
+ Ubuntu precise has packages for libdb5.1-dev and libdb5.1++-dev,
+ but using these will break binary wallet compatibility, and is not recommended.
+
+for other Ubuntu & Debian:
+ sudo apt-get install libdb4.8-dev
+ sudo apt-get install libdb4.8++-dev
+ sudo apt-get install libboost1.37-dev
P. Kaufmann
Diapolo added a note

I'm rather sure it would be better to not use such an old Boost version, but if we use that for the Linux build this just reflects it ;).

if thats the case, better update line 59 too. It specifies "Versions used in this release: Boost 1.37". I tested on ubuntu 12.04, so added the name of the newer package accordingly.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
+ (If using Boost 1.37, append -mt to the boost libraries in the makefile)
+
+Optional:
+ sudo apt-get install libminiupnpc-dev (see USE_UPNP compile flag)
Dependency Build Instructions: Gentoo
Something went wrong with that request. Please try again.