Skip to content
Permalink
Branch: master
Find file Copy path
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
47 lines (41 sloc) 3.13 KB

Dependencies

These are the dependencies currently used by Bitcoin Core. You can find instructions for installing them in the build-*.md file for your platform.

Dependency Version used Minimum required CVEs Shared Bundled Qt library
Berkeley DB 4.8.30 4.8.x No
Boost 1.64.0 1.47.0 No
Clang 3.3+ (C++11 support)
D-Bus 1.10.18 No Yes
Expat 2.2.6 No Yes
fontconfig 2.12.1 No Yes
FreeType 2.7.1 No
GCC 4.8+ (C++11 support)
HarfBuzz-NG
libevent 2.1.8-stable 2.0.22 No
libjpeg Yes
libpng Yes
librsvg
MiniUPnPc 2.0.20180203 No
OpenSSL 1.0.1k Yes
PCRE Yes
protobuf 2.6.1 No
Python (tests) 3.4
qrencode 3.4.4 No
Qt 5.9.7 5.5.1 No
XCB Yes (Linux only)
xkbcommon Yes (Linux only)
ZeroMQ 4.3.1 4.0.0 No
zlib 1.2.11 No

Controlling dependencies

Some dependencies are not needed in all configurations. The following are some factors that affect the dependency list.

Options passed to ./configure

  • MiniUPnPc is not needed with --with-miniupnpc=no.
  • Berkeley DB is not needed with --disable-wallet.
  • protobuf is not needed with --disable-bip70.
  • Qt is not needed with --without-gui.
  • If the qrencode dependency is absent, QR support won't be added. To force an error when that happens, pass --with-qrencode.
  • ZeroMQ is needed only with the --with-zmq option.

Other

  • librsvg is only needed if you need to run make deploy on (cross-compilation to) macOS.
You can’t perform that action at this time.