Permalink
Browse files

make JDK version 7 the minimum

  • Loading branch information...
Danconnolly committed May 14, 2018
1 parent 57a7464 commit f8405faeef2501d3a01d71473a89ea40d53ba2aa
Showing with 4 additions and 4 deletions.
  1. +1 −1 README.md
  2. +3 −3 core/pom.xml
View
@@ -14,7 +14,7 @@ Release notes are [here](docs/Releases.md).
### Technologies
* Java 6 for the core modules, Java 8 for everything else
* Java 7 for the core modules, Java 8 for everything else
* [Maven 3+](http://maven.apache.org) - for building the project
* [Google Protocol Buffers](https://github.com/google/protobuf) - for use with serialization and hardware communications
View
@@ -143,12 +143,12 @@
<build>
<plugins>
<!-- Ensure compilation is done under Java 6 for backwards compatibility -->
<!-- Ensure compilation is done under Java 7 -->
<plugin>
<artifactId>maven-compiler-plugin</artifactId>
<configuration>
<source>1.6</source>
<target>1.6</target>
<source>1.7</source>
<target>1.7</target>
</configuration>
</plugin>

0 comments on commit f8405fa

Please sign in to comment.