Skip to content
Permalink
Browse files

.travis.yml: update from ubuntu 12.04 to 14.04

Still keeping it old for old distro compat, but 12.04 is waaay too
old.
  • Loading branch information...
dequis committed Oct 31, 2019
1 parent 1e8f42b commit 34071192dd039af6b5ae9d2524eb3c392947ab69
Showing with 3 additions and 10 deletions.
  1. +3 −10 .travis.yml
@@ -1,18 +1,10 @@
dist: precise
dist: trusty
language: c

script:
- ./configure --pam=1 --ldap=1
- make check
- dpkg-buildpackage -uc -us -d

# ubuntu precise doesn't have libotr5, so extract a prebuilt version to ~/otr
before_install:
- wget http://dump.dequis.org/indexed/bitlbee-travis-libs/libotr5_4.1.0_amd64_with_dev_for_travis.tar.gz -O /tmp/otr.tar.gz
- echo "8424feb28a2cff3ce603ddcdff9be788701ff7e4 /tmp/otr.tar.gz" | sha1sum -c -
- tar -C "$HOME" -xf /tmp/otr.tar.gz
- sed -i "s#/usr#$HOME/otr/usr/#" "$HOME/otr/usr/lib/pkgconfig/libotr.pc"
- echo "libotr 5 libotr" > debian/shlibs.local
- dpkg-buildpackage -uc -us

env:
global:
@@ -33,6 +25,7 @@ addons:
- fakeroot
- debhelper
- devscripts
- libotr5-dev
coverity_scan:
project:
name: "bitlbee/bitlbee"

0 comments on commit 3407119

Please sign in to comment.
You can’t perform that action at this time.