Skip to content
This repository
Newer
Older
100644 39 lines (34 sloc) 1.038 kb
7d72d1c4 » mynameisfiber
2012-09-10 Updated pysimplehttp and added BaseReader+deps
1 from setuptools import setup
8811a1e5 » jehiah
2011-07-08 initial version of pysimplehttp
2
7c789aab » jehiah
2011-07-18 fix incorrect varirable in file_to_sq.py (bump rev)
3 # release steps
4 # ---------------
5 # update version variable (below)
6 # update pysimplehttp/src/__init__.__version__
7 # run python setup.py sdist
8 # upload .tar.gz to github
9 # run python setup.py register to update pypi
10
1a14a251 » mynameisfiber
2012-09-11 Compatability with recent tornado versions
11 __version__ = "0.2.1"
7d72d1c4 » mynameisfiber
2012-09-10 Updated pysimplehttp and added BaseReader+deps
12 scripts = ['pysimplehttp/scripts/ps_to_sq.py',
13 'pysimplehttp/scripts/file_to_sq.py']
14
15 setup(
16 name='pysimplehttp',
17 version=__version__,
18 author='Jehiah Czebotar',
19 author_email='jehiah@gmail.com',
20 description='Python libraries for simplehttp',
21 url='https://github.com/bitly/simplehttp',
22 classifiers=[
23 'Intended Audience :: Developers',
24 'Programming Language :: Python',
25 ],
26 download_url="http://github.com/downloads/bitly/simplehttp/pysimplehttp-%s.tar.gz" %__version__,
27
28 packages=['pysimplehttp'],
29 package_dir = {'pysimplehttp' : 'pysimplehttp/src'},
30
31 scripts = scripts,
32 install_requires = [
33 'tornado',
34 ],
35 requires = [
36 'ujson',
37 'host_pool',
38 ],
39 )
Something went wrong with that request. Please try again.