Skip to content
Combine extension for RealmSwift's types
Swift Ruby
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
Example Update example Jun 24, 2019
Sources
.gitignore Create basic structure Jun 23, 2019
.travis.yml
CombineRealm.podspec Updated version Jul 7, 2019
LICENSE Initial commit Jun 23, 2019
README.md Update README.md Jul 6, 2019

README.md

CombineRealm

CI Status Version License Platform

This library is a thin wrapper around RealmSwift ( Realm Docs ) heavily based on the amazing job on RxRealm

It is a WORK IN PROGRESS, not ready for PRODUCTION.

Installation

This library depends on RealmSwift 1.0+.

CocoaPods

CombineRealm requires CocoaPods 1.1.x or higher.

CombineRealm is available through CocoaPods. To install it, simply add the following line to your Podfile:

pod "CombineRealm"

TODO

  • Carthage
  • SPM (Support from realm still pending)
  • Test
  • Handle errors when type does not match publisher type
  • Add helpers to observe object changes
  • Add Realm operations (add, update, delete...)

Author

bitomule, bitomule@gmail.com

License

CombineRealm is available under the MIT license. See the LICENSE file for more info.

You can’t perform that action at this time.