Permalink
Browse files

Start in on doing basic project management things - travis and flake8.

Both currently fail - self-install dies after #111, and we're not actually
flake8 compat yet
  • Loading branch information...
bitprophet committed Sep 18, 2017
1 parent e29290d commit 78aa8b7b760172afd032664ad901a5866022c1d8
Showing with 34 additions and 0 deletions.
  1. +33 −0 .travis.yml
  2. +1 −0 dev-requirements.txt
View
@@ -0,0 +1,33 @@
language: python
cache:
directories:
- $HOME/.cache/pip
python:
- "2.6"
- "2.7"
- "3.3"
- "3.4"
- "3.5"
- "3.6"
- "pypy"
- "pypy3"
install:
# For some reason Travis' build envs have wildly different pip/setuptools
# versions between minor Python versions, and this can cause many hilarious
# corner packaging cases. So...
- pip install -U pip
# Setuptools 34+ seems to get less stable
- pip install 'setuptools>33,<34'
# Install dev requirements && sanity print
- pip install -r dev-requirements.txt
- pip list --format=columns
# Dev tooling sanity test: can invoke list tasks?
- inv --list
script:
# We have no real tests at present so we just make sure installation works,
# first off.
- pip install .
# Websites build OK? (Not on PyPy3, Sphinx is all "who the hell are you?" =/
- "[[ $TRAVIS_PYTHON_VERSION != 'pypy3' ]] && inv docs"
# I have this in my git pre-push hook, but contributors probably don't
- flake8
View
@@ -5,3 +5,4 @@ semantic_version>=2.4,<2.5
wheel==0.24
twine==1.5
releases>=1.2.0,<2.0
flake8==2.4.0

0 comments on commit 78aa8b7

Please sign in to comment.