Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support Boost version 1.69 #1557

Closed
jmjatlanta opened this issue Feb 5, 2019 · 6 comments

Comments

Projects
5 participants
@jmjatlanta
Copy link
Contributor

commented Feb 5, 2019

Boost 1.68 removed some headers. To compile with Boost 1.68 and above, changes will have to be made to bitshares-core.

Build Error Description
header boost/context/all.hpp cannot be found

Build Environment

  • Host OS: Ubuntu 18.10
  • Host Physical RAM 32GB
  • Source Branch/Tag: develop
  • OpenSSL Version: 1.1.0h
  • Boost Version: 1.68.0
  • C++ Compiler: g++

Steps To Reproduce
attempt to compile bitshares-core with Boost 1.68

CORE TEAM TASK LIST

  • Evaluate Build Error
  • Fix build error
  • Update Documentation
    • Wiki
    • dev.bitshares.works

@jmjatlanta jmjatlanta self-assigned this Feb 5, 2019

@abitmore abitmore added this to the Future Feature Release milestone Feb 5, 2019

@abitmore abitmore added this to To do in Feature Release (3.1.0) via automation Feb 5, 2019

@jmjatlanta

This comment has been minimized.

Copy link
Contributor Author

commented Feb 5, 2019

This was already done. Thanks @nathanhourt

@jmjatlanta jmjatlanta closed this Feb 5, 2019

Feature Release (3.1.0) automation moved this from To do to Done Feb 5, 2019

@abitmore

This comment has been minimized.

Copy link
Member

commented Feb 8, 2019

If boost 1.68 is supported we need to update README and wiki. By the way which commit(s) are for this issue?

@abitmore abitmore reopened this Feb 8, 2019

Feature Release (3.1.0) automation moved this from Done to In development Feb 8, 2019

@nathanhourt

This comment has been minimized.

Copy link
Contributor

commented Feb 9, 2019

@abitmore The most relevant to this issue's description is bitshares/bitshares-fc@2e0a03a but this one is more relevant to supporting newer versions of boost, as otherwise there were serious errors: 0da5d96

@nathanhourt

This comment has been minimized.

Copy link
Contributor

commented Feb 9, 2019

Oh, and fwiw: I can build and sync with Boost 1.69 without issue

@ryanRfox ryanRfox changed the title Support Boost version 1.68 Support Boost version 1.69 Feb 27, 2019

@ryanRfox

This comment has been minimized.

Copy link
Member

commented Feb 27, 2019

Changed the Issue title to match the intent of the PR.

@jmjatlanta

This comment has been minimized.

Copy link
Contributor Author

commented Mar 13, 2019

Fixed by several past commits plus #1648 for documentation updates.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.