Permalink
Browse files

Update notes about Xcode 9 / Swift 4 support

  • Loading branch information...
bizz84 committed Jul 16, 2017
1 parent f2ecadb commit 9ddc46c372b02ea330ff17f4de6836338928bbb6
Showing with 6 additions and 3 deletions.
  1. +1 −1 CONTRIBUTING.md
  2. +5 −2 README.md
@@ -23,7 +23,7 @@ SwiftyStoreKit aims to be a lightweight wrapper on top of [StoreKit](https://dev
While SwiftyStoreKit offers access to the [local receipt data](https://developer.apple.com/reference/foundation/bundle/1407276-appstorereceipturl), it is a non-goal to add support for persisting IAP data locally. It is up to clients to do this with a storage solution of choice (i.e. NSUserDefaults, CoreData, Keychain).
**Swift Version**: SwiftyStoreKit includes [Swift 2.3](https://github.com/bizz84/SwiftyStoreKit/tree/swift-2.3) and [Swift 2.2](https://github.com/bizz84/SwiftyStoreKit/tree/swift-2.2) branches. These legacy versions of the library are no longer maintained and all active development happens on Swift 3.0+.
**Swift Version**: SwiftyStoreKit includes [Swift 2.3](https://github.com/bizz84/SwiftyStoreKit/tree/swift-2.3) and [Swift 2.2](https://github.com/bizz84/SwiftyStoreKit/tree/swift-2.2) branches. These legacy versions are no longer maintained and all active development happens on [master](https://github.com/bizz84/SwiftyStoreKit) and [develop](https://github.com/bizz84/SwiftyStoreKit/tree/develop), which support Swift 3.x and Swift 4.x.
**Objective-C**: Currently, SwiftyStoreKit cannot be used in Objective-C projects. The main limitation is that most classes and types in the library are Swift-only. See [related issue](https://github.com/bizz84/SwiftyStoreKit/issues/123).
@@ -24,9 +24,12 @@ I'm building **Eco Buddy**, an iOS app to help you **reduce your carbon footprin
#### Got issues / pull requests / want to contribute? [Read here](CONTRIBUTING.md).
## About Xcode 9 / Swift 4.x
## About Xcode 9 / Swift 4
#### SwiftyStoreKit is compatible with Xcode 8.x (Swift 3.x) and Xcode 9 beta 3 or later (Swift 4).
**NOTE**: Apple had removed [`SKError`](https://developer.apple.com/documentation/storekit/skerror) from the iOS 11 public API on Xcode 9 betas 1 and 2. This was a bug that has been fixed on Xcode 9 beta 3.
#### Development has started on the [swift-4.0](https://github.com/bizz84/SwiftyStoreKit/tree/swift-4.0) branch, aiming to have a compilable version of SwiftyStoreKit on Xcode 9 betas.
## App startup

0 comments on commit 9ddc46c

Please sign in to comment.