New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We鈥檒l occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support for .tga images on linux? #1444

Closed
roig opened this Issue Feb 14, 2017 · 4 comments

Comments

Projects
None yet
2 participants
@roig

roig commented Feb 14, 2017

Hello I can't load a Tileset from a .TGA file, is the format unsupported by tiled? (I'm on linux). Thank you for this great tool 馃憦

@bjorn

This comment has been minimized.

Show comment
Hide comment
@bjorn

bjorn Feb 14, 2017

Owner

Hmm, I can't load TGA images on Linux myself either, will need to investigate.

How did you install Tiled?

Owner

bjorn commented Feb 14, 2017

Hmm, I can't load TGA images on Linux myself either, will need to investigate.

How did you install Tiled?

@roig

This comment has been minimized.

Show comment
Hide comment
@roig

roig Feb 15, 2017

I just downloaded the latest binary from your webpage.

roig commented Feb 15, 2017

I just downloaded the latest binary from your webpage.

bjorn added a commit that referenced this issue Feb 21, 2017

Travis CI: Install additional Qt image format plugins
This should add support for TIFF, MNG, TGA, WBMP and WEBP to the Linux
binary releases.

Closes #1444

@bjorn bjorn closed this in 7ca1e19 Feb 21, 2017

@bjorn

This comment has been minimized.

Show comment
Hide comment
@bjorn

bjorn Feb 21, 2017

Owner

So there were two problems here. First, the version of linuxdeployqt I was using had a bug causing it to only ship the SVG image format plugin. After upgrading that there was still no TGA support though, since that plugin needed to be installed separately as part of the Qt Image Formats package.

Finally, the linuxdeployqt upgrade caused the SVG image format plugin to go missing, so I needed to do a workaround for that.

But now all should be fine. :-)

Owner

bjorn commented Feb 21, 2017

So there were two problems here. First, the version of linuxdeployqt I was using had a bug causing it to only ship the SVG image format plugin. After upgrading that there was still no TGA support though, since that plugin needed to be installed separately as part of the Qt Image Formats package.

Finally, the linuxdeployqt upgrade caused the SVG image format plugin to go missing, so I needed to do a workaround for that.

But now all should be fine. :-)

@roig

This comment has been minimized.

Show comment
Hide comment
@roig

roig Feb 22, 2017

Thank you! 馃憤

roig commented Feb 22, 2017

Thank you! 馃憤

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment