New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can no longer bulk-edit tile properties since 1.0 #1611

Closed
eevee opened this Issue Jun 11, 2017 · 5 comments

Comments

Projects
None yet
2 participants
@eevee

eevee commented Jun 11, 2017

Previously, it was possible to select multiple tiles and add a property to all of them at once in the properties pane. Since 1.0, only the last tile selected will be affected.

@bjorn

This comment has been minimized.

Show comment
Hide comment
@bjorn

bjorn Jun 11, 2017

Owner

Hmm, I can't reproduce this. Can you be more specific about the version you're using and the steps you're doing?

Owner

bjorn commented Jun 11, 2017

Hmm, I can't reproduce this. Can you be more specific about the version you're using and the steps you're doing?

@eevee

This comment has been minimized.

Show comment
Hide comment
@eevee

eevee Jun 11, 2017

Oh wait, sorry, I see what happened. I had the collision editor open, which changes the properties dialog to the properties of the tile's object layer, and that can't be bulk-edited (but isn't what I wanted to edit anyway). That's surprising, but I don't know if it's really a UI bug or just the natural result of changing the collision editor to a panel.

I do notice that I can't seem to delete properties from a tile's object layer. The delete and edit buttons are grayed out.

eevee commented Jun 11, 2017

Oh wait, sorry, I see what happened. I had the collision editor open, which changes the properties dialog to the properties of the tile's object layer, and that can't be bulk-edited (but isn't what I wanted to edit anyway). That's surprising, but I don't know if it's really a UI bug or just the natural result of changing the collision editor to a panel.

I do notice that I can't seem to delete properties from a tile's object layer. The delete and edit buttons are grayed out.

@bjorn

This comment has been minimized.

Show comment
Hide comment
@bjorn

bjorn Jun 11, 2017

Owner

That's surprising, but I don't know if it's really a UI bug or just the natural result of changing the collision editor to a panel.

You're not the first to be surprised by this (see issue #1581). I'll probably really need to tweak the UI here in some way, since the only way to notice this is by paying attention to the first line in the Properties view (which says "Object Group" instead of "Tile" when the collision editor is open).

I do notice that I can't seem to delete properties from a tile's object layer. The delete and edit buttons are grayed out.

Maybe running into #1583? The logic for whether these buttons are enabled has become rather complicated... I'll be sure to look into that tomorrow.

Owner

bjorn commented Jun 11, 2017

That's surprising, but I don't know if it's really a UI bug or just the natural result of changing the collision editor to a panel.

You're not the first to be surprised by this (see issue #1581). I'll probably really need to tweak the UI here in some way, since the only way to notice this is by paying attention to the first line in the Properties view (which says "Object Group" instead of "Tile" when the collision editor is open).

I do notice that I can't seem to delete properties from a tile's object layer. The delete and edit buttons are grayed out.

Maybe running into #1583? The logic for whether these buttons are enabled has become rather complicated... I'll be sure to look into that tomorrow.

@bjorn bjorn added the bug label Jun 11, 2017

@eevee

This comment has been minimized.

Show comment
Hide comment
@eevee

eevee Jun 11, 2017

Also, if I create a bool property on multiple tiles at once, it initially appears as a string property with value false. It becomes a checkbox if I reselect the tiles.

eevee commented Jun 11, 2017

Also, if I create a bool property on multiple tiles at once, it initially appears as a string property with value false. It becomes a checkbox if I reselect the tiles.

@bjorn bjorn closed this in 8314ede Jun 12, 2017

@bjorn

This comment has been minimized.

Show comment
Hide comment
@bjorn

bjorn Jun 12, 2017

Owner

Also, if I create a bool property on multiple tiles at once, it initially appears as a string property with value false. It becomes a checkbox if I reselect the tiles.

So, this was due to the property getting set on a selected-but-not-current tile first, and then when it got set on the current tile, it wasn't changing the type of the property correctly. Anyway, will be fixed in the next snapshot / release.

Owner

bjorn commented Jun 12, 2017

Also, if I create a bool property on multiple tiles at once, it initially appears as a string property with value false. It becomes a checkbox if I reselect the tiles.

So, this was due to the property getting set on a selected-but-not-current tile first, and then when it got set on the current tile, it wasn't changing the type of the property correctly. Anyway, will be fixed in the next snapshot / release.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment