Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Scrolling with mouse broken #406

Closed
staxx6 opened this Issue Mar 30, 2013 · 6 comments

Comments

Projects
None yet
3 participants

staxx6 commented Mar 30, 2013

Hello!,

I am new to Tiled and get right on first a problem.^^

If I press the middle button or space for scrolling
the courser change its shape for scrolling. But nothing happen afterwards.
Everything seems freezing and Windows (7) itself dont respond rly to any input (mouse and keyboard). That even give me a hard time to close Tiled per Taskmanager.

Facts:
-Win 7 64bit
-Latest Release and Daily Builds
-Every time
-With map loaded and without

Owner

bjorn commented Mar 30, 2013

Hmm, I never heard of this problem before and have no idea what could cause it. Can you try whether older Tiled versions had this problem too? You can download them at http://sourceforge.net/projects/tiled/files/tiled-qt/

staxx6 commented Mar 30, 2013

0.6.2 is the last one which works. With 0.7.0 the problem occurs again.

Owner

bjorn commented Mar 30, 2013

@staxx6 With 0.7.0, the spacebar scrolling was added. You're saying that with 0.6.2, the middle-mouse scrolling worked fine, but it does not in 0.7.0?

It sounds like something is going wrong with the mouse grabbing, but it's still weird that you're the only one reporting this issue in two years. Does it happen for you on other Windows systems as well? Is there anything noteworthy about your hardware?

Contributor

toddcarnes commented Mar 30, 2013

On 3/30/2013 4:26 PM, Thorbjørn Lindeijer wrote:

@staxx6 https://github.com/staxx6 With 0.7.0, the spacebar scrolling
was added. You're saying that with 0.6.2, the middle-mouse scrolling
worked fine, but it does not in 0.7.0?

It sounds like something is going wrong with the mouse grabbing, but
it's still weird that you're the only one reporting this issue in two
years. Does it happen for you on other Windows systems as well? Is
there anything noteworthy about your hardware?


Reply to this email directly or view it on GitHub
#406 (comment).

I tried it with 64-bit Windows 8 and a freshly built (using QT 5.0.1)
tiled straight from the repository and could not reproduce the problem.

I don't have a Win 7 system I can try it on. I can only try it on 64-bit
Win8 and 64-bit WinXP.

Todd

staxx6 commented Mar 30, 2013

Ah it must be something with the mouse driver. I closed the driver ->Logitech SetPoint and the scrolling worked.
Now I cant restart Setpoint even after a pc restart. Well another bug ...

I will look into this and tell you. Looks like a individual case.

Owner

bjorn commented May 25, 2014

Closing this one since it may indeed have been an individual case. The issue does sound similar to #462, though the means of triggering it is different.

@bjorn bjorn closed this May 25, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment