When using PHP 7 - Control Panel errors and site pages won't load #27

Closed
montabruce opened this Issue Apr 15, 2016 · 0 comments

Comments

Projects
None yet
1 participant
@montabruce

When configuring my host (A2 Shared Hosting) to use PHP 7, SEO Lite generates the following notices in the EE 3 Add-On manager:

Deprecated
Methods with the same name as their class will not be constructors in a future version of PHP; >Seo_lite_upd has a deprecated constructor
user/addons/seo_lite/upd.seo_lite.php, line 14 hide details
Severity: E_DEPRECATED

Notice
Only variables should be assigned by reference
user/addons/seo_lite/upd.seo_lite.php, line 27 hide details
Severity: E_NOTICE

Further, when using PHP 7, pages using the SEO Lite tag will not load. All is well with PHP 5.6 on same host.

EE: 3.2.1
SEO Lite: 1.5.2

screenshot 2016-04-15 07 41 23

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment