Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 23 lines (18 sloc) 0.864 kb
a9d4324e »
2012-02-19 The simplest thing that works
1 # -*- encoding: utf-8 -*-
2 $:.push File.expand_path('../lib', __FILE__)
3 require 'morphine/version'
4
5 Gem::Specification.new do |s|
6 s.name = 'morphine'
7 s.version = Morphine::VERSION
8 s.authors = ['Brandon Keepers']
9 s.email = ['brandon@opensoul.org']
10 s.homepage = ''
11 s.summary = %q{A lightweight dependency injection framework for Ruby}
12 s.description = %q{Morphine is a lightweight dependency injection framework for Ruby. It uses a simple Ruby DSL to ease the pain of wiring your dependencies together.}
13
14 s.rubyforge_project = 'morphine'
15
805bff44 »
2012-03-20 Fix gemspec.
16 s.files = `git ls-files`.split("\n")
17 s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
18 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
a9d4324e »
2012-02-19 The simplest thing that works
19 s.require_paths = ['lib']
20
21 s.add_development_dependency 'rspec', '~>2.0'
22 end
Something went wrong with that request. Please try again.